Supported Hardware/Sound cards

From ReactOS Wiki
Revision as of 21:14, 9 July 2009 by Jedi-to-be (talk | contribs)
Jump to: navigation, search
Supported Hardware/Sound Cards

Please update this page with the status of each soundcard that is tested. Please add a link to the site where the driver was obtained, driver version and OS version. AS YOU CAN SEE, ITS LISTED ALPHABETICALLY, SO PLEASE COMPLY TO THIS ORDER.

Possible statuses

Status Description
Not tested No test has been performed.
Works Works without any major problems
Inaccurate Outdated / insufficient debugging data
Failed Fails to work or crashes ROS

Tested Soundcards

Soundcard Chipset Status Revision Comments Tester Download URL
AC'97 (Avance Logic) ALC100P on KT133a Inaccurate missing No wave-out device. Davy Bartoloni
Aureal Vortex 1 Aureal Vortex AU8810A1 Inaccurate 41368 Drivers: "Aureal Vortex 8810 Audio (WDM)" (XP drivers) - Inf not recognized: 8810 Davy Bartoloni
Aureal Vortex 2 Aureal Vortex AU8830A2 acpxp Inaccurate 41380 Drivers: "Aureal Vortex 8830 Audio (WDM)" (XP drivers) - Inf not recognized: 8830 Davy Bartoloni
Via Ac'97 on notebook Compaq 12XL406A Via AC'97 Inaccurate 41357 Drivers: "Controller audio (WDM) Via AC'97" (XP drivers) - BSOD (ntoskrnl.exe) during installation ( sorry no RS232 on this notebook ) Davy Bartoloni
Via AC'97 on Compaq Presario 1400 Via AC'97 Inaccurate 41351 AC97 XP drivers - Wave-Out device is present, system hangs when a sound is played. ( sorry no RS232 on this notebook ) Davy Bartoloni
Avance Logic Inc. ALS 4000 Rev 1.10 ALS4000 0A096T1 Inaccurate 41380 Installs ok, ROS crashes after restart, see debug log Davy Bartoloni
Avance Logic Inc. ALS 4000 Rev 1.1 ALS4000 04364T2 Inaccurate 41348 Wave Out is present Davy Bartoloni
AT-4000-4 ALS4000 13310Q1 Inaccurate 41380 Installation works, debug log, system hangs during boot debug log Davy Bartoloni
Avance Logic Inc. ALS 4000 Rev 1.1 ALS4000 9B122S1 Inaccurate 41384 Wave Out is present but system crashes when playing a sound ( ALS4000 official driver for XP ) debug log - This bug has been recently fixed, please re-test. Davy Bartoloni
C-Media 8738 CMedia-8738 Works missing Needs custom hacked driver Johannes Anderwald [1]
Creative SoundBlaster PCI 128 CT4700 (5507 5507000101) Works missing Card n°5 on this picture Davy Bartoloni
Creative SoundBlaster PCI 64 (audio PCI 3000) Ensoniq Es1370 Audio PCI 1370-0001-01 Works missing Using Ensoniq ES1370 drivers ( from Creative ) Davy Bartoloni
Creative SoundBlaster PCI 128 CT4750 (CT5880-DEQ) Inaccurate 41368 (copying .sys file on system32\drivers before installation , RARE BSOD during startup, debug installation Davy Bartoloni
Creative SoundBlaster PCI 128 CT4810 (CT2518-DAQ) Inaccurate missing No wave-out device. Davy Bartoloni
Creative SoundBlaster PCI 128 CT4810 (CT5880-DCQ) Inaccurate 41368
  • ---Test1--- No wave-out device.
  • ---Test2--- (Build 41368) Xp native drivers, system hangs during installation debug: creative.audio.pci.es1371.es1373
  • ---Test3--- (Build 41368) FirstQemuTests-Driver (1370 and SB PCI64 ), copying .SYS driver to drivers folder ( trick from Janderwald ) no Wave-Out device: Debug Log: audio.pci.es1371.es1374.wdm
Davy Bartoloni
Creative SoundBlaster PCI 128 ES1373 (1373-0001-02) Failed 41828 Driver installs ok, I cancel gameport installation but ros crashes upon reboot. See ES1371-ES1373 folder from link for debug log and drivers. Gabriel ilardi ES1371-ES1373
Creative SoundBlaster PCI 128 CT4810 ES1373 (1373-0001-04) Inaccurate 41380 XP native drivers, correct installation, but no Wave-Out device debug log Davy Bartoloni
Creative SoundBlaster PCI 512 Creative EMU10K1-SEF Inaccurate 41368 Hang during driver installation, see debug log

Joystick-Port setup debug log

Davy Bartoloni
Crystal SoundFusion unknown Inaccurate 32694 See bug 3138 revision too old, please update
ESS Allegro - ES1988 ES1988 Failed 41828 Ros crashes during installation - See ES1988 folder from link for debug log and drivers. Gabriel ilardi ES1988
SC2000 Ess Allegro 1989S L130 Inaccurate 41348 No wave-out device. Davy Bartoloni
ESS Solo-1 ES1938S D098 Inaccurate 41348 Hang on driver installation (native xp, ESS Solo1 PCI AudioDrive (WDM)), see debug log Davy Bartoloni
Phantom 806 (FM801) ForteMedia FM801-AU Inaccurate missing No wave-out device. Davy Bartoloni
Realtek AC'97 (VIA on board) unknown Inaccurate 40825 Successful installation but Kmixer does not start, driver version A3.90(6120). LinoSP drivers
SoundMAX integrated digital audio Failed 41388 Ros crashes during installation. See SoundMAX folder for debug log and drivers from link. Gabriel ilardi SoundMax
Turtle Beach Montego Vortex AU8820C0 (9903-MBP90) Failed missing Installs fine using XP WDM drivers. Playback is limited to few seconds (Winamp 2.91) then it's cut silent. Haos
VM QEMU AC'97 AC'97 Works missing Works from Qemu 0.10.0 Davy Bartoloni
VM QEMU ES1370 ES1370 Works missing Tested with QEMU 0.9.0 and 0.10.5. See installation instructions. Gabriel ilardi
VM VirtualBox AC'97 AC'97 Works missing This is known to work best atm, see the installation instructions Gabriel ilardi
VM VMWARE SB16 SB16 Works missing See instructions
VM VMWARE ES1371 ES1371 Works missing Broken with VMWare Workstation >= 5.5.2 Didn't work in revisions earlier than 40930. See instructions Gabriel ilardi
Yamaha XG Pci YMF724F-V Failed 41380 debug log: Start-Install-Reboot, no sound from speakers, occasionally, system crashes during sound playback Debug-BT Davy Bartoloni

Notes: Testing

Latest versions of Winamp suffer of an annoying bug in ros that won't let you click on it as if the main window were transparent. I've done some tests and the last "clickable" and "working" version is 1.90. After 1.90 Winamp crashes but its main window is still clickable until 2.08. Special pack for ros made from 2.90 + 2.08 here. Gabriel_it

Debugging

If you can provide a debug log and compile ReactOS from sources, please change NDEBUG to YDEBUG in the following files:

reactos\drivers\wdm\audio\backpln\portcls\private.h
reactos\drivers\wdm\audio\filters\kmixer\kmixer.h
reactos\drivers\wdm\audio\legacy\wdmaud\wdmaud.h
reactos\drivers\wdm\audio\sysaudio\sysaudio.h

You'll need to recompile those modules (make portcls_clean sysaudio_clean, wdmaud_kernel_clean make kmixer_clean)