Difference between revisions of "Supported Hardware/Network cards"

From ReactOS Wiki
Jump to: navigation, search
m (Tested NICs)
(Tested NICs)
Line 39: Line 39:
 
! {{works}}
 
! {{works}}
 
| Works, use Winbond W89C940 drivers, as Compex own have too old inf file.
 
| Works, use Winbond W89C940 drivers, as Compex own have too old inf file.
 +
 +
|-
 +
! style="background: #ececec;" | D-Link DFE-530TX
 +
! {{works}}
 +
| Working with builds >= r40673
  
 
|-
 
|-
Line 44: Line 49:
 
! {{works}}
 
! {{works}}
 
| Tested with rev.40487. Driver installs and works on real hardware.
 
| Tested with rev.40487. Driver installs and works on real hardware.
 +
 +
|-
 +
! style="background: #ececec;" | Intel PRO/1000
 +
! {{works}}
 +
| Works with builds >= r40673 (XP driver files need to be replaced with 2k driver files)
  
 
|-
 
|-
Line 54: Line 64:
 
! {{works}}
 
! {{works}}
 
| Works using our ne2000 driver
 
| Works using our ne2000 driver
 +
 +
|-
 +
! style="background: #ececec;" | Realtek 8139
 +
! {{works}}
 +
| Works with builds >= r40673 using Windows 2000 drivers
 +
 +
|-
 +
! style="background: #ececec;" | VIA Rhine II Fast Ethernet [VIA VT823x]
 +
! {{works}}
 +
| Tested with rev.40674. It installs and works on real hardware, using x86 Windows XP drivers. Others VIA Rhine Family Fast Ethernet might work.
  
 
|-
 
|-
Line 59: Line 79:
 
! {{failed}}
 
! {{failed}}
 
| Tested with rev.40495. It installs but doesn't work. See bug [http://www.reactos.org/bugzilla/show_bug.cgi?id=3796 3796] (see bug 1 below).
 
| Tested with rev.40495. It installs but doesn't work. See bug [http://www.reactos.org/bugzilla/show_bug.cgi?id=3796 3796] (see bug 1 below).
 
|-
 
! style="background: #ececec;" | Intel PRO/1000
 
! {{works}}
 
| Works with builds >= r40673 (XP driver files need to be replaced with 2k driver files)
 
  
 
|-
 
|-
Line 69: Line 84:
 
! {{failed}}
 
! {{failed}}
 
| Install fails.
 
| Install fails.
 
|-
 
! style="background: #ececec;" | Realtek 8139
 
! {{works}}
 
| Works with builds >= r40673 using Windows 2000 drivers
 
 
|-
 
! style="background: #ececec;" | VIA Rhine II Fast Ethernet Adapter [VIA VT823x]
 
! {{works}}
 
| Tested with rev.40674. It installs and works on real hardware, using x86 Windows XP drivers. Others VIA Rhine Family Fast Ethernet Adapters might work.
 
 
|-
 
! style="background: #ececec;" | D-Link DFE-530TX
 
! {{works}}
 
| Working with builds >= r40673
 
 
|}
 
|}
  

Revision as of 08:48, 27 April 2009

Please update this page with the status of each NIC that is tested.

Possible statuses

Status Description
Works Works without any major problems
Failed Fails to work or crashes ROS

Tested NICs

NIC Status Comments
3COM 3C905B-TX-NM Works Tested with rev.40495. You need to expand EL90XBC5.SY_ and copy it to %windir%\system32\drivers. See bug 2634.
ADMtek AN983B Works Tested with rev.40588. It installs and works on real hardware, using Windows 2000 drivers.
AMD PCNet cards Works Works using our pcnet driver
Compex ReadyLINK RL2000-PCI Works Works, use Winbond W89C940 drivers, as Compex own have too old inf file.
D-Link DFE-530TX Works Working with builds >= r40673
HP J2585B 10/100VG Works Tested with rev.40487. Driver installs and works on real hardware.
Intel PRO/1000 Works Works with builds >= r40673 (XP driver files need to be replaced with 2k driver files)
Linksys LNE100TX Works Works with builds >= r40475 using official Windows 2000 drivers
NE2000-compatible cards Works Works using our ne2000 driver
Realtek 8139 Works Works with builds >= r40673 using Windows 2000 drivers
VIA Rhine II Fast Ethernet [VIA VT823x] Works Tested with rev.40674. It installs and works on real hardware, using x86 Windows XP drivers. Others VIA Rhine Family Fast Ethernet might work.
ACCTON EN1207D Failed Tested with rev.40495. It installs but doesn't work. See bug 3796 (see bug 1 below).
Pluscom NGP-RTL8169 Failed Install fails.

Known bugs

1. NdisMRegisterInterrupt gets called with InterruptVector == 0 and InterruptLevel == 0 which causes it to fail.

2. Some INF files have both Windows 2000 and XP sections, with separate drivers for both. When trying to install Win2k driver version, Reactos is being detected as XP, thus XP driver is attempted to be installed, even though its driver file may be missing in Win2k driver directory. As Reactos doesnt fail when copying nonexistant file, successful installation is reported, alas driver file is not copied to system32\driver directory. This will cause "Successful install, please restart" window to appear at every boot.