Talk:Building ReactOS

From ReactOS Wiki
Jump to: navigation, search
Imbox notice.png

Notice: Be careful, you may damage your CPU due possible overheating, while building ReactOS for the first time. Rosbe consumes 100% computing power of ALL your CPU cores.

Ninja is not needed as command btw, you can still use make. It detects which way you set up build by comfigure.cmd and uses the right parser. --[[User::emuandco|emuandco]] 13:42, 17 August 2015

So the link to svn:// does not seem to work. Anyone come up with the same problem? --[[User::victor_m_perez|victor_m_perez]] 17:04, 24 March 2006

Yeah. --SamB 19:25, 24 March 2006 (CET)

Note that viewcvs[1] apparently still works... --SamB 21:15, 24 March 2006 (CET)

make something: to be added in main page.


make something 

might work, in some cases, it can be necessary to

make clean && make something

To verify that the runned ReactOS version match the svn used version check that the «ver» command from «cmd» from running ReactOS gives the same result than «svn info» from build environment. If both versions does not match, you might need to «make clean» before your «make something» command.

Add a note about not having spaces in the ReactOS source pathway?

I was having issues getting RosBE to build and kept getting lots of different errors that weren't quite like issues experienced by others on the forums. I finally happened across this post:

It says that RosBE can't operate when the ReactOS source it's working with has spaces in the path. I was a bit incredulous but I tried renaming the parent directory without spaces, emptying out the build folder and starting again. Bam! It worked (I couldn't believe that this was the source of all the different errors I was getting after running "ninja bootcd"!)

The thing is, this error throws somewhat cryptic, varying errors, so would it be a good idea to include a note in the wiki article on not nesting the ROS source under a directory that's got spaces (e.g. "ReactOS build/sources/reactos")? I'm not sure if it also applies to Linux systems. (I encountered this problem on Windows 7 62-bit, by the way, with RosBE 2.1.1)

Adding a link to (a tutorial that I found very helpful and that a lot of other threads have pointed to in the past) might also be a good idea.

Building Tools step is not needed anymore with RosBe 2.1.3

"Building Tools" step is not needed anymore with RosBe 2.1.3

Replace "Build Environment" link in "See Also" section

In the section "See Also", the link Build Environment should be replaced with the wiki page Build Environment