[ros-dev] Font problem on Japanese version of ReactOS

WaxDragon waxdragon at gmail.com
Thu Oct 13 19:31:17 CEST 2005


Just a followup, GvG's 18424 commit fixed the SBIT issues with some of
our fonts, it may help you too.

On 13 Oct 2005 09:02:02 +0900, tsk <tsk_n at mail.goo.ne.jp> wrote:
> Thank you for telling me that bug.
>
> I tried to use outline mplus, which doesn't include bitmap data:
>  http://reactos-j.sourceforge.jp/up/img/083.png
> and tried to use Mona Font with WaxDragon's freetype.dll:
>  http://reactos-j.sourceforge.jp/up/img/084.png
>
> Modified freetype.dll works well!
>
>
> But I think there still exist some bug with font rendering.
> One of them is a line break. ReactOS automatically insert line feeds
> at space. But Japanese text doesn't use space basically, so ReactOS
> can't insert line feeds to proper position.
>
> Many screenshots:
>  http://reactos-j.sourceforge.jp/up/img/085.zip
>
> > mf suggested one could comment out #define
> > TT_CONFIG_OPTION_EMBEDDED_BITMAPS in
> > lib/freetype/include/freetype/config/ftoption.h to DISABLE the SBIT
> > support.  Doing some quick testing, this allows Helmut 12pt to render
> > "correctly", i.e. readable.  This may or may not help with the CJK
> > font.
> >
> > tsk, if you would like to try, I put up a modified freetype.dll at
> > http://waxdragon.homeip.net/~ford/freetype.dll.  Give that one a try
> > and see if it helps with your fonts.
> >
> > WD
> _______________________________________________
> Ros-dev mailing list
> Ros-dev at reactos.org
> http://www.reactos.org/mailman/listinfo/ros-dev
>


--
<arty> don't question it ... it's clearly an optimization



More information about the Ros-dev mailing list