News: 0.3.13 is in the forge!!Read more..

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

News: 0.3.13 is in the forge!!Read more..

Post by vicmarcal » Wed Feb 16, 2011 12:42 pm

Hi followers, users, and testers!
We are preparing a new release: The 0.3.13 :)

If you look our latest commits you will see that we have just branched to perform a battery of tests with Real Apps.
During the last months ReactOS has been under a heavy rewrite(Memory Manager rewrite, Heap Manager rewrite, Printf rewrite,among others)so we expect new discovered bugs, regressions and (why not?) new apps working!!The release will try to stabilize current trunk after these important changes, something really needed at the current state.But to achieve that we need a really heavy testing.


My personal bet and a "small surprise"
Opensource believes in Distributed developing but also in Distributed Testing. Indeed more, I believe that Forum users, Developers and Testers are in a same ship helping to reach the best ReactOS possible.

You can find our battery of +100 tests here

Just pick 2 or 3, install them in this ISO and tell us if they work or not. It will take just a couple of minutes and it will speed up this heavy testing. We have been around trying to solve all your doubts and questions, hope you can find 4 minutes to help us now.

With your help we can test these +100 apps in just one day (100/2.5 =40 testers)but it would take at least 2 weeks without it. That is the power of Collaborative/Distributed testing.

This is the first time I ask for a Collaborative Testing thingy in a coordinated way, it is my personal bet, so please show out there that you are part(and feel part) of this project too!!


The small surprise:
Those who help on this (plus Devs and all those guys who have sent cool patches) will win a little "recognition reward" which will be available on 4th April. Surprise!Surprise! :)

Summing up
1)Install the ISO
1)Open our battery of +100 tests
2)Select 2 or 3 non-tested apps.
2)Edit the Wiki( "Edit" button) and add if it works or not
3)Answer to this Topic with your Nickname and the 2 Tested Apps. Also tell me if you want to have this small "recognition reward" and if i can make use of your nicknames for it.
4)Thanks :)
Last edited by vicmarcal on Mon Feb 21, 2011 10:46 pm, edited 2 times in total.
Image

wojo664
Posts: 320
Joined: Mon Jul 06, 2009 5:39 pm

Re: News: 0.3.13 is in the forge!!Read more..

Post by wojo664 » Wed Feb 16, 2011 2:20 pm

Hello. Why the wiki stays all blue, even when we edit the fields?

gonzoMD
Posts: 1018
Joined: Fri Oct 20, 2006 7:49 am
Location: Germany
Contact:

Re: News: 0.3.13 is in the forge!!Read more..

Post by gonzoMD » Wed Feb 16, 2011 2:22 pm

hangs at mshtml -.-

wojo664
Posts: 320
Joined: Mon Jul 06, 2009 5:39 pm

Re: News: 0.3.13 is in the forge!!Read more..

Post by wojo664 » Wed Feb 16, 2011 2:25 pm

Just switch to the atapi driver. hm... WORKSFORME as someone said here ;)
PS: Cancel the Gecko engine nag screen :D

Pesho
Posts: 209
Joined: Mon Dec 10, 2007 1:16 pm

Re: News: 0.3.13 is in the forge!!Read more..

Post by Pesho » Wed Feb 16, 2011 3:31 pm

Done! Tested Notepad++, Foxit Reader and aMSN.

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: News: 0.3.13 is in the forge!!Read more..

Post by vicmarcal » Wed Feb 16, 2011 3:32 pm

Pesho wrote:Done! Tested Notepad++, Foxit Reader and aMSN.
Thanks Pesho.. :)
Image

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: News: 0.3.13 is in the forge!!Read more..

Post by vicmarcal » Wed Feb 16, 2011 3:32 pm

wojo664 wrote:Just switch to the atapi driver. hm... WORKSFORME as someone said here ;)
PS: Cancel the Gecko engine nag screen :D
Thanks Wojo for your testing.
Image

Saibamen
Posts: 212
Joined: Mon Jul 19, 2010 11:19 am
Location: Poland
Contact:

Re: News: 0.3.13 is in the forge!!Read more..

Post by Saibamen » Wed Feb 16, 2011 5:35 pm

wojo664 wrote:Just switch to the atapi driver.
How in VBox 4.0.2?
ReactOS Forum Global Moderator
IT-Maniak.pl administrator

mrugiero
Posts: 482
Joined: Sun Feb 14, 2010 9:12 am

Re: News: 0.3.13 is in the forge!!Read more..

Post by mrugiero » Wed Feb 16, 2011 6:01 pm

I think I can test 7-zip, abiword and dosbox, BUT I can do it after friday, because I have an exam for college.

fLuXx
Posts: 76
Joined: Sun Oct 25, 2009 11:42 am

Re: News: 0.3.13 is in the forge!!Read more..

Post by fLuXx » Wed Feb 16, 2011 7:32 pm

Tested AC97 driver and VLC 1.1.5. Will test some more.

Saibamen
Posts: 212
Joined: Mon Jul 19, 2010 11:19 am
Location: Poland
Contact:

Re: News: 0.3.13 is in the forge!!Read more..

Post by Saibamen » Wed Feb 16, 2011 7:56 pm

I test TuxPaint, Firefox 3.6.13 and more (just watch wiki).
Last edited by Saibamen on Wed Feb 16, 2011 8:25 pm, edited 1 time in total.
ReactOS Forum Global Moderator
IT-Maniak.pl administrator

wojo664
Posts: 320
Joined: Mon Jul 06, 2009 5:39 pm

Re: News: 0.3.13 is in the forge!!Read more..

Post by wojo664 » Wed Feb 16, 2011 8:02 pm

How in VBox 4.0.2?
http://www.youtube.com/watch?v=7Qa9Rh5mjHM ;)

You can do this on any VBox and any other Emulation (Virtualization) software ;)

fLuXx
Posts: 76
Joined: Sun Oct 25, 2009 11:42 am

Re: News: 0.3.13 is in the forge!!Read more..

Post by fLuXx » Wed Feb 16, 2011 8:13 pm

Tested Opera 11 and Firefox 3.0.19 and 3.6.13. If you need specific testing, please, contact me. Will do more tests, as I have some spare time now!

mrugiero
Posts: 482
Joined: Sun Feb 14, 2010 9:12 am

Re: News: 0.3.13 is in the forge!!Read more..

Post by mrugiero » Wed Feb 16, 2011 9:18 pm

My summary so far, I continue testing.

Abiword 2.6.8
Graphics glitches and displaying errors.
Plugins work.

Abiword 2.8.6
Same than previous version.

7-zip 9.20
Works, some random crashes.

CCleaner 3.03
Works fine. But after I closed it, the system starts to fail, restarting makes it work again.

DOSBox 0.74
Crashes at startup, install fine.
The error windows says (without program name nor other useless transcript):
"ReactOS C Runtime Library
Assertion failed!
Program (obvious)
File: dll/3rdparty/mesa32/src/drivers/windows/gdi/wmesa.c
Line: 124

Expression: pwfb->cColorBits == 0 || pwfb->cColorBits == 16 || pwfb->cColorBits == 24 || pwfb->cColorBits == 32"
The same says in the DOSBox window.

SCUMMVM
Works OK, tested with Monkey Island. Except it does not answer to me (just keeps reproducing the game like no one is using the computer) after I enter to the game. I'll check in a minute.
EDIT:
I checked, change some config, and it works until I try to open the door of the SCUMM Bar, I think maybe next friday I can make further testing on this, the debug windows says it is another assertion fail, this time in the file sound/mixer.cpp, line 231, expression _mixerReady. With this, the app crashes.

Diablo II Demo
Installer freezes while installing... for a few minutes, then, it finishes what seems to be correctly. In fact, seems to be the launcher the one which fails, since when I try to play the game it freezes the whole system.

Sudoku Portable
Starts, but the graphics fails so heavy it is not usable.

Unreal Commander
Installs OK, but fails to start up.

With this I finish my testing for today, I should be studying :P

On the other hand, shall I do another testing, or just see if it works correctly?

sh4ring4n
Posts: 120
Joined: Thu Oct 30, 2008 2:05 am
Location: Canada
Contact:

Re: News: 0.3.13 is in the forge!!Read more..

Post by sh4ring4n » Thu Feb 17, 2011 2:23 am

Call dibs on Firefox 2! :D
The cake is a lie!

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 1 guest