to anyone accually running this system

Ask your support questions in here

Moderator: Moderator Team

Post Reply

Does this system work ?

Poll ended at Wed Jul 20, 2005 6:03 pm

no
2
11%
yes
12
67%
barely
4
22%
 
Total votes: 18

cyborg01001
Posts: 8
Joined: Sun Jul 10, 2005 8:44 pm
Location: usa

to anyone accually running this system

Post by cyborg01001 » Mon Jul 11, 2005 6:03 pm

I boot up on the cd where i burned the new iso using neros. it boots to blank and stays blank. nothing just
...
the welcome file starts in windows but nothing will boot in dos booting cd.

I burned three times but none would boot and run even though all the files appear to be okay on the cd.
Thats when i downloaded the binaries in order to study them and see what makes the system tic. I do that a lot.
on the boot bat file it saysloadros system32\ntoskrnl.exe system32\hal.dll /DEBUGPORT=BOCHS bootc.lst

it begins the boot1st file which issystem32\drivers\pci.sys
system32\drivers\scsiport.sys
system32\drivers\atapi.sys
system32\drivers\class2.sys
system32\drivers\disk.sys
system32\drivers\vfatfs.sys
system32\drivers\ndis.sys
system32\config\system
system32\ansi.nls
system32\oem.nls
system32\casemap.nls
*

then freezes in dos right there.

Is anyone acually able to use this system?

What file is supposed to boot after casemap?

I need someone else to read the files and see what boots into the system becouse there is no win.exe win.com or any exe capable of booting. :roll:

steveh
Posts: 271
Joined: Sat Dec 18, 2004 10:02 pm

Reactos ISO installing

Post by steveh » Mon Jul 11, 2005 11:15 pm

As you describe the problem and the symptoms of the free, i ask if you have more than one primary partition, or if your active primary partition is NTFS (XP or Win2000)

I had similar experiences:

Actually reactos can only be installed on a primary FAT16 or FAT32, not on NTFS.

Moreover the ISO installer, i think the "setupldr.sys" does not like hdd configs with more than 1 primary partitions, even if the others are inactive and hidden.

For that reason i never succeeded to install Reactos with the ISO bootcd.
However, installing Reactos via compiling/building the SVN sources or the 0.2.6-src... works.

Example:
win2000 on a FAT32 primary partition. Two other win2000'es are each on an inactive NTFS,.

In the FAT32 win2000, install RosBE, build reactos into "c:\reactos", construct "bootsect.ros" manually and copy into c:\
copy also "freeldr.sys" and "freeldr.ini" into c:\.
Add a menu item "c:\bootsect.ros" in "boot.ini".¨

You build reactos by doing "mingw32-make" and "mingw32-make install" in the "reactos" directory of the source tree.

You must also do "mingw32-make bootcd" in order to build a "fat32.bin" (see below)

bootsect.ros = first 80 bytes of partition sector 1 + bytes 81-256 from fat32.bin.
Moreover you MUST copy bytes 257-512 from fat32.bin into sector 15 of the partition.

This "manual boot setup" is more or less similar to one of the important things that "setupldr.sys" would do if it worked.

When this works correctly, the new menu item in boot.ini will boot reactos by using "bootsect.ros" instead of the first sector in the partition. Bootsect.ros + sector 15 contain freeldr's boot program and will boot reactos in the second stage.

This installation workaround is quite complicate but i found no simple alternative. Good luck!

cyborg01001
Posts: 8
Joined: Sun Jul 10, 2005 8:44 pm
Location: usa

thanx alot guy

Post by cyborg01001 » Tue Jul 12, 2005 12:12 am

you gave me the best answers i have recieved in the lanquage i understan. I can definately do the make and make boot thing..
i have fat 32 but my hard disk is really 10 gigs but im only using about four of it becouse there were errors on a portion of it.
But the hard disk i use to install onto is 2500 megs and fat 32.
I did see it the pole a lot of people at least 25 out of 100 are having problems running the os.
Again thanks a lot for your exact advice.

cyborg01001
Posts: 8
Joined: Sun Jul 10, 2005 8:44 pm
Location: usa

Is he still here

Post by cyborg01001 » Thu Jul 14, 2005 1:43 am

Is there a file called bootsect.ros or do ihave to make one by hand?

steveh
Posts: 271
Joined: Sat Dec 18, 2004 10:02 pm

bootsect.ros

Post by steveh » Sun Jul 17, 2005 11:56 pm

>Is there a file called bootsect.ros or do ihave to make one by hand?

There is no pre-made bootsect.ros you can use on the fly. Normally one could think that the first 512 bytes of fat32.bin were one, but it did not work.

When i tried to copy bytes 1-512 into the "bootsect.ros", the partition got defective. I think in the bytes 1-80 of the first sector are stored essential INDIVIDUAL parameters about the partition (size??, cluster size?, absolute position on hdd ??). So you must copy bytes 1-80 from the 1st sector of YOUR partition, followed with bytes 81-512 from fat32.bin

You can use knoppix "dd if=... of=... bs=... count=1", or a commercial software like acronis disk director's "raw" disk edit function for doing this. Knoppix is the simplest, because you don't need install special software, it runs from CD. But the Acronis product also runs from an "emergency recovery cd".

peat
Posts: 27
Joined: Wed Feb 23, 2005 12:36 pm
Location: Rammenau Germany

Post by peat » Mon Jul 18, 2005 9:54 am

Can´t boot SVN builds on real hardware since a few weeks.
Gives me only a inacessible boot device at the first start. :?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests