ReactOS 0.3.7 не работает

Обсуждаем ReactOS по-русски

Moderators: fog, fireball

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

ReactOS 0.3.7 не работает

Post by Jarod » Tue Jan 20, 2009 1:18 pm

Скажите, почему последние релизы напрочь отказываются запускаться или устанавливаться?
При загрузке с boot-cd после самого первого текстового экрана, когда происходит загрузка драйверов, дальше по-идее должно следовать окно для выбора раздела для установки и прочих параметров. А у меня комп зависает намертво, черный экран (при этом монитор находится в режиме on-line) и клавиатура не реагирует ни на какие клавиши.
Конфигурация ПК следующая:
Pentiun Core 2 Duo
1024 Gb RAM
SATA-II 250 Gb HDD
Видео nVidia GeForce 8600GT
Монитор BenQ 19"
Sound - интегрированый.Intel 82801G HD Audio.

Конфигурация другого ПК примерно следующая:
Celeron 2.4 GHz, 512 RAM, EIDE - Samsung 160Gb,
Видео : nVidis GeForce MX440 32 mb RAM, монитор 17" Samtron 78DF

ЧЯДНТ?

П.С. Давние сборки, работали...

NOX86
Posts: 164
Joined: Tue Jun 20, 2006 12:21 pm

Re: ReactOS 0.3.7 не работает

Post by NOX86 » Tue Jan 20, 2009 1:38 pm

SATA не поддерживается. Если очень хочется - установи SATA диск в режим эмуляци IDE

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Re: ReactOS 0.3.7 не работает

Post by Jarod » Tue Jan 20, 2009 8:58 pm

Но второй комп... не с SATA :roll:

hto
Developer
Posts: 2193
Joined: Sun Oct 01, 2006 3:43 pm

Re: ReactOS 0.3.7 не работает

Post by hto » Tue Jan 20, 2009 11:50 pm

Можно соединить оба компа через нуль-модемный кабель, как описано здесь, и посмотреть, что там реактос пишет в последовательный порт при загрузке. А иначе невозможно догадаться, в чём дело.

NOX86
Posts: 164
Joined: Tue Jun 20, 2006 12:21 pm

Re: ReactOS 0.3.7 не работает

Post by NOX86 » Wed Jan 21, 2009 1:45 am

скорее всего некомпатибильная графа nVidia

hto
Developer
Posts: 2193
Joined: Sun Oct 01, 2006 3:43 pm

Re: ReactOS 0.3.7 не работает

Post by hto » Wed Jan 21, 2009 2:03 am

Хм… при первой загрузке с BootCD, используется только обычный VGA режим. Уж не может быть, чтоб nVidia его не поддерживала.

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Re: ReactOS 0.3.7 не работает

Post by Jarod » Thu Jan 22, 2009 12:58 pm

Кое-как удалось установить систему в VirtualBox с iso-образа.
(Неужели все три болванки от разных производителей оказались браковаными :roll: )

Система далеко продвинулась, но все равно мелки глюки есть.
1. FoxitReader-Под значками кнопок на панели виден фон рабочего стола вместо серого цвета окна.
2. Total Commander - на панели упорно не хочет оборажать значки кнопок.
3. Вобще с отрисовкой окон есть проблемы (серый фон после перемещения дочернего окна)
:)... часто падает в синий экран
И не переключается клавиатура.

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Re: ReactOS 0.3.7 не работает

Post by Jarod » Thu Jan 22, 2009 5:22 pm

Единственное, что есть общего между этими компами, это DVD дисковод LG-GSA-4167

Urra
Posts: 14
Joined: Wed Apr 11, 2007 2:21 pm

Re: ReactOS 0.3.7 не работает

Post by Urra » Thu Jan 22, 2009 6:18 pm

Jarod wrote:Кое-как удалось установить систему в VirtualBox с iso-образа.
(Неужели все три болванки от разных производителей оказались браковаными :roll: ).
Любишь экспериментировать? Купи перезаписываемый диск. Серьезно, жаба не будет душить. Я на один и тот же CD-RW чего только не записывал, а он еще жив. И пиши на низкой скорости!

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Re: ReactOS 0.3.7 не работает

Post by Jarod » Thu Jan 22, 2009 11:30 pm

Небольшой флейм, конечно, но под рукой только куча CD-R была.
Но все-таки попробую выяснить, не из-за железа-ли проблемы были... т.к. Nero после прожига проверил диск и ошибок не нашел.

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Обновление :)

Post by Jarod » Wed Feb 25, 2009 11:21 am

Выкачал вчера из SVN bootcd-39743-dbg
Опять тоже самое:
Прошел текстовый этап установки, перезагрузился. В графический режим он так и не зашел.
Конфигурация ПК следующая:
Celeron 2.4 GHz, 512 RAM, EIDE - Samsung 160Gb,
Видео : nVidia AGP GeForce MX440 32 mb RAM, монитор 17" Samtron 78
Монитор потух, мигает лампочка на нем, как будто комп в спящем режиме и всё.

:?: ReactOS вобще AGP поддерживает?

hto
Developer
Posts: 2193
Joined: Sun Oct 01, 2006 3:43 pm

Post by hto » Wed Feb 25, 2009 2:01 pm

Поддерживаются VBE 2.0 и VGA.

Можно попробовать переименовать или удалить файл vbemp.sys в каталоге reactos\system32\drivers. Тогда при следующей загрузке будет использоваться режим VGA.

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Re: ReactOS 0.3.7 не работает

Post by Jarod » Wed Feb 25, 2009 3:46 pm

Получилось!
А теперь как-то драйвера можно поменять, на nVidi'евские?

hto
Developer
Posts: 2193
Joined: Sun Oct 01, 2006 3:43 pm

Post by hto » Wed Feb 25, 2009 4:39 pm

После третьей загрузки обычно появляется диалог с предложением установить драйверы с CD.

Jarod
Posts: 58
Joined: Sun Jan 18, 2009 9:39 pm

Re: ReactOS 0.3.7 не работает

Post by Jarod » Wed Feb 25, 2009 9:48 pm

Я сделал хитро. Когда после перезагрузки появился мастер оборудования, указал ему папку c:\windows\inf. Нашелся сетевой адаптер, Звуковая Creative, Game-Port от нее. А вот видео..
Что-то не срослось. Стоит "Стандартный VGA" (или что-то типа того) и никак не пойму, как его сменить.

П.С. Установленное оборудование пока не проверил. Но в диспетчере устройств оно появилось, что уже радует :)

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest