No USB mouse, keyboard

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Posts: 1
Joined: Fri Nov 02, 2018 3:34 pm

No USB mouse, keyboard

Post by BrunoBL »

Hi All,

I installed ReactOS 0.4.9 both in a VMware virtual machine and also in a real computer.

In each case, I got the same result: the OS does not seem to detect the USB port. This happens not only in the VMware virtual machine, but also in the real computer which incidentally was NOT the same hardware in which the VM ran. In each case, ReactOs failed to detect the USB keyboard and mouse, but I could use a PS2 keyboard without issues, on both. I do not have a PS2 mouse to test, so don't know whether or not it would be detected.

The hardware (mouse, KB) is not at fault, as they work fine in a fresh Windows install on the computer I attempted to run ReactOS, and also in the computer that is host to the VM running ReactOS. Also, different USB mice were tried to no avail.

ReactOS version 0.4.9.
I tried both the LiveCD and installation CD, with identical results.

Any ideas on what might be the problem would be greatly appreciated.

Posts: 510
Joined: Thu Jan 10, 2013 6:17 pm

Re: No USB mouse, keyboard

Post by karlexceed »

USB support in ROS is a bit hit-or-miss right now. There's enough there to do interesting things, but not enough to say that it'll work with even most keyboards/mice.

Here's the general USB entry on the wiki:

The USB mouse via VirtualBox should work. I know from experience that VMware's mouse is... Iffy at best.

I also know that there's a known issue with running the installer with USB devices attached, where it can cause the installer to hang.

Lastly, if you search around the forum, you should find links to download VGal's USB builds. Give one of those a try and see if it changes things for your real hardware testing.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest