Setting up ReactOS in VirtualBox

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Posts: 2
Joined: Fri Aug 26, 2016 10:26 pm

Setting up ReactOS in VirtualBox

Post by runar-orested »

I've tried to set up a ReactOS virtual machine, and I've found a plethora of trouble :( , which I don't know if they are genuine bugs or not. Before raising the bugs if apropiate, I would like all the wisdom/help you guys can spare ;) .

My objetive is to set up ReactOS and for it to detect all posible emulated hardware, and make it a tutorial or at least a driver package that allows full use of it.

To begin with, I'm trying the recomended hardware configuration by ReactOS for Oracle VirtualBox, which is the Windows XP 32 bit default machine configuration. Said configuration matches:
  • A motherboard with a Intel 440FX north brigde / PIIX3 south brigde chipset for Intel Pentium II processors, USB 1.0, PCI and ISA ports, no AGP, no UltraDMA for PATA drives, and no SATA. It is the same emulated motherboard used for QEMU, and a predecesor of the popular Intel 440BX / PIIX4 used in VMware and Virtual PC.
  • A Realtek AC'97 integrated audio chipset
  • A AMD PcNET III network card.
  • A PS/2 keyboard and an USB touchpad
I'm using ReactOS REL 4.2 on VirtualBox 5.1.4, in a Windows 10 x64 host. Hyper-V is disabled and VirtualBox recognices it, since it does allow to set up 64 bit virtual machines.
  1. I install ReactOS from the official REL 4.2 CD-ROM ISO image, setting Spanish language. After rebooting it detects the hardware and reboots again. It hangs loading, in the progress bar.
    FIX: After testing if it is an USB issue, I discover that it is a problem with the emulated touchpad. Switch it for a PS/2 Mouse and boots correctly.
    BUG?: Incompatibility with USB touchpad. It may also mean with other USB pointer devices?
    Unrecogniced hardware: AC adapter device, Unknown Audio device, Unknown system device (PCI\VEN_80EE&DEV_CAFE), Unknown device (\HTREE\ROOT\0)
  2. I install the Guest Additions for Windows (XP/Vista/7/8+) 32 bits. It does recognice the CAFE device, which is is used by the guest additions. Once it works, I can use shared folders to transfer from host to guest the driver files.
  3. I shut down the system and switch the network device to Intel PRO/1000 MT network driver for server. Download the Intel 82540EM driver on the host and share PRO2K3XP_x32 through shared folders. Execute it and it fails.
    BUG?: Can't execute or open/view files in networkd shares, even if mapped (mounted) as local drives.
    FIX: Copy all files to a local (Inside the VM hard disk) directory, like the desktop.
  4. Decompress the exe file and copy it to the desktop via shared folders. Update the driver from \PRO1000\Win32\NDIS5x folder and reboot.
    BUG?: Even if the new network device is recogniced, the old one still appears on the device tree.
    FIX: Reinstall ReactOS after each HW change
  5. Install audio driver for the Realtek AC'97 driver for XP, from the folder 0001-WDM_A406\WDM_A406\WDM.
    BUG?: The driver installation hangs ReactOS as a whole.
  6. Switch audio hardware to Soundblaster. Reinstall to force hardware detection.
    BUG?: It does not recognice the Soundblaster. Possible error on ISA/PNP devices autodetection?
Are the mentioned bugs genuine? Can you reproduce them? Other sugestions?

Posts: 1028
Joined: Tue May 07, 2013 9:18 pm
Location: California, USA

Re: Setting up ReactOS in VirtualBox

Post by middings »

#3, I know ReactOS has problems with Intel's Ethernet controllers on real hardware. CORE-8340, "Intel PRO/100 VE Network Connection network adapter drivers are disabled (Code 31)". I haven't had time to re-investigate this problem since trying r70575 in January 2016.

Posts: 1
Joined: Sat Aug 27, 2016 3:46 am

Re: Setting up ReactOS in VirtualBox

Post by j32 »

So I've been messing/fighting with 0.4.2 in vbox for many hours now, and these are my notes:

This seems to work and prevent it from failing to boot randomly:

MB=PIIX3 + 32bit
Mouse=PS/2 , later tried USB
I/O APIC=off

Install ReactOS with the Standard, not default (detected) CPU

Don't use the Application Manager, download firefox.exe on ubuntu and put it in a folder to convert to iso for mounting via:
~$ genisoimage -o output_firefox_image.iso ./firefox/

Reboot and savestate every couple of seconds, until everything is installed mouse will freeze or system may crash randomly.

Install GuestAdditions

Install MFC,vb5,v6 runtimes

Install AC97 driver, follow these directions ... g_up_audio , it will likely not work the first couple times, just keep rebooting and repeating

If I go to more than 1 or 2 websites in firefox without rebooting the mouse still freezes in place (mouse will exist in two locations) and then it becomes unresponsive, so just keep rebooting until finished.

In the end, USB, Networking, Sound etc should work. You can check networking because if you don't have an ip, ipconfig will just crash, so it it doesn't you are networked.

Try that and see if you can get it working.

Posts: 2
Joined: Fri Aug 26, 2016 10:26 pm

Re: Setting up ReactOS in VirtualBox

Post by runar-orested »

Thanks for the config, but I'm more interested in someone confirming the bugs that make the system non-working.

After all the effort put into make it semi-workable in real hardware in the latest 0.3.x versions, it is prety damn sad having so many new bugs and regresions in the 0.4.x versions :cry: . Also it is not usable to have to reinstall ReactOS for every hardware change or driver update.

For example, the virtual additions are damn useful to import the driver files to the emulated HD, yet they interfere with the detection of the AC'97 hardware. If I uninstall the additions to install the AC'97 driver, the video system stops working because it does not redetects the (S)VGA driver again :shock: , and the screen remains black.

The Intel network drivers are far beter than the PcNET ones, except that they work fine only a few times. If you install them they will ping all right, but the downloader for the applications will fail, so you can't use it to download other drivers or programs, like the browser (that is not included). If you install the pcnet drivers first to make it work, they will interfere with the intel ones when installing them later since they both register as present. :roll:

It's just that it seems that for every step forward there is a matching step back, ReactOS has not progressed much in the last years, and that is awful. Even worse is there that while some money could make it progress faster, there are no good ways for the project to monetice, and donations will not come seeing the lack of progress. The Haiku project does have less problem with that, and the progress rate is envidiable.

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 0 guests