Livecd 56875 dbg setup initialization failed

Ask your support questions in here

Moderator: Moderator Team

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Livecd 56875 dbg setup initialization failed

Post by kayedee »

Hi All, this is my first experience.
Attempted to setup Reactos for first time to learn and later do some testing, setup failed on the Dell Latitude 101L laptop, screen displayed hang at NDIS.SYS, typed cont and blue screen displayed INITIALIZATION FAILED, last line STOP: 0x00000069.
Tried in my other 2 computers, Dell laptop Inspiron 1300 and Custom Desktop with Asrock M3A785GMH, all with same result.
Due to the severity of this bug, I guess it must be being solved as I write, but thought it better to report it here just in case it a regression, as it did appear in Bugzilla some time ago.

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Re: Livecd 56875 dbg setup initialization failed

Post by kayedee »

Have also just tried livecd 0.3.14, (someone posted here that this release worked OK) both failed to setup again on both Dell laptops, same error as follows, (ntoskrnl\io\iomgr\iomgr.c:525)IopCreateArtNames failed: c0000034.
How will I know when this has been fixed, so I can try the new build.

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Re: Livecd 56875 dbg setup initialization failed

Post by SomeGuy »

That STOP: 0x00000069 error message usually means that the UniATA driver doesn't recognize your machines disk controller chipset. Try enabling IDE compatibility in the BIOS and see if that works.

I don't know about the Dell, but at a glance it looks like that Asrock motherboard has an ATI SB700/800 SATA controller which is known to not work unless it is set to IDE compatibility mode.

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Re: Livecd 56875 dbg setup initialization failed

Post by kayedee »

Thanks for your reply,
The Dell laptops are not aware of SATA, bit old for that technology, yes the Asrock has a SB710 chipset, but using IDE HDD on it, so do not think that can be the problem because the same happens on all 3 machines.

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: Livecd 56875 dbg setup initialization failed

Post by Haos »

Its hard to say what happened.Please try revision 56869 to see if the problem lies in new Uniata version. Also please try bootcd, as livecd is grossly untested and might have some bugs unkown to us at the present moment.

If problem persists, you will need to set up debugging on that hardware. The best way would be to use serial port (if present) and serial null modem or serial-usb adapter cables to obtain debug logs - only then we will know what is happening.

milon
Posts: 969
Joined: Sat Sep 05, 2009 9:26 pm

Re: Livecd 56875 dbg setup initialization failed

Post by milon »

Are HDD & CD both on the same IDE channel as master & slave? That's a known issue. The current work-around is to run them both as masters on separate channels.
Oops, nevermind what I wrote here before. That's been fixed.
Last edited by milon on Sat Jul 14, 2012 8:29 pm, edited 1 time in total.

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: Livecd 56875 dbg setup initialization failed

Post by Haos »

That particular issue should be fixed in latest uniata.

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Re: Livecd 56875 dbg setup initialization failed

Post by kayedee »

Thank you all for your suggestions so far.
Update. Tried the latest livecd build 56881 on my custom desktop with the Asrock mobo, after trying tips from posters here saw that with loading in screen mode then revealed failure at USB port 2, which then made me realise that my USB keyboard was not supported, after removing it just after cd booted all went sweet to the desktop, but I am unable to test much from here as there is no download application manager on the livecd, so I am unable to download any apps to try.
Is this normal or is it a problem with this build?
No change with the Dell laptops on this build same error as previous builds, the bootcd is OK with them inside VBox, but I would like to get the livecd to run on the Dell Latitude 110L as this is a spare machine, I will then progress to installing on the HDD for testing the golden apps.
In the meantime I will try the 56869 as Haos suggests, but it will be the livecd version because I do not want to jump to a full install until I know the cd setup runs OK.
Is it possible to expand on this please, how it is done the laptop only has USB ports, but I do have a serial/USB adapter.
"If problem persists, you will need to set up debugging on that hardware. The best way would be to use serial port (if present) and serial null modem or serial-usb adapter cables to obtain debug logs - only then we will know what is happening."

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: Livecd 56875 dbg setup initialization failed

Post by Haos »

I cant help you much with livecd, as i never really tried it.

As for real hardware debugging, unfortunately, you need serial port on the debugee. We dont support debugging over USB yet. There are other options you can explore, like debugging to screen, this should be described on our wiki.

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Re: Livecd 56875 dbg setup initialization failed

Post by kayedee »

Haos,
Tried Livecd r56869, on my Dell laptops, with same result.
I do use the screen mode boot up option, but how can the devs get to see it? I could take a picture of the screen if that would suffice.
Having browsed Bugzilla seems to be bug 6400 would you say it is a duplicate, if so would I be right not to report it?

Dave3434
Posts: 323
Joined: Tue Jun 28, 2011 2:14 am

Re: Livecd 56875 dbg setup initialization failed

Post by Dave3434 »

ros is not ready for real hardware yet.

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: Livecd 56875 dbg setup initialization failed

Post by Haos »

@kayedee

Please do post the screenshot, so we can see what are you getting there. ROS can be tested on real hardware, but without serial cable, this is very difficult.

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Re: Livecd 56875 dbg setup initialization failed

Post by kayedee »

Dave 3434,
ros is not ready for real hardware yet.
As I understand the current position, the project is at the threshold of beta, and the purpose of the livecd is for people to experience reactos on a real machine without harm, and retain their interest with the project, unless we report the issues with real hardware, the bugs will remain, and the people will have moved on with possibly a bad opinion of the project, and the threshold to beta would not be crossed.
I am aware there are issues as we are in alpha, but all hardware bugs need to be made known to progress.

kayedee
Posts: 47
Joined: Fri Jul 13, 2012 10:44 am

Re: Livecd 56875 dbg setup initialization failed

Post by kayedee »

@Haos,
Shall I post image of the screen after typing bt, or without bt.
And how can I attach the image, there is no attachment button to be seen?

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: Livecd 56875 dbg setup initialization failed

Post by Haos »

Please open a bug report and attach it there, with all info you can provide. We will move on from there.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests