USB now works

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

mrugiero
Posts: 482
Joined: Sun Feb 14, 2010 9:12 am

Re: USB now works

Post by mrugiero » Tue Feb 21, 2012 9:31 am

Pisarz wrote:
milon wrote:
Pisarz wrote:It would be great, if I could just plug my USB stick to virtual machine, install the latest revision and boot it up. Saves a lot of time and money (CD's aren't free, are they?)
You don't need CD's for a virtual machine. Just point the virtual machine's CD drive to the ISO file.
I've meant testing ROS on RealHW of course. Preparing an USB stick and booting on RealHW is much different than testing ROS in VM.
I just give new life to an old HDD, and installed ReactOS on it through the VM. Of course, you need to be able to mount real disks on the VM to do that. I know it can be done with qemu on Linux, don't know if there is a way for Windows.

DOSGuy
Posts: 582
Joined: Wed Sep 14, 2011 5:55 pm
Contact:

Re: USB now works

Post by DOSGuy » Tue Feb 21, 2012 6:05 pm

r55780: Start implementing UHCI controller

Yes! USB on Intel and Via controllers is underway!
Today entirely the maniac there is no excuse with the article. Get free DOS, Windows and OS/2 games at RGB Classic Games.

igorko
Posts: 145
Joined: Thu Jun 18, 2009 3:12 pm

Re: USB now works

Post by igorko » Wed Feb 22, 2012 10:33 am

I'll write guide after my new test usb-stick will be fixed under ROS. This bug prevents me from trying LIveCD from usb-stick. And using LiveCD from usb-stick is much better than using bootcd.

fulup
Posts: 25
Joined: Thu Jan 03, 2008 12:11 am
Location: Brest, Bretagne

Re: USB now works

Post by fulup » Wed Feb 22, 2012 8:44 pm

Hi,

I post very rarely but I always follow this great project, keep going Reactos team!

Testing on real hardware, since the merge into trunk of USB, I can't install or boot Reactos without disabling the USB controller in the bios. For install, PS2 keyboard is stucked at first stage at the language selection screen.
With the USB controller enabled, when Reactos boots, it seems too freeze while loading OHCI.
The motherboard is Asrock K7S8X with SIS963L chipset, from what I've found, it is claim to be a OHCI.
Should I open a bug? I got a debug log for r55792...

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: USB now works

Post by vicmarcal » Wed Feb 22, 2012 10:11 pm

Sure!Please report it detailing Host/VM/RealHardware configuration :)
Image

fulup
Posts: 25
Joined: Thu Jan 03, 2008 12:11 am
Location: Brest, Bretagne

Re: USB now works

Post by fulup » Thu Feb 23, 2012 2:31 pm

Done, bug 6924.

igorko
Posts: 145
Joined: Thu Jun 18, 2009 3:12 pm

Re: USB now works

Post by igorko » Sun Mar 04, 2012 6:35 pm


Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests