¿Es un bug ... es una mala implementación ... ?

Moderators: HUMA2000, elhoir

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

¿Es un bug ... es una mala implementación ... ?

Post by xerver » Fri Apr 29, 2011 5:35 pm

¿Qué es un bug ... qué es una mala implementación ... cómo reportarlo?.. Los que comenzamos tenemos más dudas que conocimientos y más ganas de hacer que suerte a la hora de encaminarnos. Gracias a que cuento con vicmarcal pero no quiero molestarlo..por ahora. :D .. Así que recorriendo el menu inicio me sale el siguiente mensaje en una ventana aparte:

unknown Exception: 0x80004005
Context: ShellFolder::ShellFolder(IShellFolder*, LPCITMIDLIST)
Location: base\shell\explorer\utility\shellclasses.cpp:287

Lo que yo interpreto como una excepción desconocida en 0x80004005 dirección de memoria
En la función de iniciación ShellFolder
que se encuentra en base\shell\explorer\utility\shellclasses.cpp número de línea 287

¿esta mal?..¿es un bug?..¿es un problema de implementación?.. ¿sirve de algo reportarlo o es algo en lo que ya se pensó resolverlo en el futuro?..¿es normal este mensaje?...

soy novato.. ¿digo novato?.. ¡novatisimo!...

pda: y le doy aceptar y se molesta y se esfuma el entorno de escritorio... :(

gabrielilardi
Moderator Team
Posts: 873
Joined: Sat Sep 02, 2006 1:30 am
Location: Italy

Re: ¿Es un bug ... es una mala implementación ... ?

Post by gabrielilardi » Fri Apr 29, 2011 6:32 pm

Es un bug ya concido. Mitad de la solucion ha sido implementada, la otra mitad falta.

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Fri Apr 29, 2011 11:47 pm

¿hay alg escrito sobre como enviar bugs?...como revisar si lo que considero un bug ya alguien a trabajado en el... como saber en que partes trabajan actualmente algunos desarrolladores para no estar perdido..

gabrielilardi
Moderator Team
Posts: 873
Joined: Sat Sep 02, 2006 1:30 am
Location: Italy

Re: ¿Es un bug ... es una mala implementación ... ?

Post by gabrielilardi » Sat Apr 30, 2011 12:36 am

xerver wrote:¿hay alg escrito sobre como enviar bugs?...como revisar si lo que considero un bug ya alguien a trabajado en el... como saber en que partes trabajan actualmente algunos desarrolladores para no estar perdido..
Fijate en mi firma para ver como enviar bugs (en inglés), generalmente te conviene mirar en bugzilla, los bugs estan ahi y ves la actividad de la gente que estas trabajado en ellos.
Tambien: http://www.reactos.org/wiki/buglist
Por cualquier cosa, puedes preguntar en el foro o en IRC.

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Sat Apr 30, 2011 12:54 am

He estado googleando buscando la forma de hacer que mi ReactOS en qemu vea una carpeta exterior para poner programas he instalarlos... pero casi he muero en el intento...¿no se puede instalar programas en ReactOS para qemu?... voy a gugzillear... :lol:

nicamarvin2005
Posts: 151
Joined: Tue Jul 06, 2010 12:03 am

Re: ¿Es un bug ... es una mala implementación ... ?

Post by nicamarvin2005 » Sat Apr 30, 2011 10:44 pm

para instalar programas en reactos lo mas conveniente es ponerlos en un ISO y montarlos como CDs, so google Folder2Iso, es un programita muy util, tambien si queres sacar programas o carpetas de Reactos en qemu utiliza un programita llamado WinImage, pero los discos duros tienen que ser .vmdk ya que no se puede con las extenciones nativas de qemu

buena suerte

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Thu May 12, 2011 5:14 pm

Bueno.. hace un par de semanas que tengo el código fuente y el ambiente pero no habia podido hacer nada con ellos.. ayer tuve algo de tiempo he instale el build enviroment .. le copie el código a la carpeta que me creó en document and setting con el nombre reactos... arranque el entorno y en la pantalla verde hice un cd a la carpeta del código fuente .. hice un make .. un make all y todo lo demás.. fui a la página donde explican como compilar pero mi problema no aparece... corri el post instalación que agregó al registro

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell]
"ExecutionPolicy"="RemoteSigned"
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell]
"ExecutionPolicy"="RemoteSigned"

probe otra vez y nada.... hace un par de años me habia hecho de estas mismas cosas y me habia compilado sin problemas... ¿me habré vuelto más bruto con el tiempo..?.. jajajaa.. no lo creo.. :)

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Thu May 12, 2011 5:19 pm

adjunto el LOG

[HOST-CC] tools\rbuild\backend\mingw\mingw.cpp
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::ProcessModules()':
tools\rbuild\backend\mingw\mingw.cpp:254: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:279: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::CheckAutomaticDependenciesForModuleOnly()':
tools\rbuild\backend\mingw\mingw.cpp:323: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:328: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::CreateMakefile()':
tools\rbuild\backend\mingw\mingw.cpp:366: error: 'fopen' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::CloseMakefile() const':
tools\rbuild\backend\mingw\mingw.cpp:377: error: 'fclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateHeader() const':
tools\rbuild\backend\mingw\mingw.cpp:384: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateProjectCFlagsMacro(const char*, const IfableData&) const':
tools\rbuild\backend\mingw\mingw.cpp:398: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:405: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateGlobalCFlagsAndProperties(const char*, const IfableData&) const':
tools\rbuild\backend\mingw\mingw.cpp:421: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateProjectGccOptionsMacro(const char*, IfableData&) const':
tools\rbuild\backend\mingw\mingw.cpp:441: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:454: error: 'fputs' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateGlobalVariables() const':
tools\rbuild\backend\mingw\mingw.cpp:523: error: 'fputs' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:531: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:536: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateAllTarget(const std::vector<MingwModuleHandler*, std::allocator<MingwModuleHandler*> >&) const':
tools\rbuild\backend\mingw\mingw.cpp:590: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateRegTestsRunTarget() const':
tools\rbuild\backend\mingw\mingw.cpp:612: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateXmlBuildFilesMacro() const':
tools\rbuild\backend\mingw\mingw.cpp:625: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:640: error: 'fopen' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:644: error: 'fileno' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:646: error: 'fclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:659: error: 'fclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateTestSupportCode()':
tools\rbuild\backend\mingw\mingw.cpp:686: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateCompilationUnitSupportCode()':
tools\rbuild\backend\mingw\mingw.cpp:697: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateSysSetup()':
tools\rbuild\backend\mingw\mingw.cpp:707: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateProxyMakefiles()':
tools\rbuild\backend\mingw\mingw.cpp:725: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::CheckAutomaticDependencies()':
tools\rbuild\backend\mingw\mingw.cpp:737: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateDirectories()':
tools\rbuild\backend\mingw\mingw.cpp:747: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::DetectCompiler()':
tools\rbuild\backend\mingw\mingw.cpp:770: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'std::string MingwBackend::GetVersionString(const std::string&)':
tools\rbuild\backend\mingw\mingw.cpp:833: error: 'popen' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:836: error: 'feof' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:837: error: 'fgetc' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:843: error: 'pclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'std::string MingwBackend::GetBinutilsVersionDate(const std::string&)':
tools\rbuild\backend\mingw\mingw.cpp:938: error: 'popen' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:941: error: 'feof' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:942: error: 'fgetc' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:948: error: 'pclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::DetectBinutils()':
tools\rbuild\backend\mingw\mingw.cpp:997: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::DetectNetwideAssembler()':
tools\rbuild\backend\mingw\mingw.cpp:1044: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::DetectPipeSupport()':
tools\rbuild\backend\mingw\mingw.cpp:1069: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:1082: error: 'fopen' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:1086: error: 'fclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::DetectPCHSupport()':
tools\rbuild\backend\mingw\mingw.cpp:1101: error: 'printf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:1115: error: 'fopen' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp:1119: error: 'fclose' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::OutputInstallTarget(const FileLocation&, const FileLocation&)':
tools\rbuild\backend\mingw\mingw.cpp:1178: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::OutputRegistryInstallTarget()':
tools\rbuild\backend\mingw\mingw.cpp:1261: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateInstallTarget()':
tools\rbuild\backend\mingw\mingw.cpp:1288: error: 'fprintf' was not declared in this scope
tools\rbuild\backend\mingw\mingw.cpp: In member function 'void MingwBackend::GenerateTestTarget()':
tools\rbuild\backend\mingw\mingw.cpp:1319: error: 'fprintf' was not declared in this scope
make.exe: *** No rule to make target `makefile.auto', needed by `all'. Stop.

Total Build Time: 00:00:05

gabrielilardi
Moderator Team
Posts: 873
Joined: Sat Sep 02, 2006 1:30 am
Location: Italy

Re: ¿Es un bug ... es una mala implementación ... ?

Post by gabrielilardi » Thu May 12, 2011 5:44 pm

Parece que no has descargado del todo el código o que han habido errores durante la descarga. Supongo que estás en Windows. Con esta premisa:

1) Descarga e instala TortoiseSVN.
2) Una vez instalado, vas a una carpeta donde alojarás todo el código de ReactOS, haces click con el botón derecho del mouse, y luego click en SVN Checkout, la url es:

Code: Select all

svn://svn.reactos.org/reactos/trunk/reactos
(mira la guia).
3) Botón derecho sobre il icono de RosBE en el scritorio, propiedades, en el campo "desde:" debes escribir la ruta a donde has descargado el código en el paso anterior, ej.: g:\codigo\reactos\trunk\ (es importante que sea reactos\trunk), aceptas.
4) Doble click en RosBE, tipea: "make bootcd" enter (sin las comillas).

Para aclarar tus dudas es ideal que leas la guia en la wiki, sección "Building".

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Thu May 12, 2011 10:28 pm

He probados tus consejos y nada.. ¿podría ser un problema de permisos en mi win?... como si no encontrara las librerias include del gcc para enlazarse y compilar.. será algo como eso... voy a meter la cabeza a la tina con hielo .. jajajajajaa.. en media hora vere si resuelvo el problem.. thanks...

gabrielilardi
Moderator Team
Posts: 873
Joined: Sat Sep 02, 2006 1:30 am
Location: Italy

Re: ¿Es un bug ... es una mala implementación ... ?

Post by gabrielilardi » Thu May 12, 2011 10:45 pm

xerver wrote:He probados tus consejos y nada.. ¿podría ser un problema de permisos en mi win?... como si no encontrara las librerias include del gcc para enlazarse y compilar.. será algo como eso... voy a meter la cabeza a la tina con hielo .. jajajajajaa.. en media hora vere si resuelvo el problem.. thanks...
Hmmm, windows 7? Prueba a lanzar RosBE con el botón derecho, y "ejectuar como administrador" (o como diga, que no me acuerdo)...

elhoir
Test Team
Posts: 397
Joined: Thu Sep 13, 2007 7:01 pm
Location: Madrid, Spain
Contact:

Re: ¿Es un bug ... es una mala implementación ... ?

Post by elhoir » Fri May 13, 2011 12:11 pm

yo tengo instalado RosBE en Windows 7 y no he tenido ningún problema.... Seguramente no hayas incluído la carpeta correcta de código fuente en la ruta del entorno ....

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Fri May 13, 2011 6:01 pm

Sigo usando XP... lo he ejecutado como Administrador con click derecho y he includido en la variable PATH todas rutas.. desde el código fuente hasta las librerias del compilador.. busque el archivo mingw.cpp y le incluí las librerias stdio.h porque el error me está diciendo fprintf no esta declarada en ese ámbito(scope).. pero si está declarada en stdio, es una función para el trabajo con ficheros, asi que cuando menos no tenia porque seguir repitiendome el mismo error. pero es literalmente el mismo error. ¿Alguna otra idea?..¿Alguien más con el mismo problema?

gabrielilardi
Moderator Team
Posts: 873
Joined: Sat Sep 02, 2006 1:30 am
Location: Italy

Re: ¿Es un bug ... es una mala implementación ... ?

Post by gabrielilardi » Fri May 13, 2011 6:53 pm

Es imposible que en una instalación limpia pase esto, hay algo en tu equipo que no está bien, estas seguro que estás usando RosBE y no mingw? Esto es muy importante, si aún tienes problemas yo desinstalaría verificando que no hayan rastros de instalación e instalaría RosBE nuevamente, tal vez en una ruta diferente para probar...

xerver
Posts: 25
Joined: Thu Apr 24, 2008 8:15 pm

Re: ¿Es un bug ... es una mala implementación ... ?

Post by xerver » Fri May 13, 2011 7:47 pm

Hola.. bueno uso RosBE probe desintalarlo e instalarlo en otra dirección y nada. el mismo error, lo he instalado en otra compu y el mismo error, lo que me confunde es que si el problema fuera del código fuente al incluirle el stdio.h debia reconocer el fprintf y demás que me sale de error como se ve en el log que he pegado arriba... ¿alguien a descargado el RosBE que está en el link de la página de descarga y el código fuente que está ahí también y lo ha probado?..

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests