Preview of 0.3.1

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

oiaohm
Posts: 1322
Joined: Sun Dec 12, 2004 8:40 am

Post by oiaohm »

It does work on real hardware.

Its just extreamly picky. Had a pent 75 running it.

Mrkaras
Posts: 379
Joined: Sat Nov 27, 2004 5:43 am
Location: Australia
Contact:

Works for me

Post by Mrkaras »

I have it working fine on VMware (mustn't be broken anymore). not exactly stable and still has most of its bugs but I can see some improvements and I'm sure there are lots I can't see.

Atari
Posts: 5
Joined: Sat Jan 06, 2007 2:16 pm

Post by Atari »

Z98 wrote:Asked around on IRC and there may be hidden bugs related to removing debugging symbols. This may or may not apply to ROS_LEAN_AND_MEAN, but it would explain problems booting.
thanks for the info. I figured it was some problem with the debugging stuff that gets turned off in ROS_LEAN_AND_MEAN, so I compiled it using default settings (while turning off all debugging in config.rbuild by setting "KDBG", "DBG" and "GDB" to '0') and added -fomit-frame-pointer to the optimizations and it failed just as with ROS_LEAN_AND_MEAN so I guess there's some problem with omitting the frame pointer even though all debugging should be disabled?

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Preview of 0.3.1

Post by PeterK »

Z98 wrote: Preview of 0.3.1:

.. If you do test this build, feel free to mention what programs don't install/run here. ..
Well, fine.

But as mentioned in
http://www.reactos.org/forum/viewtopic.php?t=3517
I miss a fullfeatured way to send feedback.

Cheers, Peter.

Rettung
Posts: 5
Joined: Sat Dec 03, 2005 1:58 pm
Location: Germany, near Frankfurt am Main

Prerelease of ReactOS 0.3.1 available

Post by Rettung »

Prerelease of ReactOS 0.3.1
is available at
http://svn.reactos.org/prereleases/
ReactOS-0.3.1-REL-iso.zip 02-Mar-2007 23:49 18.8M
ReactOS-0.3.1-REL-live.zip 02-Mar-2007 23:54 18.2M
ReactOS-0.3.1-REL-vmware.zip 03-Mar-2007 00:13 17.9M

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Re: Prerelease of ReactOS 0.3.1 available

Post by PeterK »

Just reporting ...
Rettung wrote:Prerelease of ReactOS 0.3.1
ReactOS-0.3.1-REL-iso.zip 02-Mar-2007 23:49 18.8M
... does successfully install on Dell GX 260 (Pentium 4)

On the 3. stage ReactOS tries to identify and install drivers - on this system ReactOS does find NOTHING matching the drivers' hardware ..

On Dell GX 260 the ReactOS Explorer does not see Floppy or CDROM.

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Re: Prerelease of ReactOS 0.3.1 available

Post by PeterK »

Rettung wrote:Prerelease of ReactOS 0.3.1
ReactOS-0.3.1-REL-live.zip 02-Mar-2007 23:54 18.2M
On Dell GX 260 0.3.1 prerelease LiveCD rel does not work.

Probably because VESA driver is in use under LiveCD ?
=> on installation with BootCD I have to select VGA-driver, VESA driver does not work

Is there a possibility to deactivate VESA driver on LiveCD rel ?

GreatLord
Developer
Posts: 926
Joined: Tue Nov 30, 2004 10:26 am
Location: Sweden

Post by GreatLord »

On Dell GX 260 0.3.1 prerelease LiveCD rel does not work.
you graphice card is
Graphics processor: Intel 845G/GL (integrated)



I am reading at http://www.intel.com/support/graphics/sb/CS-004672.htm
"The Intel® Extreme Graphics controllers support VBE 1.2, 2.0 and 3.0. Both linear and banked framebuffer modes are supported"

It mean it does not support real framebuffer it need todo a bankswitch
after each 32kb or 64kb or 128kb depns how u mainboard bios are config

and at http://www.intel.com/support/graphics/sb/CS-004045.htm

I reading the chip does not support framebufer only banked switch and
that is voltations agains 2.0 spec and higher.

Then we start looking at there compatible list for games
http://www.intel.com/support/graphics/i ... 020666.htm

as we can see allot games does not working with this chip as well.

I will never use a intel graphice chip as long I live in my own computer.
they are so bad.

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Post by PeterK »

GreatLord wrote:
On Dell GX 260 0.3.1 prerelease LiveCD rel does not work.
you graphice card is
Graphics processor: Intel 845G/GL (integrated)
...
I will never use a intel graphice chip as long I live in my own computer. they are so bad.
No question - this graphic chip is not for gamers.

But Your personal opinion to badly designed hardware doesn't help me - my main usage of PCs is running music software (Cubase, Emagic Logic, Samplitude, Wavelab, VST Plugins, ...), OpenOffice and Borland Delphi. I don't need fast gaming graphics cards. I much more need at least 2 (slow) video screens parallel !

So again, how can I run ReactOS LiveCD with VGA driver instead of miniport vbemp.sys VESA driver ?
Why does ReactOS make no use of hardware detection in 1st stage and preselect VGA if stuff like Intel 845G/GL is detected ?

Thanks, Peter.

GreatLord
Developer
Posts: 926
Joined: Tue Nov 30, 2004 10:26 am
Location: Sweden

Post by GreatLord »

The problem is we do not detect what type of graphice card.
we do not use pnp for our own graphice card we doing a force install of it.
But does it exists a inf file of a driver with pnp on we are using it instead.
like we do with vmware own driver.

if u which I can guide u how to make vga drv for livecd if u known how to compile reactos it self.

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Post by PeterK »

GreatLord wrote:The problem is we do not detect what type of graphice card.
Please see my PM or Email to You.

SpoonmAn
Posts: 77
Joined: Mon Dec 19, 2005 6:09 pm

Post by SpoonmAn »

I will never use a intel graphice chip as long I live in my own computer.
they are so bad.
how long u alrealy live in your computer? *jokingly*

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Post by PeterK »

GreatLord wrote:if u which I can guide u how to make vga drv for livecd if u known how to compile reactos it self.
I can compile the sources.

Yes, please tell me how to make VGA driver work on LiveCD.

PeterK
Posts: 168
Joined: Mon Aug 07, 2006 9:24 am

Post by PeterK »

Just reporting ...
PeterK wrote:Prerelease II of ReactOS 0.3.1
ReactOS 0.3.1 Branch (r25955) - Installation ISO file
... does successfully install on Dell GX 260 (Pentium 4)

- No more "3 Minutes waittime 'til surface comes up"
- but serial Debug Output shows "ààààààààààààààààààààààààààààààààààààààà"
instead of senseful output (why that?)

--------------------------------------

EDIT: I found out that ReactOS (r25955 PreRelease) serial output speed is 19200 bps instead of the usual 115200 bps !!!
115200 is recommended on: http://www.reactos.org/wiki/index.php/P ... rial_Cable


(The only) Text output is:

Used memory 391620Kb

hto
Developer
Posts: 2193
Joined: Sun Oct 01, 2006 3:43 pm

Post by hto »

The latest trunk works well on my machine (with Intel 845GE graphics processor) using VESA driver (with a small hack).

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot], Bing [Bot], DotBot [Crawler], Semrush [Bot] and 1 guest