Is this boot problem related to SATA?

Ask your support questions in here

Moderator: Moderator Team

Post Reply
fyn
Posts: 4
Joined: Sun Feb 25, 2007 7:30 pm

Is this boot problem related to SATA?

Post by fyn » Sun Feb 25, 2007 7:47 pm

I get the following messages when I boot from 0.3.0 REL install CD:

Failed to read the super block
[OK]

Failed to read the boot sector
[OK][OK]

Unable to locate boot partition
[OK]

Faild to open boot drive
[OK]

Then BIOS let me boot from the next device in the boot device list.

I get similar messages booting from 0.3.0 REL Live CD.

Is the problem related to my SATA drive?
Would it help if I connect the drive to the IDE interface using a converter?

GreyGhost
Posts: 295
Joined: Mon Jun 13, 2005 12:16 pm

Post by GreyGhost » Sun Feb 25, 2007 7:59 pm

Hello.
SATA is not completely implemented with ROS .... (yeah ..tahts why alpha development stage ;) /..its issing a lot of stuff..)
U can try changing the "Legacy device" setting in the BIOS first... hopefully that'll help...
U can also try ROS under a VM in QEMU+kqemu or VMware and such ..
QEMU
QEMU+kqemu
Regards GreyGhost

fyn
Posts: 4
Joined: Sun Feb 25, 2007 7:30 pm

Post by fyn » Sun Feb 25, 2007 9:33 pm

I have checked a previous thread talking about SATA("SATA support - plans?"http://www.reactos.org/forum/viewtopic.php?t=3296). Maybe steveh and you mean the same thing? Unfortunately It seems there is no such setting in my BIOS. I am considering QEMU now.

Thanks for your quick response :)

Post Reply

Who is online

Users browsing this forum: DotBot [Crawler] and 1 guest