[TESTING] Developer request: UNIATA

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

sh4ring4n
Posts: 120
Joined: Thu Oct 30, 2008 2:05 am
Location: Canada
Contact:

Re: [TESTING] Developer request: UNIATA

Post by sh4ring4n »

vicmarcal wrote:Could you create a patch?I'll give it to rafalh or alter to review it :)

Patch is already here :D :http://www.reactos.org/bugzilla/show_bug.cgi?id=6078
Last edited by Saibamen on Tue Apr 26, 2011 11:00 pm, edited 1 time in total.
Reason: URL fixed :)
The cake is a lie!

sh4ring4n
Posts: 120
Joined: Thu Oct 30, 2008 2:05 am
Location: Canada
Contact:

Re: [TESTING] Developer request: UNIATA

Post by sh4ring4n »

Works on Virtualbox :D
The cake is a lie!

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Re: [TESTING] Developer request: UNIATA

Post by SomeGuy »

I finally got around to testing the image with the new UniATA driver. It successfully recognizes and installs to a drive attached to VIA6421 SATA card with no apparent problems. Also tried it on a motherboard SATA with an AMD 770/SV710 chipset, but it did not appear to recognize that at all.

Were there any specific kinds of tests anyone was looking for?

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: [TESTING] Developer request: UNIATA

Post by Haos »

Hiya

Could you perhaps gather debug logs? I wasn't sure on SATA Chipset used in that motherboard of yours, but it seems to be AHCI. Can you see bios if you can set up a single drive in RAID or IDE mode instead?

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Re: [TESTING] Developer request: UNIATA

Post by SomeGuy »

Ok, looking up some more info about the controller in this chipset it seems this is actually an ATI Technologies Inc SB700/SB800 SATA Controller and is apparently not supported by UniATA. (The motherboard is a Biostar A770E3 and "AMD 770/SV710" is what the documentation calls the whole chipset)

If you still want it here is a debug log of ReactOS trying to boot from the SATA Hard drive in the default "Native IDE" mode:

Code: Select all

(ntoskrnl\kd\kdio.c:298) -----------------------------------------------------
(ntoskrnl\kd\kdio.c:299) ReactOS 0.4-SVN (Build 20110415-r51347)
(ntoskrnl\kd\kdio.c:300) Command Line: /DEBUG /DEBUGPORT=COM1 /BAUDRATE=115200 /SOS
(ntoskrnl\kd\kdio.c:304) ARC Paths: multi(0)disk(0)rdisk(0)partition(1) \ multi(0)disk(0)rdisk(0)partition(1) \ReactOS\
(ntoskrnl\ke\i386\cpu.c:501) Supported CPU features : KF_V86_VIS KF_RDTSC KF_CR4 KF_CMOV KF_GLOBAL_PAGE KF_LARGE_PAGE KF_MTRR KF_CMPXCHG8B KF_MMX KF_WORKING_PTE KF_PAT KF_FXSR KF_FAST_SYSCALL KF_XMMI KF_3DNOW  KF_XMMI64  KF_NX_BIT  
(ntoskrnl\ke\i386\cpu.c:808) Prefetch Cache: 64 bytes	L2 Cache: 1048576 bytes	L2 Cache Line: 64 bytes	L2 Cache Associativity: 16
(ntoskrnl\mm\ARM3\mminit.c:1224) HAL I/O Mapping at FFFE0000 is unsafe
(ntoskrnl\ke\i386\kiinit.c:54) Large Page support detected but not yet taken advantage of
(ntoskrnl\ke\i386\patpge.c:46) Global page support detected but not yet taken advantage of
(ntoskrnl\ke\i386\patpge.c:60) PAT support detected but not yet taken advantage of
(ntoskrnl\ke\i386\cpu.c:1081) Support for SYSENTER detected.
(ntoskrnl\ke\i386\mtrr.c:25) MTRR support detected but not yet taken advantage of
(ntoskrnl\mm\mminit.c:243)           0x80000000 - 0x81400000	Boot Loaded Image
(ntoskrnl\mm\mminit.c:247)           0xB0000000 - 0xB0C00000	PFN Database
(ntoskrnl\mm\mminit.c:251)           0xB0C00000 - 0xB4BA0000	ARM³ Non Paged Pool
(ntoskrnl\mm\mminit.c:255)           0xBC000000 - 0xBD000000	System View Space
(ntoskrnl\mm\mminit.c:259)           0xBD000000 - 0xC0000000	Session Space
(ntoskrnl\mm\mminit.c:262)           0xC0000000 - 0xC0300000	Page Tables
(ntoskrnl\mm\mminit.c:265)           0xC0300000 - 0xC0400000	Page Directories
(ntoskrnl\mm\mminit.c:268)           0xC0400000 - 0xC0800000	Hyperspace
(ntoskrnl\mm\mminit.c:272)           0xE1000000 - 0xF2400000	ARM³ Paged Pool
(ntoskrnl\mm\mminit.c:275)           0xF2400000 - 0xF7BE0000	System PTE Space
(ntoskrnl\mm\mminit.c:278)           0xF7BE0000 - 0xFFBE0000	Non Paged Pool Expansion PTE Space
(hal\halx86\generic\legacy\bussupp.c:591) Your machine has a PCI-to-PCI or CardBUS Bridge. PCI devices may fail!
(hal\halx86\generic\legacy\bussupp.c:620) Found parent bus (indicating PCI Bridge). PCI devices may fail!

====== PCI BUS HARDWARE DETECTION =======

00:00.0 Host bridge [0600]: ATI Technologies Inc RX780/RX790 Chipset Host Bridge [1002:5957] (rev 00)
	Subsystem: Unknown [1002:5957]
	Flags: bus master, 66MHz, medium devsel, latency 0
	Memory at e0000000 (64-bit, non-prefetchable) [size=512M]

00:02.0 PCI bridge [0604]:  RD790 PCI to PCI bridge (externa [1002:5978] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: bus master, latency 0, IRQ 10
	Memory at 00010100 (32-bit, non-prefetchable) [size=256]
	I/O ports at 2000d1d0 [size=16]
	Memory at fea0fd00 (32-bit, non-prefetchable) [size=256]
	I/O ports at dff1ce00 [size=512]

00:07.0 PCI bridge [0604]:  RD790 PCI to PCI bridge (PCI exp [1002:597d] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: bus master, latency 0, IRQ 11
	Memory at 00020200 (32-bit, non-prefetchable) [size=512]
	I/O ports at 2000e1e0 [size=32]
	Memory at feb0feb0 (32-bit, non-prefetchable) [size=512]
	I/O ports at fbf1fbf0 [size=16]

00:11.0 IDE interface [0101]:  SB700/SB800 SATA Controller [IDE [1002:4390] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	I/O ports at c000 [size=16K]
	I/O ports at b000 [size=4K]
	I/O ports at a000 [size=8K]
	I/O ports at 9000 [size=4K]
	I/O ports at 8000 [size=32K]
	Memory at fcfff800 (32-bit, non-prefetchable) [size=2K]

00:12.0 USB Controller [0c03]:  SB700/SB800 USB OHCI0 Controller [1002:4397] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 11
	Memory at fcffe000 (32-bit, non-prefetchable) [size=8K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 11
	Memory at fcffd000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcfff000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!

00:13.0 USB Controller [0c03]:  SB700/SB800 USB OHCI0 Controller [1002:4397] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcffc000 (32-bit, non-prefetchable) [size=16K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcffb000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396] (rev 00)
	Subsystem: Unknown [1002:4396]
	Flags: 66MHz, medium devsel, latency 64, IRQ 11
	Memory at fcffa800 (32-bit, non-prefetchable) [size=2K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3c)
	Subsystem: Unknown [1565:3700]
	Flags: 66MHz, medium devsel, latency 0

00:14.1 IDE interface [0101]: ATI Technologies Inc SB700/SB800 IDE Controller [1002:439c] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 0
	I/O ports at 0000	I/O ports at 0000	I/O ports at 0000	I/O ports at 0000	I/O ports at ff00 [size=256]

00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (rev 00)
	Subsystem: Unknown [1565:821f]
	Flags: bus master, fast devsel, latency 64, IRQ 11
	Memory at fcff4000 (64-bit, non-prefetchable) [size=16K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: bus master, 66MHz, medium devsel, latency 64
	Memory at 40030300 (32-bit, non-prefetchable) [size=256]
	Memory at 228000f0 (32-bit, non-prefetchable) [size=8M]
	Memory at 0000fff0 (32-bit, non-prefetchable) [size=256]
	Memory at 0000fff0 (32-bit, non-prefetchable) [size=256]

00:14.5 USB Controller [0c03]:  SB700/SB800 USB OHCI2 Controller [1002:4399] (rev 00)
	Subsystem: Unknown [1002:4396]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcff9000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:18.0 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1200] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.1 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1201] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.2 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1202] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.3 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1203] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.4 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1204] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

01:00.0 VGA compatible controller [0300]:  82562GT-2 10/100 Network Connect [10de:10c3] (rev a2)
	Subsystem: Unknown [1462:2400]
	Flags: bus master, latency 0, IRQ 10
	Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at ce000000 (64-bit, prefetchable) [size=32M]
	I/O ports at d800 [size=2K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!

01:00.1 Audio device [0403]: nVidia Corporation Unknown device [10de:0be3] (rev a1)
	Subsystem: Unknown [1462:2400]
	Flags: bus master, latency 0, IRQ 11
	Memory at fea7c000 (32-bit, non-prefetchable) [size=16K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

02:00.0 Ethernet controller [0200]:  RTL8111/8168B PCI Express Gigabi [10ec:8168] (rev 03)
	Subsystem: Unknown [1565:2309]
	Flags: bus master, latency 0, IRQ 11
	I/O ports at e800 [size=2K]
	Memory at fbfff000 (64-bit, prefetchable) [size=4K]
	Memory at fbff8000 (64-bit, prefetchable) [size=32K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

====== PCI BUS DETECTION COMPLETE =======

PC Compatible Eisa/Isa HAL Detected
(ntoskrnl\io\iomgr\iorsrce.c:882) IoReportResourceUsage is halfplemented!
(hal\halx86\generic\legacy\bussupp.c:1149) Slot assignment for 5 on bus 0
(hal\halx86\generic\legacy\bus\pcibus.c:719) WARNING: PCI Slot Resource Assignment is FOOBAR
(ntoskrnl\io\iomgr\iorsrce.c:882) IoReportResourceUsage is halfplemented!
(ntoskrnl\io\iomgr\driver.c:1540) '\Driver\BUSLOGIC' initialization failed, status (0xc00000c0)
(ntoskrnl\io\iomgr\driver.c:1540) '\Driver\DISK' initialization failed, status (0xc000000e)

*** Fatal System Error: 0x0000007b
                       (0xF7A91B2C,0xC0000034,0x00000000,0x00000000)

[7hEntered debugger on embedded INT3 at 0x0008:0x808fdfbc.
kdb:> 
In the BIOS it has "Native IDE", "RAID", "AHCI", and "Legacy IDE". If I change it to Legacy IDE then ReactOS will boot from the SATA hard drive, but then it can't access or successfully boot the IDE CD-ROM drive. (I had to install ReactOS on the hard drive using a different computer)

In "Native IDE" mode I can boot the IDE CD-ROM and get to the setup program where it will tell me it can not find a hard drive. Same with RAID and AHCI mode.

I'm guessing since "Legacy IDE" mode makes the SATA ports look like IDE to the system, the IDE port changes so it doesn't look like standard IDE anymore.

Here is a log of attempting to boot in "Legacy IDE" mode from the actual IDE CD:

Code: Select all

(ntoskrnl\kd\kdio.c:298) -----------------------------------------------------
(ntoskrnl\kd\kdio.c:299) ReactOS 0.4-SVN (Build 20110415-r51347)
(ntoskrnl\kd\kdio.c:300) Command Line: /NOGUIBOOT /DEBUGPORT=COM1 /FIRSTCHANCE
(ntoskrnl\kd\kdio.c:304) ARC Paths: multi(0)disk(0)cdrom(111) \ multi(0)disk(0)cdrom(111) \reactos\
(ntoskrnl\ke\i386\cpu.c:501) Supported CPU features : KF_V86_VIS KF_RDTSC KF_CR4 KF_CMOV KF_GLOBAL_PAGE KF_LARGE_PAGE KF_MTRR KF_CMPXCHG8B KF_MMX KF_WORKING_PTE KF_PAT KF_FXSR KF_FAST_SYSCALL KF_XMMI KF_3DNOW  KF_XMMI64  KF_NX_BIT  
(ntoskrnl\ke\i386\cpu.c:808) Prefetch Cache: 64 bytes	L2 Cache: 1048576 bytes	L2 Cache Line: 64 bytes	L2 Cache Associativity: 16
(ntoskrnl\mm\ARM3\mminit.c:1224) HAL I/O Mapping at FFFE0000 is unsafe
(ntoskrnl\ke\i386\kiinit.c:54) Large Page support detected but not yet taken advantage of
(ntoskrnl\ke\i386\patpge.c:46) Global page support detected but not yet taken advantage of
(ntoskrnl\ke\i386\patpge.c:60) PAT support detected but not yet taken advantage of
(ntoskrnl\ke\i386\cpu.c:1081) Support for SYSENTER detected.
(ntoskrnl\ke\i386\mtrr.c:25) MTRR support detected but not yet taken advantage of
(ntoskrnl\mm\mminit.c:243)           0x80000000 - 0x81000000	Boot Loaded Image
(ntoskrnl\mm\mminit.c:247)           0xB0000000 - 0xB0C00000	PFN Database
(ntoskrnl\mm\mminit.c:251)           0xB0C00000 - 0xB4BB8000	ARM³ Non Paged Pool
(ntoskrnl\mm\mminit.c:255)           0xBC000000 - 0xBD000000	System View Space
(ntoskrnl\mm\mminit.c:259)           0xBD000000 - 0xC0000000	Session Space
(ntoskrnl\mm\mminit.c:262)           0xC0000000 - 0xC0300000	Page Tables
(ntoskrnl\mm\mminit.c:265)           0xC0300000 - 0xC0400000	Page Directories
(ntoskrnl\mm\mminit.c:268)           0xC0400000 - 0xC0800000	Hyperspace
(ntoskrnl\mm\mminit.c:272)           0xE1000000 - 0xF2400000	ARM³ Paged Pool
(ntoskrnl\mm\mminit.c:275)           0xF2400000 - 0xF7BE0000	System PTE Space
(ntoskrnl\mm\mminit.c:278)           0xF7BE0000 - 0xFFBE0000	Non Paged Pool Expansion PTE Space
(hal\halx86\generic\legacy\bussupp.c:591) Your machine has a PCI-to-PCI or CardBUS Bridge. PCI devices may fail!
(hal\halx86\generic\legacy\bussupp.c:620) Found parent bus (indicating PCI Bridge). PCI devices may fail!

====== PCI BUS HARDWARE DETECTION =======

00:00.0 Host bridge [0600]: ATI Technologies Inc RX780/RX790 Chipset Host Bridge [1002:5957] (rev 00)
	Subsystem: Unknown [1002:5957]
	Flags: bus master, 66MHz, medium devsel, latency 0
	Memory at e0000000 (64-bit, non-prefetchable) [size=512M]

00:02.0 PCI bridge [0604]:  RD790 PCI to PCI bridge (externa [1002:5978] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: bus master, latency 0, IRQ 10
	Memory at 00010100 (32-bit, non-prefetchable) [size=256]
	I/O ports at 2000d1d0 [size=16]
	Memory at fea0fd00 (32-bit, non-prefetchable) [size=256]
	I/O ports at dff1ce00 [size=512]

00:07.0 PCI bridge [0604]:  RD790 PCI to PCI bridge (PCI exp [1002:597d] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: bus master, latency 0, IRQ 11
	Memory at 00020200 (32-bit, non-prefetchable) [size=512]
	I/O ports at 2000e1e0 [size=32]
	Memory at feb0feb0 (32-bit, non-prefetchable) [size=512]
	I/O ports at fbf1fbf0 [size=16]

00:11.0 IDE interface [0101]:  SB700/SB800 SATA Controller [IDE [1002:4390] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 0
	I/O ports at 0000	I/O ports at 0000	I/O ports at 0000	I/O ports at 0000	I/O ports at ff00 [size=256]
	Memory at fec01000 (32-bit, non-prefetchable) [size=4K]

00:12.0 USB Controller [0c03]:  SB700/SB800 USB OHCI0 Controller [1002:4397] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcfff000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcffe000 (32-bit, non-prefetchable) [size=8K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: 66MHz, medium devsel, latency 64, IRQ 11
	Memory at fcffd800 (32-bit, non-prefetchable) [size=2K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

00:13.0 USB Controller [0c03]:  SB700/SB800 USB OHCI0 Controller [1002:4397] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcffc000 (32-bit, non-prefetchable) [size=16K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcffb000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396] (rev 00)
	Subsystem: Unknown [1002:4396]
	Flags: 66MHz, medium devsel, latency 64, IRQ 11
	Memory at fcffd000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3c)
	Subsystem: Unknown [1565:3700]
	Flags: 66MHz, medium devsel, latency 0

00:14.1 IDE interface [0101]: ATI Technologies Inc SB700/SB800 IDE Controller [1002:439c] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	I/O ports at c000 [size=16K]
	I/O ports at b000 [size=4K]
	I/O ports at a000 [size=8K]
	I/O ports at 9000 [size=4K]
	I/O ports at 8000 [size=32K]

00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (rev 00)
	Subsystem: Unknown [1565:821f]
	Flags: bus master, fast devsel, latency 64, IRQ 10
	Memory at fcff4000 (64-bit, non-prefetchable) [size=16K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!

00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d] (rev 00)
	Subsystem: Unknown [1565:3700]
	Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: bus master, 66MHz, medium devsel, latency 64
	Memory at 40030300 (32-bit, non-prefetchable) [size=256]
	Memory at 228000f0 (32-bit, non-prefetchable) [size=8M]
	Memory at 0000fff0 (32-bit, non-prefetchable) [size=256]
	Memory at 0000fff0 (32-bit, non-prefetchable) [size=256]

00:14.5 USB Controller [0c03]:  SB700/SB800 USB OHCI2 Controller [1002:4399] (rev 00)
	Subsystem: Unknown [1002:4396]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
	Memory at fcffa000 (32-bit, non-prefetchable) [size=8K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!
	Device is an OHCI (USB) PCI Expansion Card. Turn off Legacy USB in your BIOS!

00:18.0 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1200] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.1 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1201] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.2 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1202] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.3 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1203] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

00:18.4 Host bridge [0600]:  K10 [Opteron, Athlon64, Sempron] [1022:1204] (rev 00)
	Subsystem: GLoria L [0000:0000]
	Flags: latency 0

01:00.0 VGA compatible controller [0300]:  82562GT-2 10/100 Network Connect [10de:10c3] (rev a2)
	Subsystem: Unknown [1462:2400]
	Flags: bus master, latency 0, IRQ 10
	Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at ce000000 (64-bit, prefetchable) [size=32M]
	I/O ports at d800 [size=2K]
	Device is using IRQ 10! ISA Cards using that IRQ may fail!

01:00.1 Audio device [0403]: nVidia Corporation Unknown device [10de:0be3] (rev a1)
	Subsystem: Unknown [1462:2400]
	Flags: bus master, latency 0, IRQ 11
	Memory at fea7c000 (32-bit, non-prefetchable) [size=16K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

02:00.0 Ethernet controller [0200]:  RTL8111/8168B PCI Express Gigabi [10ec:8168] (rev 03)
	Subsystem: Unknown [1565:2309]
	Flags: bus master, latency 0, IRQ 11
	I/O ports at e800 [size=2K]
	Memory at fbfff000 (64-bit, prefetchable) [size=4K]
	Memory at fbff8000 (64-bit, prefetchable) [size=32K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

====== PCI BUS DETECTION COMPLETE =======

PC Compatible Eisa/Isa HAL Detected
(ntoskrnl\io\pnpmgr\pnpinit.c:403) Need to build DACL
(hal\halx86\generic\legacy\bussupp.c:1149) Slot assignment for 5 on bus 0
(hal\halx86\generic\legacy\bus\pcibus.c:719) WARNING: PCI Slot Resource Assignment is FOOBAR
(ntoskrnl\io\iomgr\iorsrce.c:882) IoReportResourceUsage is halfplemented!
(ntoskrnl\io\iomgr\driver.c:1540) '\Driver\buslogic' initialization failed, status (0xc00000c0)
(ntoskrnl\io\iomgr\driver.c:1540) '\Driver\cdrom' initialization failed, status (0xc000000e)

*** Fatal System Error: 0x00000069
                       (0x00000000,0x00000000,0x00000000,0x00000000)

[7hEntered debugger on embedded INT3 at 0x0008:0x808fdfbc.
kdb:>  
If I had an SATA CD drive instead of mixing SATA and IDE it looks like it would work as long as "Legacy IDE" mode is selected.

BTW, also there seemed to be something odd with the posted ISO image, it wouldn't even get to the ISO loader ("Press any key to boot from CD") on this computer but worked fine on others. I wound up extracting the contents and creating a new bootable ISO using ImgBurn (did not change any files) and then it could get to the setup, at least in Native IDE mode. But whatever that deal is is not UniATA related.

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: [TESTING] Developer request: UNIATA

Post by Haos »

Well, we need debugging fixed first in uniata, then we can try something.

http://www.reactos.org/bugzilla/show_bug.cgi?id=6078

OK, here is debug version of new UNIATA. If you experience issues with normal UNIATA, please try this one and gather logs.

sh4ring4n
Posts: 120
Joined: Thu Oct 30, 2008 2:05 am
Location: Canada
Contact:

Re: [TESTING] Developer request: UNIATA

Post by sh4ring4n »

Haos wrote:Well, we need debugging fixed first in uniata, then we can try something.

http://www.reactos.org/bugzilla/show_bug.cgi?id=6078

OK, here is debug version of new UNIATA. If you experience issues with normal UNIATA, please try this one and gather logs.
To make your lives easier, there's this: http://www.mediafire.com/?vcd5rgzat8c9cek
The cake is a lie!

wojo664
Posts: 320
Joined: Mon Jul 06, 2009 5:39 pm

Re: [TESTING] Developer request: UNIATA

Post by wojo664 »

I'm confirming working uniata driver in VirtualBox 3.1.8 in r51750 on IDE type,
PIIX4 mode. Now I can boot ROS right from the Internet without modifying iso image :-) I can also mount and unmount iso images in VBox on the fly, and read data from them :-) Good Work.

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: [TESTING] Developer request: UNIATA

Post by vicmarcal »

Patch has been commited to trunk.So testings can be done now in Trunk.Thanks for your testings!:)

ale5000
Posts: 9
Joined: Thu Apr 19, 2007 11:06 pm

Re: [TESTING] Developer request: UNIATA

Post by ale5000 »

Hi,
I see that almost one year has passed from last UniATA update.
What is happened?

PS: I can test it on real hardware.

hbelusca
Developer
Posts: 1164
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: [TESTING] Developer request: UNIATA

Post by hbelusca »

ale5000 wrote:
Fri Feb 07, 2020 12:19 pm
Hi,
I see that almost one year has passed from last UniATA update.
What is happened?
Well.... maybe because there is nothing to update? :lol: :lol:
http://alter.org.ua/soft/win/uni_ata/
Updated 2019.04.03
To get previous stable version - v 0.46d8 click here
Current version - v 0.47a

ale5000
Posts: 9
Joined: Thu Apr 19, 2007 11:06 pm

Re: [TESTING] Developer request: UNIATA

Post by ale5000 »

Eh eh :)
It would be nice if it were so but we aren't yet at this point; I hope to help for this.

Post Reply

Who is online

Users browsing this forum: DotBot [Crawler] and 8 guests