WordPress Version 5.0 For Website Development

If it doesn't fit anywhere else, drop it in here. (not to be used as a chat/nonsense section)

Moderator: Moderator Team

Post Reply
youngg50
Posts: 2
Joined: Tue Nov 27, 2018 7:06 am
Location: California City, CA
Contact:

WordPress Version 5.0 For Website Development

Post by youngg50 »

The biggest change users are about to witness in the WordPress 5.0 is the default editor. But the question is it safe for website? Actually I need some guidance for that either I should upgrade my Wordpress Version or the version 3.5 that I am using currently.

User avatar
EmuandCo
Developer
Posts: 4425
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: WordPress Version 5.0 For Website Development

Post by EmuandCo »

Quite a bit the wrong forum to ask that I would say. Please reply to verify that you are no bot btw.
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

youngg50
Posts: 2
Joined: Tue Nov 27, 2018 7:06 am
Location: California City, CA
Contact:

Re: WordPress Version 5.0 For Website Development

Post by youngg50 »

EmuandCo wrote:
Wed Apr 17, 2019 8:18 pm
Quite a bit the wrong forum to ask that I would say. Please reply to verify that you are no bot btw.
I am not a bot in real.

justincase
Posts: 441
Joined: Sat Nov 15, 2008 4:13 pm

Re: WordPress Version 5.0 For Website Development

Post by justincase »

@youngg50 Sorry to say, but your message does seem very bot-like.

Anyway, assuming you're a real person, and you're still using WordPress version 3.5 as indicated by your first message, PLEASE update to the latest version.
Yes the interface has changed a bit since version 3.5, but it's not that hard to get used to the new versions, and if you don't like the 'Gutenberg' editor added in version 5.x, you can always switch to the plain-text editor to do your editing more similar to how you're used to, though I think you have to do so every time you want to edit a post/page. The important bit though, is that there are many security issues in WordPress 3.5 that will never be fixed because it's not supported any more. Running such an old version of WordPress, you're almost guaranteed to get hacked. It may not be right away, but it's extremely likely, as there are so many security issues with old versions of WordPress that hackers can easily identify with a quick scan across many sites, and then they can easily take over your website.
I reserve the right to ignore any portion of any post if I deem it not constructive or likely to cause the discussion to degenerate.

Lewis-H
Posts: 14
Joined: Fri Nov 22, 2019 10:07 am
Contact:

Re: WordPress Version 5.0 For Website Development

Post by Lewis-H »

For now, 3.5 version will be okay but after couple of years, you have to update to 5.0 or else your website will be out-dated. You won't be able to use new features as well.
Regards,
Lewis

gardencrafted
Posts: 1
Joined: Wed Aug 12, 2020 6:50 pm
Contact:

Re: WordPress Version 5.0 For Website Development

Post by gardencrafted »

I'm using the latest version. It is past 5.0 now at 5.5

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests