EPIC WIN!

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

MadWolf
Posts: 544
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: EPIC WIN!

Post by MadWolf »

Illen wrote:
Wed Oct 17, 2018 2:51 pm
hbelusca wrote:
Tue Oct 16, 2018 11:31 pm
Heh cool :D Now, can you test *Microsoft* Virtual PC 2004, or 2007, in ReactOS? (they should be available somewhere for download.)
Already tried these, couldn't get them working. They are complaining about missing MSXML 4/6, even though I have it already installed. I will report all the Virtual PC related issues to Jira soon.
when you get the error missing MSXML 4/6 are you getting this during the install or when you start the application

i think i may have a fix for the missing MSXML 4/6 error but i need to look in to it

hbelusca
Developer
Posts: 1154
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: EPIC WIN!

Post by hbelusca »


MadWolf
Posts: 544
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: EPIC WIN!

Post by MadWolf »

hi
i have a workaround to fix the problem
the problem is reactos ships withe an incompatible version of msxml4.dll msxml4a.dll msxml4r.dll and the installer may be installing the DLL file in the to \reactos\System or it may be failing to replace the dll files but when Virtual PC 2004 is starting it is using the incompatible version you need to manually replace msxml4.dll msxml4a.dll msxml4r.dll if you are using the install file from
https://winworldpc.com/product/virtual-pc/2004
you need to copy the files from the System folder on the iso to \reactos\System32 and replace the existing files

User avatar
binarymaster
Posts: 325
Joined: Sun Nov 16, 2014 7:05 pm
Location: Russia, Moscow
Contact:

Re: EPIC WIN!

Post by binarymaster »

MadWolf wrote:
Sat Oct 20, 2018 12:58 am
hi
i have a workaround to fix the problem
But that was already known in the JIRA ticket comments. :|

MadWolf
Posts: 544
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: EPIC WIN!

Post by MadWolf »

after using the workaround to fix the problem Virtual PC 2004 starts but you can not create a new virtual machine

PurpleGurl
Posts: 1788
Joined: Fri Aug 07, 2009 5:11 am
Location: USA

Re: EPIC WIN!

Post by PurpleGurl »

I think we need to get this thread back on topic.

Illen
Posts: 34
Joined: Mon Feb 20, 2017 7:12 pm

Re: EPIC WIN!

Post by Illen »

Partial Epic Win, it does freeze quite often.
m3N2nRm.png
m3N2nRm.png (210.54 KiB) Viewed 180 times
zkzvf30.png
zkzvf30.png (39.55 KiB) Viewed 180 times
IxBnzlh.png
IxBnzlh.png (59.71 KiB) Viewed 180 times
Note: Big pool table extension from PR#860 is needed in order to install and run Visual Studio 2010 on ReactOS. In addition, Samba (the NTLM auth provider) from rapps is required to run Visual Studio IDE.
MadWolf wrote:
Sat Oct 20, 2018 2:42 am
after using the workaround to fix the problem Virtual PC 2004 starts but you can not create a new virtual machine
You can create a virtual machine, it is still possible to go through the broken wizard dialogs, you might need to import the virtual hard drive though.
pcTk4uo.png
pcTk4uo.png (241.38 KiB) Viewed 180 times
EDIT: Not possible to build ReactOS in ReactOS using the MSVC compiler, see CORE-15246
Last edited by Illen on Sat Mar 28, 2020 1:13 pm, edited 1 time in total.

Illen
Posts: 34
Joined: Mon Feb 20, 2017 7:12 pm

Re: EPIC WIN!

Post by Illen »

PowerStrip 3.90 on ReactOS. Most of the functionality (including GPU overclocking) appears to work.
oT3arFw.png
oT3arFw.png (121.73 KiB) Viewed 180 times
And the HWiNFO screenshot showing a TNT2 GPU overclocked.
0QBitWc.png
0QBitWc.png (103.91 KiB) Viewed 180 times
As you may have noticed, ReactOS is installed on real hardware, if anyone wonders about the specifications:
ASrock P4Dual-915GL
Intel Pentium 4 2.40A @ 3.1GHz
1.5 GB DDR400 RAM
NVidia RIVA TNT2 M64 32 MB GPU (with NVidia 52.16 driver from rapps installed)
NVidia RIVA 128 PCI (not used)
Realtek AC'97 Audio
Last edited by Illen on Sat Mar 28, 2020 1:09 pm, edited 1 time in total.

User avatar
dizt3mp3r
Posts: 1520
Joined: Mon Jun 14, 2010 5:54 pm

Re: EPIC WIN!

Post by dizt3mp3r »

Good one Illen!
Skillset: VMS sysadmin 20 years, fault Tolerance, cluster, Vax, Alpha, ftSparc. DCL, QB45, VB6, NET, PHP, JS, CMS, Graphics, Project Manager, DOS, Windows admin from 1985. Quad Electronics. Classic cars & motorbikes. Artist watercolours. Historian.

Illen
Posts: 34
Joined: Mon Feb 20, 2017 7:12 pm

Re: EPIC WIN!

Post by Illen »

dizt3mp3r wrote:
Tue Dec 04, 2018 1:21 pm
Good one Illen!
Thank you :)

ThrottleStop 8.70.2 on ReactOS, appears to be mostly functional, the CPU settings and voltage control are all working fine.
wVWHnB5.png
wVWHnB5.png (278.88 KiB) Viewed 157 times
Detects only one core because ReactOS doesn't really support SMP (Multiprocessing).
Tested on ReactOS 0.4.12 dev build with VGal patches applied (installed on USB drive).

Notebook specifications:
Lenovo Y50-70
Intel Core i7 4710HQ
16 GB DDR3L 1600 RAM
Intel HD Graphics 4600 iGPU
NVidia GeForce GTX 860M dGPU
Realtek HD Audio
Last edited by Illen on Thu Apr 02, 2020 7:30 pm, edited 2 times in total.

User avatar
Oleg Dubinskij
Posts: 21
Joined: Mon Aug 07, 2017 6:34 pm

Re: EPIC WIN!

Post by Oleg Dubinskij »

Aimp 2.61 plays sound correctly with replaced dsound.dll from win2k3 in fresh ReactOS nightly build! :D Although sometimes may appear an application error upon Aimp startup, but it doesn't interfere with the program's work. Earlier it crashed with this replaced dll. Without replacing, appeared error 23 (Can't initialize sound engine), same as now. See video: https://youtu.be/dcCUYksQw7M

manuel
Posts: 406
Joined: Thu Jan 28, 2010 11:20 pm
Location: México
Contact:

Re: EPIC WIN!

Post by manuel »

CDBurnerXP working very good (requiere .NET Framework 2.0 previous, setup too fine) 8-)
[ external image ]

gonzoMD
Posts: 1040
Joined: Fri Oct 20, 2006 7:49 am
Location: Germany
Contact:

Re: EPIC WIN!

Post by gonzoMD »

manuel wrote:
Tue Feb 12, 2019 7:46 am
CDBurnerXP working very good (requiere .NET Framework 2.0 previous, setup too fine) 8-)
[ external image ]
Did you run on RealHw and try to burn a CD?

manuel
Posts: 406
Joined: Thu Jan 28, 2010 11:20 pm
Location: México
Contact:

Re: EPIC WIN!

Post by manuel »

gonzoMD wrote:
Tue Feb 12, 2019 8:25 am
Did you run on RealHw and try to burn a CD?
No, it was only tested on VirtualBox, in fact my computer don't have a CD/DVD reader, I can't test on real hardware.

oldman
Posts: 1078
Joined: Sun Dec 20, 2009 1:23 pm

Re: EPIC WIN!

Post by oldman »

manuel wrote:
Tue Feb 12, 2019 4:45 pm
No, it was only tested on VirtualBox, in fact my computer don't have a CD/DVD reader, I can't test on real hardware.
Then it is not an epic win. InfraRecorder (tested a month or so ago) runs but does not find a CD burner, though the computer has 2 drives, so it is not an epic win.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 12 guests