0.4.8 Testing

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
Heis Spiter
Posts: 183
Joined: Sun Sep 03, 2006 11:39 am
Location: Paris, France
Contact:

0.4.8 Testing

Post by Heis Spiter » Sat Feb 24, 2018 9:05 pm

We have another release coming up! Please support us in testing for regressions.

https://reactos.org/wiki/Tests_for_0.4.8

Thanks!
Pierre Schweitzer (aka Heis Spiter)
ReactOS kernel developer.
ReactOS systems administrator.

Zombiedeth
Posts: 116
Joined: Fri Jun 27, 2014 9:01 am

Re: 0.4.8 Testing

Post by Zombiedeth » Wed Feb 28, 2018 5:27 pm

Where can we get ReactOS 0.4.8 for testing?

hbelusca
Developer
Posts: 1132
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: 0.4.8 Testing

Post by hbelusca » Wed Feb 28, 2018 6:06 pm

Zombiedeth wrote:Where can we get ReactOS 0.4.8 for testing?
Read the wiki page.

gonzoMD
Posts: 1021
Joined: Fri Oct 20, 2006 7:49 am
Location: Germany
Contact:

Re: 0.4.8 Testing

Post by gonzoMD » Wed Feb 28, 2018 6:06 pm

Zombiedeth wrote:Where can we get ReactOS 0.4.8 for testing?
https://sourceforge.net/projects/reacto ... p/download

ctasan
Posts: 384
Joined: Mon Feb 24, 2014 7:02 pm
Location: Istanbul, Turkey

Re: 0.4.8 Testing

Post by ctasan » Wed Feb 28, 2018 10:43 pm

Strangely, Phoronix didn't make news about ReactOS 0.4.8-RC1.

jkroylance
Posts: 1
Joined: Sat Jun 20, 2009 8:07 am

Re: 0.4.8 Testing

Post by jkroylance » Thu Mar 01, 2018 6:51 am

I installed ReactOS 0.4.8 RC in VirtualBox but when I run ReactOS Application Manager I get an "SSL certificate verification failed" error. Anyone else come across this problem or any way to fix it?

Edit: Disregard this post, I may or may not have been running an 0.4.7 image. (I was, I don't know how I overlooked that...)

linrx
Posts: 9
Joined: Fri May 19, 2017 4:09 pm
Location: Singapore

Re: 0.4.8 Testing

Post by linrx » Sun Mar 04, 2018 7:09 am

Am new, might pop by in support of future releases of ReactOS though at this time am here at best as an observor. Have downloaded the iso in a compressed zip file.

tojestzart
Posts: 7
Joined: Fri Dec 08, 2017 1:15 am

Re: 0.4.8 Testing

Post by tojestzart » Sat Mar 10, 2018 4:29 am

reactos-livecd-0.4.9-dev-208-gdedd08c-x86-gcc-lin-dbg

doesnt allow to execute any exe file, stack for ntfs/fat is broken when im trying to see user downloaded folder (windows 7 [46,8 GB (bajtów: 50 327 597 919)]) - causes hang up.
tried aswell to install centrino 2230 exes [ internet access] - dead 1st case browsed partition wheres ntfs, second case burned files WiFi_WinXP_32_15.8.0 , BT_WinXP_32_3.0.1302 together with reactos - same result .exe files arent executing.

U need something to fix under ram management, regards
ps. acutally i can see huge progress, i can see desktop screen, and usb stack doesnt blueing it (or before stages)

reactos-bootcd-0.4.9-dev-212-g516c5a9-x86-gcc-lin-dbg
my bios/uefi yelling not active partition found after installation (both bootloaders dead )
sometime ago driver from reactos for fat system made mess under disk - crystaldiskinfo was saying my hard drive its almost dead , wheres not - needs to be confirmed

type47
Posts: 6
Joined: Sun Oct 25, 2015 9:09 am

Re: 0.4.8 Testing

Post by type47 » Sat Mar 10, 2018 11:53 pm

I just downloaded a ReactOS installation ISO and attempted to start it in Virtual PC 2004. After double checking, I realized that it is 0.4.7. Why does the ReactOS front page link to 0.4.7 if there is already a 0.4.8 or 0.4.9? In any case, trying to boot resulted in a brief message about loading files and then frozen at a black screen. The following logs were written to the serial ports:

Code: Select all

(../../ntoskrnl/kd/kdio.c:104) -----------------------------------------------------
(../../ntoskrnl/kd/kdio.c:105) ReactOS 0.4.7 (Build 20171124-0.4.7-release) (Commit 31794c27eb2b6a3187521666055faa9e3ef7958b)
(../../ntoskrnl/kd/kdio.c:106) 1 System Processor [255 MB Memory]
(../../ntoskrnl/kd/kdio.c:107) Command Line: NOGUIBOOT KDSERIAL DEBUGPORT=COM1 FIRSTCHANCE
(../../ntoskrnl/kd/kdio.c:108) ARC Paths: multi(0)disk(0)cdrom(111) \ multi(0)disk(0)cdrom(111) \reactos\
(../../ntoskrnl/ke/i386/cpu.c:450) Supported CPU features : KF_V86_VIS KF_RDTSC KF_CR4 KF_CMOV KF_GLOBAL_PAGE KF_LARGE_PAGE  KF_CMPXCHG8B KF_MMX KF_WORKING_PTE  KF_FXSR KF_FAST_SYSCALL KF_XMMI   KF_XMMI64    
(../../ntoskrnl/ke/i386/cpu.c:722) Prefetch Cache: 64 bytes	L2 Cache: 1048576 bytes	L2 Cache Line: 64 bytes	L2 Cache Associativity: 16
(../../ntoskrnl/mm/mminit.c:134)           0x80000000 - 0x83000000	Boot Loaded Image
(../../ntoskrnl/mm/mminit.c:138)           0xB0000000 - 0xB01C0000	PFN Database
(../../ntoskrnl/mm/mminit.c:142)           0xB01C0000 - 0xB0970000	ARM3 Non Paged Pool
(../../ntoskrnl/mm/mminit.c:146)           0xB9400000 - 0xBB400000	System View Space
(../../ntoskrnl/mm/mminit.c:150)           0xBB400000 - 0xC0000000	Session Space
(../../ntoskrnl/mm/mminit.c:153)           0xC0000000 - 0xC03FFFFF	Page Tables
(../../ntoskrnl/mm/mminit.c:156)           0xC0300000 - 0xC0300FFF	Page Directories
(../../ntoskrnl/mm/mminit.c:159)           0xC0400000 - 0xC07FFFFF	Hyperspace
(../../ntoskrnl/mm/mminit.c:163)           0xE1000000 - 0xED000000	ARM3 Paged Pool
(../../ntoskrnl/mm/mminit.c:166)           0xF4C00000 - 0xFA3D9000	System PTE Space
(../../ntoskrnl/mm/mminit.c:169)           0xFA3D9000 - 0xFFBE0000	Non Paged Pool Expansion PTE Space
(../../ntoskrnl/config/cmhvlist.c:158) CmpAddToHiveFileList: Creation or opening of the hive list failed, status = 0xc0000034
(../../hal/halx86/legacy/bussupp.c:717) Found parent bus (indicating PCI Bridge). PCI devices may fail!

====== PCI BUS HARDWARE DETECTION =======

00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) [8086:7192] (rev 03)
	Subsystem: Unknown [0000:0000]
	Flags: bus master, medium devsel, latency 0

00:07.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (rev 01)
	Subsystem: Unknown [0000:0000]
	Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01)
	Subsystem: Unknown [0000:0000]
	Flags: bus master, medium devsel, latency 0
	I/O ports at ffa0 [size=32]

00:07.2 Non-VGA unclassified device [0000]:  Unknown device [0000:0000] (rev 00)
	Subsystem: Unknown [0000:0000]
	Flags: medium devsel, latency 0, IRQ assignment required

00:07.3 Secondary bus towards host CPU [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 02)
	Subsystem: Unknown [0000:0000]
	Flags: medium devsel, latency 0, IRQ assignment required

00:08.0 VGA compatible controller [0300]: S3 Graphics Ltd. 86c764/765 [Trio32/64/64V+] [5333:8811] (rev 00)
	Subsystem: Unknown [0000:0000]
	Flags: bus master, fast devsel, latency 0
	Memory at f8000000 (32-bit, non-prefetchable) [size=128M]

00:0a.0 Ethernet controller [0200]: Digital Equipment Corporation DECchip 21140 [FasterNet] [1011:0009] (rev 20)
	Subsystem: Unknown [0a00:2114]
	Flags: bus master, medium devsel, latency 64, IRQ 11
	I/O ports at ec00 [size=1K]
	Memory at febff000 (32-bit, non-prefetchable) [size=4K]
	Device is using IRQ 11! ISA Cards using that IRQ may fail!

====== PCI BUS DETECTION COMPLETE =======

PC Compatible Eisa/Isa HAL Detected
(../../ntoskrnl/io/pnpmgr/pnpinit.c:62) WARNING!! In PiInitCacheGroupInformation, using ReactOS HACK for SETUPLDR!!
(../../ntoskrnl/io/pnpmgr/pnpmgr.c:3288) ZwOpenKey(\Registry\Machine\SYSTEM\CURRENTCONTROLSET\Control\Pnp) failed with status 0xc0000034
(../../ntoskrnl/ps/apphelp.c:318) SHIMS: ApphelpCacheRead could not even open Session Manager\AppCompatCache (0xc0000034)
(../../sdk/lib/rtl/image.c:171) Invalid base address: 00000000
(../../ntoskrnl/io/iomgr/driver.c:1576) '\Driver\sacdrv' initialization failed, status (0xc0000037)
(../../ntoskrnl/io/iomgr/driver.c:64) Deleting driver object '\Driver\sacdrv'
(../../drivers/storage/scsiport/scsiport.c:5859) ZwOpenKey() failed with Status=0xC0000034
(../../hal/halx86/legacy/bussupp.c:1253) Slot assignment for 5 on bus 0
(../../hal/halx86/legacy/bus/pcibus.c:727) WARNING: PCI Slot Resource Assignment is FOOBAR
(../../ntoskrnl/io/iomgr/iorsrce.c:874) IoReportResourceUsage is halfplemented!
(../../ntoskrnl/io/iomgr/iorsrce.c:874) IoReportResourceUsage is halfplemented!
(../../ntoskrnl/io/iomgr/driver.c:1576) '\Driver\buslogic' initialization failed, status (0xc00000c0)
(../../ntoskrnl/io/iomgr/driver.c:64) Deleting driver object '\Driver\buslogic'
(../../drivers/storage/port/storport/storport.c:858) StorPortInitialize(B06E0CC8 F9C40A4C F9C40880 00000000)
(../../drivers/storage/port/storport/storport.c:860) HwInitializationDataSize: 84
(../../drivers/storage/port/storport/storport.c:861) AdapterInterfaceType: 5
(../../drivers/storage/port/storport/storport.c:862) HwInitialize: FA2EA51C
(../../drivers/storage/port/storport/storport.c:863) HwStartIo: FA2ED091
(../../drivers/storage/port/storport/storport.c:864) HwInterrupt: FA2EB66A
(../../drivers/storage/port/storport/storport.c:865) HwFindAdapter: FA2ED430
(../../drivers/storage/port/storport/storport.c:866) HwResetBus: FA2EA5B3
(../../drivers/storage/port/storport/storport.c:867) HwDmaStarted: 00000000
(../../drivers/storage/port/storport/storport.c:868) HwAdapterState: 00000000
(../../drivers/storage/port/storport/storport.c:869) DeviceExtensionSize: 75584
(../../drivers/storage/port/storport/storport.c:870) SpecificLuExtensionSize: 0
(../../drivers/storage/port/storport/storport.c:871) SrbExtensionSize: 1320
(../../drivers/storage/port/storport/storport.c:872) NumberOfAccessRanges: 6
(../../drivers/storage/port/storport/storport.c:898) No driver object extension!
(../../drivers/storage/port/storport/storport.c:910) Driver object extension created!
(../../drivers/storage/port/storport/storport.c:31) PortAddDriverInitData()
(../../drivers/storage/port/storport/storport.c:941) StorPortInitialize() done (Status 0x00000000)
(../../drivers/storage/class/disk/disk.c:2257) HACK: Handling partition 0 request!
(../../ntoskrnl/fstub/disksup.c:1495) FSTUB: (IoReadPartitionTable) No 0xaa55 found in partition table 0

Code: Select all

(../../boot/freeldr/freeldr/arch/i386/i386vid.c:263) err: VESA/DDC installation check failed

start1119
Posts: 5
Joined: Sat Nov 26, 2016 10:54 am

Re: 0.4.8 Testing

Post by start1119 » Sun Mar 18, 2018 6:44 am

0.4.8-RC-25-g11bf8fa when install one software will lost another software list in applicatoin manager.
Some software will show cpu 100% ,in 0.47 does not this problem.
0.48-RC-25 install error less than 0.47

perseus
Posts: 8
Joined: Wed Oct 19, 2011 4:12 am

Re: 0.4.8 Testing

Post by perseus » Sat Apr 07, 2018 4:20 pm

Heis Spiter wrote:We have another release coming up! Please support us in testing for regressions.

https://reactos.org/wiki/Tests_for_0.4.8

Thanks!
None of the download links for 0.4.8 RC seem to work. :cry:

perseus
Posts: 8
Joined: Wed Oct 19, 2011 4:12 am

Re: 0.4.8 Testing

Post by perseus » Sat Apr 07, 2018 4:26 pm

Never-mind. I am greeted with the initial message
The "/ReactOS/0.4.8/React..tOS-0.4.8-RC-iso.zip" file could not be found or is not available. Please select another file.
. However, if you drill down deeper, you eventually get to a working link.

zlm1229
Posts: 19
Joined: Mon Oct 16, 2017 3:05 pm

Re: 0.4.8 Testing

Post by zlm1229 » Tue Apr 17, 2018 8:15 pm

Heis Spiter wrote:We have another release coming up! Please support us in testing for regressions.

https://reactos.org/wiki/Tests_for_0.4.8

Thanks!

I actually made a burnable disc ISO just for this.

I hope you can use it

https://drive.google.com/file/d/128zAzh ... sp=sharing

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot], Baidu [Spider] and 7 guests