0.3.17 testing

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

0.3.17 testing

Post by Z98 » Thu Oct 16, 2014 6:20 pm

Hi all, it's that time of the release cycle again wherein we ask members of the community to beat upon a release candidate to see what works and what doesn't work. The ISO and applications we would like testing done for are listed here: https://www.reactos.org/wiki/Tests_for_0.3.17

Note, do not add new entries to that list without my express permission. The goal here is to have a useful reference to compare different versions of ReactOS with known, specific versions. Anyway, any help you guys can provide would be appreciated and the faster that chart gets filled out the sooner we can get 0.3.17 out the door.

laurflorin
Posts: 86
Joined: Mon Feb 13, 2012 7:39 pm

Re: 0.3.17 testing

Post by laurflorin » Thu Oct 16, 2014 6:58 pm

Image

I suppose this is a false positive and I've reported it as such.
IT: The only place where a cookie could pose a risk to your privacy.

laurflorin
Posts: 86
Joined: Mon Feb 13, 2012 7:39 pm

Re: 0.3.17 testing

Post by laurflorin » Thu Oct 16, 2014 7:02 pm

On another note, I cannot install ReactOS in VMWare Player 6.0.3 from the
iso image provided. It just gives me a black screen (after "Loading Files" initial
screen), even though the VM HDD and Optical Drive LEDs are on, indicating activity.

EDIT/UPDATE: On VirtualBox v4.3.16 it seems that it works...
IT: The only place where a cookie could pose a risk to your privacy.

rachid
Posts: 35
Joined: Tue Mar 18, 2014 10:47 am

Re: 0.3.17 testing

Post by rachid » Thu Oct 16, 2014 8:16 pm

VirtulaBox 4.3.12

Cant install ReactOS
Just a black screen.

justincase
Posts: 430
Joined: Sat Nov 15, 2008 4:13 pm

Re: 0.3.17 testing

Post by justincase » Thu Oct 16, 2014 9:30 pm

It won't boot here either, using the ReactOS 0.3.17 RC iso I get a black screen and Putty says:

Code: Select all

000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒000▒▒▒%10sa▒▒▒zXR▒▒▒@▒▒▒_▒#p%▒▒▒▒]▒
U▒▒SW▒▒M
##0▒WINDOWS\SYSTEM32\NTOSKRNL.EXE▒
(why does it say "WINDOWS"?)

Just to be certain I decided to compare against build bootcd-64750-dbg in the same environment, it boots fine, so this issue is specific to the 0.3.17 branch.
I reserve the right to ignore any portion of any post if I deem it not constructive or likely to cause the discussion to degenerate.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: 0.3.17 testing

Post by Z98 » Thu Oct 16, 2014 10:17 pm

Redownload please, I built using the wrong toolchain which triggered a bug in our serial driver. A new version has been uploaded.

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: 0.3.17 testing

Post by Webunny » Thu Oct 16, 2014 10:48 pm

Z98 wrote:Hi all, it's that time of the release cycle again wherein we ask members of the community to beat upon a release candidate to see what works and what doesn't work. The ISO and applications we would like testing done for are listed here: https://www.reactos.org/wiki/Tests_for_0.3.17

Note, do not add new entries to that list without my express permission. The goal here is to have a useful reference to compare different versions of ReactOS with known, specific versions. Anyway, any help you guys can provide would be appreciated and the faster that chart gets filled out the sooner we can get 0.3.17 out the door.
Real hardware testing here. Tried to install it, but got borked right after the first initialisation. Got a black screen, nothing more. Re-burned it to be sure there wasn't an error introduced that way, but with the same result. Aka: doesn't install. It's getting late, so debugging with the serial cable will have to wait for this weekend, but it's safe to say there seems considerable regression going on, since I didn't have that problem since after 0.3.15.

Edit:
Z98 wrote:Redownload please, I built using the wrong toolchain which triggered a bug in our serial driver. A new version has been uploaded.
-.-


Redownloading...

Edit2:

Installation worked now. Installed correctly. Booted up. Seems ok at first glance. As said, further testing will have to wait until this weekend, but at least it seems to work pretty well now for the moment.
Last edited by Webunny on Thu Oct 16, 2014 11:22 pm, edited 3 times in total.

justincase
Posts: 430
Joined: Sat Nov 15, 2008 4:13 pm

Re: 0.3.17 testing

Post by justincase » Thu Oct 16, 2014 10:58 pm

Z98 wrote:Redownload please ... A new version has been uploaded.
Thanks, the new version boots up fine for me. (note - I had to download twice because my first download decided to use a mirror that still had the old version)
I reserve the right to ignore any portion of any post if I deem it not constructive or likely to cause the discussion to degenerate.

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Sat Oct 18, 2014 10:12 am

Z98 wrote:The goal here is to have a useful reference to compare different versions of ReactOS with known, specific versions.
Recently (wiki changeset 35867) I updated app versions on the testing page with the versions that are actually available in the Downloader. But since it's either "available in Downloader" or "known, specific version" (can't have both), I may have done wrong. Please advise.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: 0.3.17 testing

Post by Z98 » Sat Oct 18, 2014 10:58 pm

A somewhat unfortunate case of things not entirely being in sync. In this case, "known, specific" version takes priority. You don't have to move them outside of the available in downloader category however, since they were at one point available.

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Sat Oct 18, 2014 11:31 pm

OK, I reverted the change to keep the same version numbers as on the previous pre-release.

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: 0.3.17 testing

Post by Webunny » Sat Oct 18, 2014 11:33 pm

Hmm. In the 0.3.17 RC version, I don't see any new wallpapers for backgrounds...

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: 0.3.17 testing

Post by Z98 » Sun Oct 19, 2014 12:15 am

And the wallpapers are necessary for testing, why?

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: 0.3.17 testing

Post by Webunny » Sun Oct 19, 2014 9:57 pm

Z98 wrote:And the wallpapers are necessary for testing, why?
For instance, to see if they work?

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Sun Oct 19, 2014 10:22 pm

Come on, this is bikeshedding... it takes a minute or two to download some wallpaper from the net and test it (including browser download & install). But testing the applications from the list will take a lot more time, let's focust on that.

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot], Baidu [Spider], Bing [Bot], onestop_mid and 3 guests