Hard drive not found.

Ask your support questions in here

Moderator: Moderator Team

Post Reply
oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Hard drive not found.

Post by oldman »

I have today tried to install Ros on generic computer of about 6 years old. The hard drive (100Gb+) is partitioned
1. Primary (C: - Fat32 - 35.9Gb).
2. Primary (Linux - Ext4 - 29.3Gb).
3. Primary (Linux Swap).
4. Extended with two Logical (both Linux: Reiserfs - 37.1Gb : Ext4 - 38.4Gb).

Gparted can see all the partitions, FreeDos fdisk can see all the partitions, but the Ros installer cannot find an hard drive!

I was going to install Ros on the C: drive, but Ros gives me the error 'cannot find an hard drive'.

Does anyone have an idea why?
Last edited by oldman on Thu May 15, 2014 9:12 am, edited 1 time in total.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

The_French_Rat
Posts: 101
Joined: Sun Oct 21, 2012 11:57 pm
Location: Melbourne, Victoria, Australia
Contact:

Re: Hard drive not found.

Post by The_French_Rat »

Have you partitioned the C: partition as a FAT partition?
Just think of ReactOS as the XP beta, Whistler.

oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Re: Hard drive not found.

Post by oldman »

The_French_Rat wrote:Have you partitioned the C: partition as a FAT partition?
See the edited post for the answer to your question.

#############################

Puppy Linux reports the hard drive as ata, not s-ata.

Grub was showing up at boot (not with the Ros install disc in), so I have done a fdisk /mbr with Freedos, and tried again, but with no difference.

Is the partition too large?

Any ideas, anyone?
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

elhoir
Test Team
Posts: 397
Joined: Thu Sep 13, 2007 7:01 pm
Location: Madrid, Spain
Contact:

Re: Hard drive not found.

Post by elhoir »

Hello oldman,

Is there any way you can get debug logs to see what is happening to your machine?

oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Re: Hard drive not found.

Post by oldman »

elhoir wrote:Hello oldman,

Is there any way you can get debug logs to see what is happening to your machine?
Unfortunately not, no serial port = no debug log!
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

User avatar
Blue
Posts: 53
Joined: Mon Apr 21, 2014 8:14 pm

Re: Hard drive not found.

Post by Blue »

Format the Hard drive... MS has this problem also... It normally says hard drive not found when trying to install a new OS... (It also can stop you from installing a OS and give you errors at the end of new OS install build...) Had that problem with Windows 7 once.

Now It sounds to be like ReactOS its acting like the OS is blocking from having install rights..

oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Re: Hard drive not found.

Post by oldman »

Blue wrote:Format the Hard drive... MS has this problem also... It normally says hard drive not found when trying to install a new OS... (It also can stop you from installing a OS and give you errors at the end of new OS install build...) Had that problem with Windows 7 once.

Now It sounds to be like ReactOS its acting like the OS is blocking from having install rights..
Already done a fresh format before I even tried to install Ros.

I had thought to wipe all the partitions from the drive and start afresh, but I will leave that for now (I am reluctant to do that).
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: Hard drive not found.

Post by Z98 »

This SATA or IDE?

oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Re: Hard drive not found.

Post by oldman »

Z98 wrote:This SATA or IDE?
I have now had the computer case side off and found that it is plugged into one of the SATA pugs, not the IDE. So that looks like the problem!

Is there any plans to support SATA drives in the near future, because it's going to get more of a problem.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

elhoir
Test Team
Posts: 397
Joined: Thu Sep 13, 2007 7:01 pm
Location: Madrid, Spain
Contact:

Re: Hard drive not found.

Post by elhoir »

which mobo does yout computer have?

ReactOS should support SATA drives (that´s UniATA purpose :) ), but it doenst support *EVERY* SATA controller.....

oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Re: Hard drive not found.

Post by oldman »

elhoir wrote:which mobo does yout computer have?

ReactOS should support SATA drives (that´s UniATA purpose :) ), but it doenst support *EVERY* SATA controller.....
This is the motherboard (GF7050-M2):
http://www.biostar.com.tw/app/en/mb/int ... p?S_ID=311
I don't know what version my board is, but the image on the website looks exactly the same as the one shown in the installation guide that came with the computer.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: Hard drive not found.

Post by vicmarcal »

oldman wrote:
elhoir wrote:which mobo does yout computer have?

ReactOS should support SATA drives (that´s UniATA purpose :) ), but it doenst support *EVERY* SATA controller.....
This is the motherboard (GF7050-M2):
http://www.biostar.com.tw/app/en/mb/int ... p?S_ID=311
I don't know what version my board is, but the image on the website looks exactly the same as the one shown in the installation guide that came with the computer.
Here you have a list of supported SATA:
http://alter.org.ua/en/soft/win/uni_ata/compat.php

oldman
Posts: 1125
Joined: Sun Dec 20, 2009 1:23 pm

Re: Hard drive not found.

Post by oldman »

vicmarcal wrote:
oldman wrote:
elhoir wrote:which mobo does yout computer have?

ReactOS should support SATA drives (that´s UniATA purpose :) ), but it doenst support *EVERY* SATA controller.....
This is the motherboard (GF7050-M2):
http://www.biostar.com.tw/app/en/mb/int ... p?S_ID=311
I don't know what version my board is, but the image on the website looks exactly the same as the one shown in the installation guide that came with the computer.
Here you have a list of supported SATA:
http://alter.org.ua/en/soft/win/uni_ata/compat.php
Yes, I have been there and could not see the chip for my board.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: Hard drive not found.

Post by vicmarcal »

Try contacting alter :)
Maybe he knows if he current supports it or not :)

Post Reply

Who is online

Users browsing this forum: Semrush [Bot] and 2 guests