self-compiled builds don't boot in qemu

All development related issues welcome

Moderator: Moderator Team

Post Reply
RomanH
Posts: 83
Joined: Fri Nov 26, 2004 11:14 pm
Location: Switzerland

self-compiled builds don't boot in qemu

Post by RomanH »

Hello

for some reason my self compiled builds don't boot in qemu anymore. I've just tried it with a fresh check out and had no success. The livecd as well as the bootcd hang while fading in the splash screen. Any idea what could be the problem?

BTW: I'm using qemu 0.6.1 for Windows (win2k)
RomanH

Meklort
Posts: 175
Joined: Sat Mar 05, 2005 11:53 pm
Location: Colorado
Contact:

Re: self-compiled builds don't boot in qemu

Post by Meklort »

RomanH wrote:Hello

for some reason my self compiled builds don't boot in qemu anymore. I've just tried it with a fresh check out and had no success. The livecd as well as the bootcd hang while fading in the splash screen. Any idea what could be the problem?

BTW: I'm using qemu 0.6.1 for Windows (win2k)
I havent tried my builds lately, but it used to hang after the splash screen (not sur eif id does now)
I would just try compiling it again, doing a make clean.

RomanH
Posts: 83
Joined: Fri Nov 26, 2004 11:14 pm
Location: Switzerland

Post by RomanH »

Hi meklort

thanks for the tip but I still have no success. I tried make clean and now did a completely fresh checkout and the thing still doesn't boot on qemu. (However, I've just tried your latest build and it runs perfectly, so I guess the problem is not qemu)

here's my setup:
- SVN checkout 14618
- binutils-2.15.94-20050118-1.tar.gz
- gcc-core-3.4.2-20040916-1.tar.gz
- gcc-g++-3.4.2-20040916-1.tar.gz
- w32api-2.5.tar.gz
- nasm-0.98.39-win32.zip

an ideas?
RomanH

Meklort
Posts: 175
Joined: Sat Mar 05, 2005 11:53 pm
Location: Colorado
Contact:

Post by Meklort »

RomanH wrote:here's my setup:
- SVN checkout 14618
- binutils-2.15.94-20050118-1.tar.gz
- gcc-core-3.4.2-20040916-1.tar.gz
- gcc-g++-3.4.2-20040916-1.tar.gz
- w32api-2.5.tar.gz
- nasm-0.98.39-win32.zip
This is waht I am using to compile:
xmingw-binutils -> 2.15.90.0.2
xmingw-gcc -> 3.4.2
xmingw-runtime -> 3.5
xmingw-w32api -> 3.1

I dont know about binutils, but I think some versions wont work, try a differnet one
gcc : same as mine
try a higher version of the win32api

RomanH
Posts: 83
Joined: Fri Nov 26, 2004 11:14 pm
Location: Switzerland

Post by RomanH »

I have no idea why but my builds work in qemu again :D
RomanH

Dr. Fred
Developer
Posts: 607
Joined: Wed Dec 22, 2004 10:09 pm
Location: Amsterdam

Post by Dr. Fred »

I think it's a bug fix from hpoussin that made it work.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest