RosBE-0.3.1.exe, reactos0.3.0-REL-src.zip don't mix?

All development related issues welcome

Moderator: Moderator Team

Post Reply
curiousone
Posts: 14
Joined: Sat Nov 04, 2006 9:25 pm

RosBE-0.3.1.exe, reactos0.3.0-REL-src.zip don't mix?

Post by curiousone »

Downloaded the above items, attempted to follow the instructions trying to do a mingw32-make all, and do not get clean builds from either the gcc 4.1.2 or the gcc 3.4.5 build environment prompts (errors different between the two different versions.)

I wound up with "No rule to make target makefile.auto..." from the 3.4.5 prompt.

From the gcc 4.1.2 environment, tried both
mingw32-make all and mingw32-make bootcd
I got two "warnings as errors" about computed value not used from sndvol32.c(lines 335 and 500), which I avoided by adding (void) casts to a couple of call return values... then I got
============================================
base\shell\explorer\utility\shellbrowserimpl.cpp:119: error: 'HRESULT const GUID
::*LTHUNK0(const GUID*, ULONG, OLECMD*, OLECMDTEXT*)' aliased to undefined symbo
l '_ZN17IShellBrowserImpl11QueryStatusEPK5_GUIDmP10_tagOLECMDP14_tagOLECMDTEXT'
base\shell\explorer\utility\shellbrowserimpl.cpp:119: error: 'HRESULT const GUID
::*LTHUNK1(const GUID*, DWORD, DWORD, VARIANT*, VARIANT*)' aliased to undefined
symbol '_ZN17IShellBrowserImpl4ExecEPK5_GUIDmmP10tagVARIANTS4_'
base\shell\explorer\utility\shellbrowserimpl.cpp:119: error: 'HRESULT IShellView
::*LTHUNK2(IShellView*)' aliased to undefined symbol '_ZN17IShellBrowserImpl16On
DefaultCommandEP10IShellView'
base\shell\explorer\utility\shellbrowserimpl.cpp:119: error: 'HRESULT const GUID
::*LTHUNK3(const GUID&, const IID&, void**)' aliased to undefined symbol '_ZN17I
ShellBrowserImpl12QueryServiceERK5_GUIDS2_PPv'
mingw32-make: *** [obj-i386\base\shell\explorer\utility\shellbrowserimpl.o] Erro
r 1
============================================

I observe that the RosBE-0.3.1.exe seems to have been released _after_ the reactos0.3.0 file sets...

How does one manage to build at least an .ISO equivalent to whatever is in the 0.3.0 reactos/QEMU release bundle?
Quip
Posts: 2
Joined: Fri Dec 17, 2004 8:47 am

Post by Quip »

The gcc 4 build env. is not fully supported at this time. Please use the 3.4.5 buld env. try reinstalling the build environment if you still have problems and post back in this thread. :D

Update: 3.4.5 build environment builds ros .3.0. remember to go to the reactos source directory and type "mingw32-make install" , "mingw32-make bootcd" or "mingw32-make livecd". to do this go to Startmenu ->Programs -> ReactOS Build Environment and click on GCC 3.4.5 ReactOS Build Environment. Make sure you delete "makefile.auto" file, output-i386 and obj-i386 directories.

hope this helps.
Last edited by Quip on Sun Nov 05, 2006 12:34 am, edited 1 time in total.
Coviti
Posts: 300
Joined: Wed Mar 01, 2006 4:26 am

Post by Coviti »

curiousone wrote:I wound up with "No rule to make target makefile.auto..." from the 3.4.5 prompt.
Did you try deleting makefile.auto?
curiousone
Posts: 14
Joined: Sat Nov 04, 2006 9:25 pm

Post by curiousone »

initially, no change.

But before I posted this I had an idea - I already had a mingw installation. Hiding this installation seems to have avoided the problem. It hasn't finished building yet, but its gotten beyond the point indicated below. I don't think that installation is in my path by default, so this would suggest the build environment does not entirely isolate itself, and somehow finds that one which was messing things up...

-----------------------------------------------------------
(This represents what happened before I hid the other mingw installation.)

extracted fresh copy of source archive.
uninstalled reinstalled build environment
opened 3.4.5 build environment command prompt.

Execute:
mingw32-make bootcd

Appears to be problem related to (absence of?) std::..RB_tree... stuff

Receive multiple instances of error similar to:
obj-i386\tools\rbuild\backend\msvc\msvcmaker.o: In function `ZSt11__copy_aux2IPS
sS0_ET0_T_S2_S1_12__false_type':
C:/RosBE/3.4.5/bin/../lib/gcc/mingw32/3.4.5/../../../../include/c++/3.4.5/bits/s
tl_algobase.h:(.text$_ZNSt23_Rb_tree_const_iteratorISsEppEi[std::_Rb_tree_const_
iterator<std::basic_string<char, std::char_traits<char>, std::allocator<char> >
>::operator++(int)]+0x1b): undefined reference to `std::_Rb_tree_increment(std::
_Rb_tree_node_base const*)'
C:/RosBE/3.4.5/bin/../lib/gcc/mingw32/3.4.5/../../../../include/c++/3.4.5/bits/s
tl_algobase.h:(.text$_ZNSt8_Rb_treeISsSsSt9_IdentityISsESt4lessISsESaISsEE9_M_in
sertEPSt18_Rb_tree_node_baseS7_RKSs[std::_Rb_tree<std::basic_string<char, std::c
har_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_trai
ts<char>, std::allocator<char> >, std::_Identity<std::basic_string<char, std::ch
ar_traits<char>, std::allocator<char> > >, std::less<std::basic_string<char, std
::char_traits<char>, std::allocator<char> > >, std::allocator<std::basic_string<
char, std::char_traits<char>, std::allocator<char> > > >::_M_insert(std::_Rb_tre
e_node_base*, std::_Rb_tree_node_base*, std::basic_string<char, std::char_traits
<char>, std::allocator<char> > const&)]+0x99): undefined reference to `std::_Rb_
tree_insert_and_rebalance(bool, std::_Rb_tree_node_base*, std::_Rb_tree_node_bas
e*, std::_Rb_tree_node_base&)'

Any more ideas?
hto
Developer
Posts: 2193
Joined: Sun Oct 01, 2006 3:43 pm

Post by hto »

Try to execute "mingw32-make depends".

>How does one manage to build at least an .ISO equivalent
>to whatever is in the 0.3.0 reactos/QEMU release bundle?

I have gcc and g++ 3.4.5, binutils 2.17.50, make 3.81, mingw-runtime 3.10, w32api 3.7 and nasm 0.98.39 in c:\usr directory tree, bash 3.1.14 and other GNU utils in c:\bin. ".bashrc" sets path to "/bin:/usr/bin".
curiousone
Posts: 14
Joined: Sat Nov 04, 2006 9:25 pm

Post by curiousone »

I'm sorry my previous post was apparently not completely clear.

After I hid my existing mingw implementation (by moving mingw and msys folders out of my root directory), a build succeeded (although I did post before it had completed, but after it had passed the previous point of failure.

(The errors shown in that post reflect what I was seeing prior to the "hide mingw" discovery.)

There is apparently "something" about the mingw builds or the build environment builds, that an existing mingw installation is found and referenced, in spite of the fact that the build environment tries to set up its own "world".

And neither of the original mingw/msys directories I had pre-installed were in my default paths.
merck
Posts: 1
Joined: Wed Dec 06, 2006 3:13 pm

Post by merck »

Hi all,

There is a patch which solved this issue, when using gcc-4.1.[0-1]

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=27067

I had tried it on my Gentoo linux pc with CROSSDEV tools.

And Compiling ReactOS checked out from SVN, the error condition no longer occured.


My compiler version:
mingw32-gcc-4.1.1
mingw32-as-2.17

good luck

Merck
steveh
Posts: 271
Joined: Sat Dec 18, 2004 10:02 pm

"make clean"

Post by steveh »

If you get stuck after unsuccessfull build attempts, it's not necessary to do manual actions like deleting makefile.auto....

But you should do "make clean" oder "mingw32make clean" which deletes every intermediate / object / binary ... file created by previous build attempts. Only the bare source trunk (with all build components) will stay in place.
Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests