Page 1 of 1

[SOLVED]Installing RosBE on Linux Mint 18 Sarah

Posted: Sat Sep 24, 2016 9:14 pm
by eersoy93
Hi everyone! I have a problem with installing RosBE. When I run RosBE-Builder.sh, I get ths output:

Code: Select all

*******************************************************************************
*         ReactOS Build Environment for Unix-based Operating Systems          *
*                      Builder Tool for the Base package                      *
*                      by Colin Finck <colin@reactos.org>                     *
*                                                                             *
*                                 Version 2.1.2                               *
*******************************************************************************

This script compiles and installs a complete Build Environment for building
ReactOS.

Checking for the needed tools...
Checking for as... OK
Checking for bison... OK
Checking for flex... OK
Checking for gcc... OK
Checking for g++... OK
Checking for grep... OK
Checking for makeinfo... MISSING
Checking for python... OK
Checking for GNU Make... OK
Checking for zlib... MISSING
At least one needed tool is missing, aborted!
What is the solution? Thanks for replies.

Re: Installing RosBE on Linux Mint 18 Sarah

Posted: Sat Sep 24, 2016 9:33 pm
by eersoy93
After installing "texinfo" package, I get this output:

Code: Select all

*******************************************************************************
*         ReactOS Build Environment for Unix-based Operating Systems          *
*                      Builder Tool for the Base package                      *
*                      by Colin Finck <colin@reactos.org>                     *
*                                                                             *
*                                 Version 2.1.2                               *
*******************************************************************************

This script compiles and installs a complete Build Environment for building
ReactOS.

Checking for the needed tools...
Checking for as... OK
Checking for bison... OK
Checking for flex... OK
Checking for gcc... OK
Checking for g++... OK
Checking for grep... OK
Checking for makeinfo... OK
Checking for python... OK
Checking for GNU Make... OK
Checking for zlib... MISSING
At least one needed tool is missing, aborted!

Re: Installing RosBE on Linux Mint 18 Sarah

Posted: Sun Sep 25, 2016 1:11 am
by hbelusca
Install the missing package.

Re: Installing RosBE on Linux Mint 18 Sarah

Posted: Sun Sep 25, 2016 10:27 am
by EmuandCo
Wasnt there some problem with 32 bit version of zlib needed? I don't use Linux, but there rings a bell somewhere.

Re: Installing RosBE on Linux Mint 18 Sarah

Posted: Sun Sep 25, 2016 11:27 am
by eersoy93
I couldn't find the package. In spite of zlib1g and zlib1g:i386 packages are installed, I can't continue RosBE installing.

Re: Installing RosBE on Linux Mint 18 Sarah

Posted: Sun Sep 25, 2016 8:37 pm
by eersoy93
I installed zlib1g-dev, then the problem has been resolved.