Network Adapter on real hardware...

Ask your support questions in here

Moderator: Moderator Team

Post Reply
User avatar
Jaix
Moderator Team
Posts: 838
Joined: Sat Nov 27, 2004 3:40 pm
Location: Sweden, Växjö

Network Adapter on real hardware...

Post by Jaix »

I have tried to connect real hardware to the net, but I don't succeed, I have many cards to choose from, but none of them seams to work.

first I have a NE2000 isa card (BNC) isn't this card supposed to work directly, or do I have to edit the registry?

secondly Realtec8139 PCI shouldn't this work I have read reports about this card, but how do I do it?

thirdly 3-com (various)
and
Davicom (DM9102AF)

Which should be the most easy one to get to work and what do I have to do?

Phalanx
Posts: 360
Joined: Sun Dec 19, 2004 12:42 am
Location: Australia

Post by Phalanx »

What version are you using?

Ged
Developer
Posts: 925
Joined: Thu Sep 29, 2005 3:00 pm
Location: UK

Post by Ged »

Herve has setup plug and play which should automatically detect cards now. The pcnet1 and ne2001 entries have gone.

Pasting what Herve wrote today in the mailing list:
If your netcard is a PCI one, with VendorID 1022 and DeviceID 2000, you have
nothing to do. It will be installed automatically.
Otherwise, you have to provide the .inf and the .sys files in ReactOS/inf
directory, and the netcard should be installed at next reboot.
If it still doesn't work, you have to install it manually as per Wiki driver
page. Don't forget to change the last 0000 subkey to something like
1&xxxxxxxx&xx
hth

User avatar
Jaix
Moderator Team
Posts: 838
Joined: Sat Nov 27, 2004 3:40 pm
Location: Sweden, Växjö

svn or RC1

Post by Jaix »

Phalanx wrote:What version are you using?
First I tried the SVN but I had USB troubble so I retruned to 0.2.8 RC1

Is the PnP - embryo in the RC1 or in the Trunk Branch of the SVN?
Last edited by Jaix on Thu Oct 20, 2005 7:07 pm, edited 1 time in total.

GvG
Posts: 499
Joined: Mon Nov 22, 2004 10:50 pm
Location: The Netherlands

Post by GvG »

It's only in trunk, not in the 0.2.8 branch.

gge
Posts: 24
Joined: Mon Feb 21, 2005 9:58 pm
Location: France

Post by gge »

Realtek 8139 works for me in real hardware with svn 18648 ( my lmast test).
See install instructions in Wiki/drivers page

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests