mouse not working

Ask your support questions in here

Moderator: Moderator Team

peter long
Posts: 9
Joined: Fri Oct 14, 2011 2:31 am

mouse not working

Post by peter long » Tue Oct 18, 2011 1:36 pm

I install the .0.3.14 build , but I can't get the mouse to work , I get the pointer but it will not move, tried a ordinary mouse (non-usb) but still the same. Running on virtualbox (linux). The .0.3.13 will working OK. Can any one HELP....peter

Saibamen
Posts: 212
Joined: Mon Jul 19, 2010 11:19 am
Location: Poland
Contact:

Re: mouse not working

Post by Saibamen » Tue Oct 18, 2011 3:10 pm

0.3.14 wow! How do you get that!?
ReactOS Forum Global Moderator
IT-Maniak.pl administrator

EmuandCo
Developer
Posts: 4334
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: mouse not working

Post by EmuandCo » Tue Oct 18, 2011 7:32 pm

He talks about trunk...
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

Saibamen
Posts: 212
Joined: Mon Jul 19, 2010 11:19 am
Location: Poland
Contact:

Re: mouse not working

Post by Saibamen » Tue Oct 18, 2011 7:48 pm

I know, i know, but tell me revision, peter long.
ReactOS Forum Global Moderator
IT-Maniak.pl administrator

peter long
Posts: 9
Joined: Fri Oct 14, 2011 2:31 am

Re: mouse not working

Post by peter long » Tue Oct 18, 2011 9:17 pm

I now install the .0.3.14 on virtualbox using the windows platform(winXP) and the mouse is working on that OK , but the problem with this install is that I have no internet to download the driver for the sound etc. can someone help with this?

PS : the Ref to the .0.3.14 is the nightly build when released, you can download it for yourself. please see my other question about "no sound on virtualbox" or look for build at the bottom of the main page.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: mouse not working

Post by Z98 » Tue Oct 18, 2011 10:00 pm

Considering we have a build for every commit, saying "0.3.14" or "nightly" doesn't tell us with any certainty which revision you are testing. Saying "0.3.14" is also inaccurate as what you are calling 0.3.14 will not be the 0.3.14 that ultimately gets released.

peter long
Posts: 9
Joined: Fri Oct 14, 2011 2:31 am

Re: mouse not working

Post by peter long » Thu Oct 20, 2011 1:02 am

well thanks for your comments Z98 but this blog to to get help for newbie to this OS and not to me put off with not very helpful comment, if you find the time, you can look at my other blog asking for help with "no sound on virtualbox and from there you can read this post from one of your tester:

"You should try one of the nightly builds. 0.3.13 is pretty outdated. We are now in the trunk stabilise period, preceding the actual release of 0.3.14."

I find it alot with this type of help blog that the one's who post comments like this don't help anyone. roger

Sof_T
Posts: 140
Joined: Fri May 01, 2009 4:46 pm

Re: mouse not working

Post by Sof_T » Thu Oct 20, 2011 11:01 am

Peter Z98 is trying to be helpful the version numbers you are using are those of release builds, inbetween each build are many revisions. If you download the latest build from here http://www.reactos.org/getbuilds/ to try, the revision number is the 5 figure number in the title, that is the number required since things can start or stop working between one revision and another.

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: mouse not working

Post by Haos » Thu Oct 20, 2011 8:06 pm

@peter long

If you find concepts like nightly build/revision number too complicated, you should wait with testing ReactOS until tad later.

PurpleGurl
Posts: 1778
Joined: Fri Aug 07, 2009 5:11 am
Location: USA

Re: mouse not working

Post by PurpleGurl » Mon Oct 24, 2011 6:24 am

peter long wrote:I install the .0.3.14 build , but I can't get the mouse to work , I get the pointer but it will not move, tried a ordinary mouse (non-usb) but still the same. Running on virtualbox (linux). The .0.3.13 will working OK. Can any one HELP....peter
There is no 0.3.14 build. It does not exist yet. We need to know the 5 digit number of the exact revision you downloaded, like 54243, for instance.

You may wish to try the latest on this page:
http://www.reactos.org/getbuilds/

Still, try disabling your legacy USB support in the BIOS (even if using a PS/2 mouse) just in case some users still have to do that.

timsoft
Posts: 3
Joined: Thu Feb 21, 2008 5:36 pm

Re: mouse not working

Post by timsoft » Thu Feb 09, 2012 1:03 pm

I also have problem with mouse and keyboard not working but with reactos 0.3.14-rel on a real pc (not virtual)
I have a ps/2 keyboard and mouse attached, and have also attached a usb mouse and a serial mouse but non of the mice move the cursor so i am stuck at the "Welcome to the reactos setup wizard" screen.

I also had a problem with the installation setup hanging after loading the kernel before asking for keyboard layouts etc, but that was fixed by disconnecting the floppy drive and moving the cdrom from slave to master setting on the secondary ide cable. Any clues or debugging I can do to make them (mouse and keyboard) work? thanks

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: mouse not working

Post by vicmarcal » Thu Feb 09, 2012 4:52 pm

timsoft wrote:I also have problem with mouse and keyboard not working but with reactos 0.3.14-rel on a real pc (not virtual)
I have a ps/2 keyboard and mouse attached, and have also attached a usb mouse and a serial mouse but non of the mice move the cursor so i am stuck at the "Welcome to the reactos setup wizard" screen.

I also had a problem with the installation setup hanging after loading the kernel before asking for keyboard layouts etc, but that was fixed by disconnecting the floppy drive and moving the cdrom from slave to master setting on the secondary ide cable. Any clues or debugging I can do to make them (mouse and keyboard) work? thanks
USB mouse and keyboard are supposed to not be working :)
Just keep your ps/2 keyboard and mouse attached. How old is the PC?is it a laptop?
We need specs to help you.
Thanks for testing.
Image

timsoft
Posts: 3
Joined: Thu Feb 21, 2008 5:36 pm

Re: mouse not working

Post by timsoft » Thu Feb 09, 2012 5:23 pm

pc is athonxp2400 224mb ram (256 with 32 shared for vga) running in a gigabyte GA7VKMP motherboard, a seagate 40gb ide hard drive and a samsung dvdwriter sh-s202. it is almost 8.5yrs old (apart from the dvdrw). It was running win98 fine :-)
I have keyboard and mouse connected into ps/2 ports as well as the mouse in com1 and another in usb. I've taken out the usb one and tried with just ps/2 and com1 mice, and I have also tried with just ps/2 mouse and keyboard.
it only installs when I select basic pc uniprocessor (not acpi uniprocessor). the keyboard works, but the mouse does not.

ubuntu 11.10 works on the above hardware including mice and keyboard, so hardware appears to be fully functional

I have some other oldish hardware I can test reactos on. :)

wojo664
Posts: 320
Joined: Mon Jul 06, 2009 5:39 pm

Re: mouse not working

Post by wojo664 » Thu Feb 09, 2012 9:29 pm

Hello :-)

During testing of the official 0.3.14 version, I've noticed simmilar bug when installing with ACPI enabled on VBox. Keyboard was working but mouse not. When installing without ACPI, it worked fine.

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: mouse not working

Post by vicmarcal » Fri Feb 10, 2012 2:46 am

wojo664 wrote:Hello :-)

During testing of the official 0.3.14 version, I've noticed simmilar bug when installing with ACPI enabled on VBox. Keyboard was working but mouse not. When installing without ACPI, it worked fine.
Is it reported?This is an important bug ;)
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest