Page 1 of 1

once again: compile errors

Posted: Tue Jul 19, 2005 1:23 am
by Mr. Anderson
Hello,

anybody out there who has successfully compiled the current rev of ReactOS?
I get errors on hal/halx86/up/halinit_up.c and lib/aclui/aclui.c

Posted: Tue Jul 19, 2005 1:07 pm
by i386DX
I don't know what "current" is for you, but the current 16640 revision compiles

Posted: Tue Jul 19, 2005 3:01 pm
by Mr. Anderson
Sorry. Did not work with revision 16639 (also not with 16636, 16637, 16638 and 16641)

Thank you for testing. Which compiler did you use?
I already posted a bug report for my problem. (http://reactos.com/bugzilla/show_bug.cgi?id=678)

But there are even more problems, so I would like to find out, whether it's a problem concerning my configuration.

Posted: Tue Jul 19, 2005 4:51 pm
by i386DX
Hmz, I can compile rev 16641...

I use the mingw32 compiler (ReactOS Build Environment).

You can try to delete your file that give an error and get it back by svn up. This sometimes work for me.

Posted: Tue Jul 19, 2005 5:14 pm
by Mr. Anderson
I have already tried that.

Maybe just deleting anything and download it all again will help. (*sigh more than 200 MB)

Posted: Tue Jul 19, 2005 9:44 pm
by GreatLord
delete all *.gch file it will do the trix, when we are update header file *.h some time rbuild will not generate new one, so you need manual delete them. when it happen. del *.gch /s

Posted: Tue Jul 19, 2005 10:54 pm
by Mr. Anderson
Thank you.

Code: Select all

find . -name "*.gch" -exec rm {} \;
did work.