[solved]Compile problems

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Mr. Anderson
Posts: 36
Joined: Tue Mar 01, 2005 10:45 pm

[solved]Compile problems

Post by Mr. Anderson »

Hello,

I checked out the svn tree completely new and tried to compile it. But it breaks up. The exakt output:

Code: Select all

svn co svn://svn.reactos.com/trunk/reactos
[...]
cd reactos
make
[MKDIR]    obj-i386/tools
[MKDIR]    obj-i386/tools/rbuild
[MKDIR]    obj-i386/tools/rbuild/backend
[MKDIR]    obj-i386/tools/rbuild/backend/mingw
[CC]       tools/rbuild/backend/mingw/mingw.cpp
[CC]       tools/rbuild/backend/mingw/modulehandler.cpp
[CC]       tools/rbuild/backend/mingw/proxymakefile.cpp
[MKDIR]    obj-i386/tools/rbuild/backend/devcpp
[CC]       tools/rbuild/backend/devcpp/devcpp.cpp
[CC]       tools/rbuild/backend/backend.cpp
[CC]       tools/rbuild/automaticdependency.cpp
[CC]       tools/rbuild/bootstrap.cpp
[CC]       tools/rbuild/cdfile.cpp
[CC]       tools/rbuild/compilerflag.cpp
[CC]       tools/rbuild/configuration.cpp
[CC]       tools/rbuild/define.cpp
[CC]       tools/rbuild/exception.cpp
[CC]       tools/rbuild/filesupportcode.cpp
[CC]       tools/rbuild/include.cpp
[CC]       tools/rbuild/installfile.cpp
[CC]       tools/rbuild/linkerflag.cpp
[CC]       tools/rbuild/module.cpp
[CC]       tools/rbuild/project.cpp
[CC]       tools/rbuild/ssprintf.cpp
[CC]       tools/rbuild/stubbedcomponent.cpp
[CC]       tools/rbuild/testsupportcode.cpp
[CC]       tools/rbuild/wineresource.cpp
[CC]       tools/rbuild/XML.cpp
[CC]       tools/rbuild/rbuild.cpp
[MKDIR]    output-i386/tools
[MKDIR]    output-i386/tools/rbuild
[LD]       output-i386/tools/rbuild/rbuild
[MKDIR]    obj-i386/tools/bin2res
[CC]       tools/bin2res/bin2res.c
[CC]       tools/bin2res/mkstemps.c
[MKDIR]    output-i386/tools/bin2res
[LD]       output-i386/tools/bin2res/bin2res
[MKDIR]    obj-i386/tools/buildno
[CC]       tools/buildno/buildno.cpp
[CC]       tools/buildno/exception.cpp
[CC]       tools/buildno/ssprintf.cpp
[CC]       tools/buildno/XML.cpp
[MKDIR]    output-i386/tools/buildno
[LD]       output-i386/tools/buildno/buildno
[BUILDNO]  include/reactos/buildno.h
[MKDIR]    obj-i386/tools/wmc
[CC]       tools/wmc/getopt.c
[CC]       tools/wmc/lang.c
[CC]       tools/wmc/mcl.c
[CC]       tools/wmc/utils.c
[CC]       tools/wmc/wmc.c
[CC]       tools/wmc/write.c
[CC]       tools/wmc/y_tab.c
[CC]       tools/wmc/misc.c
[MKDIR]    output-i386/tools/wmc
[LD]       output-i386/tools/wmc/wmc
[WMC]      include/reactos/bugcodes.h
[WMC]      include/reactos/errcodes.h
[MKDIR]    obj-i386/tools/nci
[CC]       tools/nci/ncitool.c
[MKDIR]    output-i386/tools/nci
[LD]       output-i386/tools/nci/nci
[NCI]      include/ntdll/napi.h
[RBUILD]   makefile.auto
Reading build files...done
Detecting compiler...not detected
Detecting netwide assembler...detected (nasm)
Detecting compiler -pipe support...not detected
Detecting compiler pre-compiled header support...not detected
Processing modules...done
Creating directories...done
Unpacking WINE resources...done
Generating test support code...done
Generating proxy makefiles...done
Checking automatic dependencies...done
[DLLTOOL]  obj-i386/lib/kernel32/libkernel32.a
make: mingw32-dlltool: Command not found
make: *** [obj-i386/lib/kernel32/libkernel32.a] Error 127

I'm using a Gentoo Linux with the same versions of XMingw that have worked fine for many months. I don't know much about this new xml build system, so I don't really know where to look for the problem.
Any idea?

edit: Problem solved. The ROS_PREFIX variable must not be set in the Makefile. Just made a export ROS_PREFIX = ... and ROS is compiling atm.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests