unable to chose language

Ask your support questions in here

Moderator: Moderator Team

Post Reply
ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

unable to chose language

Post by ravenxbishop »

i read the forums and saw that i should get a truck build....

i chose bootcd-32280-dbg

i unzip'd burnt..... booted..... press any key to boot from cd

success.... loads drivers... then the num lock light goes off....

please select language hit enter or f3.... try to select english by simply hitting enter.... NADA...

wont let me chose (i assume with arrow keys) wont let me select (with enter) ... wont let me quit (f3) hitting num lock doesnt change the status of num lock light....

did i get the wrong build?
:cry:

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Post by Haos »

Nope, but you could try latest trunk version as well. We are being notified of a small portion of PC`s that still doesnt work well with our keyboard/mouse driver. I suppose this is one of them. If possible, please get debug output from this PC (it requires another PC and a null modem cable). If not, you will have to wait till we get enough debug data to fix it.

ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

Post by ravenxbishop »

bootcd-32280-dbg is not the latest trunk version? what is the latest trunk vs?

as far as a null modem cable, is that serial to serial or parallell to paralell, i have a paralell to paralell (printer cable) ... for my sound cards but i dont think i have serial to serial.... and i think thats the one i need ... willing to go to bust buy and get one.... the motherboard is a msi k7n2gl i believe i think i have an amd 1800+ on it with maybe a 512 ram

phoenix award bios version 6.00pg

maybe i should update the bios?

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Post by Haos »

Umm, better do not touch your bios. If you want, you can buy such cable (not very expensive). Be sure to ask for a "null modem" cable, which is serial to serial (but not all serial2serial are null modem cables). Also check if both your PC`s have serial ports as some newer mainboards have only pinouts but not the port connector itself.

ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

Post by ravenxbishop »

you said bootcd-32280-dbg wasnt the latest and that getting the latest might help.... what is the latest... and where

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Post by Z98 »


ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

Post by ravenxbishop »

no joy :?

mrmrmrkevin
Posts: 8
Joined: Mon Feb 18, 2008 6:30 am

Post by mrmrmrkevin »

I had the exact same problem on two different machines. Both old: Compaq Presario 1200 and a Dell Optiplex GX110.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Post by Z98 »

At which point we would need a debug log to see what's going on.

ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

Post by ravenxbishop »

once i get said cable as i should in the next few hours.

what are the instructions for recieving the debug messages... windows vista

ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

cant choose language

Post by ravenxbishop »

null modem debug result

ì

it was 1 or 2 characters from far right.


so i put the null modem cable on, and loaded putty selected serial com1, booted up 32412-dbg.iso

i was going to get a newer one just for luck, but www.reactos.org/getbuilds didnt seem to ever finish fetching the builds from the robot.... i tried even pushing the buildbot back a few cycles and it didnt finish fetching (tried on different machines and 3 different networks over a few days)

so i booted up, and when it got stuck at the language choosing screen i looked at the terminal, and all i got was ì on the far right....

hopefull this is meaningful to you guys...

i'm going to try and get a usb keyboard and see if theres a better result

GoBusto
Posts: 579
Joined: Fri Jan 25, 2008 11:13 am
Location: UK
Contact:

Post by GoBusto »

The trunk builds page is broken right now. Try http://iso.reactos.org instead.

ravenxbishop
Posts: 9
Joined: Fri Aug 31, 2007 11:08 pm

Post by ravenxbishop »

(ntoskrnl/kd/kdio.c:191) -----------------------------------------------------
(ntoskrnl/kd/kdio.c:192) ReactOS 0.4-SVN (Build 20080316-r32699)
(ntoskrnl/kd/kdio.c:193) Command Line: NOGUIBOOT DEBUGPORT=COM1 NOGUIBOOT DEBU
GPORT=COM1
(ntoskrnl/kd/kdio.c:194) ARC Paths: multi(0)disk(0)cdrom(159) \ multi(0)disk(0)c
drom(159) \reactos\
Used memory 1048116Kb
(ntoskrnl/mm/mminit.c:294) Start End Type
(ntoskrnl/mm/mminit.c:295) 0x80000000 - 0x80800000 Undefined region
(ntoskrnl/mm/mminit.c:298) 0x80800000 - 0x80000000 FreeLDR Kernel mapping r
egion
(ntoskrnl/mm/mminit.c:301) 0x80000000 - 0x80800000 PFN Database region
(ntoskrnl/mm/mminit.c:305) 0x80800000 - 0x80E00000 Remaining FreeLDR mappin
g
(ntoskrnl/mm/mminit.c:308) 0x80E00000 - 0x87200000 Non paged pool region
(ntoskrnl/mm/mminit.c:311) 0x87200000 - 0x8D600000 Paged pool region
(ntoskrnl/ke/i386/kiinit.c:47) Large Page support detected but not yet taken adv
antage of!
WARNING: KdDebuggerInitialize1 at drivers/base/kdcom/kdbg.c:489 is UNIMPLEMENTE
D!
(drivers/filesystems/ext2/src/ext2init.c:63) Ext2 File System Driver Entry <<<<<
<<,IRQL = 0
WARNING: IoReportResourceUsage at ntoskrnl/io/iomgr/iorsrce.c:700 is UNIMPLEMEN
TED!
WARNING: IoReportResourceUsage at ntoskrnl/io/iomgr/iorsrce.c:700 is UNIMPLEMEN
TED!
(drivers/filesystems/ext2/src/ext2init.c:354) Ext2QueueHandlerThread!!!,IRQL = 0

(ntoskrnl/io/iomgr/driver.c:1347) '\Driver\BUSLOGIC' initialization failed, stat
us (0xc00000c0)
(ntoskrnl/io/iomgr/file.c:414) Using IopParseDevice() hack
(base/setup/usetup/interface/devinst.c:371) Device arrival event: HTREE\ROOT\0
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0F13\
0000
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0501\
0001
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0501\
0000
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0A03\
0001
(base/setup/usetup/interface/devinst.c:84) Using driver 'pci.sys' for device 'Ro
ot\*PNP0A03\0001'
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0A03\
0002
(base/setup/usetup/interface/devinst.c:84) Using driver 'pci.sys' for device 'Ro
ot\*PNP0A03\0002'
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0A03\
0000
(base/setup/usetup/interface/devinst.c:84) Using driver 'pci.sys' for device 'Ro
ot\*PNP0A03\0000'
(base/setup/usetup/interface/devinst.c:371) Device arrival event: Root\*PNP0303\
0000
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D5&SUBSYS_03D5A0A0&REV_02\1&c335d926&BF
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D3&SUBSYS_042DA0A0&REV_02\1&c335d926&7F
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D1&SUBSYS_042EA0A0&REV_02\1&c335d926&5F
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24DB&SUBSYS_042DA0A0&REV_02\1&c335d926&3F
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D0&SUBSYS_00000000&REV_02\1&c335d926&1F
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_244E&SUBSYS_00000000&REV_C2\1&c335d926&1E
(base/setup/usetup/interface/devinst.c:84) Using driver 'pci.sys' for device 'PC
I\VEN_8086&DEV_244E&SUBSYS_00000000&REV_C2\1&c335d926&1E'
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24DD&SUBSYS_040AA0A0&REV_02\1&c335d926&FD
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24DE&SUBSYS_042DA0A0&REV_02\1&c335d926&7D
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D7&SUBSYS_042DA0A0&REV_02\1&c335d926&5D
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D4&SUBSYS_042DA0A0&REV_02\1&c335d926&3D
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_24D2&SUBSYS_042DA0A0&REV_02\1&c335d926&1D
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_2571&SUBSYS_00000000&REV_02\1&c335d926&01
(base/setup/usetup/interface/devinst.c:84) Using driver 'pci.sys' for device 'PC
I\VEN_8086&DEV_2571&SUBSYS_00000000&REV_02\1&c335d926&01'
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_2570&SUBSYS_25708086&REV_02\1&c335d926&00
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_8086&D
EV_1050&SUBSYS_0517A0A0&REV_02\2&36751148&08
(base/setup/usetup/interface/devinst.c:371) Device arrival event: PCI\VEN_10DE&D
EV_0110&SUBSYS_00000000&REV_B2\2&c2a1153e&00

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Post by Haos »

You should consult Colin_Finck on irc channel #reactos (irc.freenode.net).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest