Page 1 of 2

ReactOS 0.3.1 freezes at boot screen

Posted: Sun Apr 01, 2007 9:32 am
by Haos
When resolution is set to VESA, ReactOS will fail to boot for the first time.
Usually, on the same machine, ReactOS works well on QEMU.

640x480x16 VGA mode should be working

If the bug persists on your machine, please post your specs as well as comments (if for example, even vga mode isn`t working).

Posted: Sun Apr 01, 2007 1:33 pm
by hto
ReactOS 0.3.1 freezes at boot screen (AKA AMD bug)
It is not AMD bug, it is different bug which is already fixed in the trunk. AMD bug (AKA unfinished path in trap.s) is not yet fixed. Invalid opcode bug is in the bootloader and also different issue.

Posted: Sun Apr 01, 2007 4:20 pm
by Haos
Post edited with accordance to hto directions.

Posted: Tue Apr 03, 2007 12:46 am
by gececi_78
my computer: celeron 2.4,intel865 mb, 40gb ide hdd,256ram,52idecdrom
iso : livecd-26249-rel.7z

ReactOS will fail to boot for the first time.

sorry bad english :(

no luck with virtual pc 2004

Posted: Tue Apr 03, 2007 3:48 pm
by Paul Conway
I tried to run ReactOS 0.3.1 using Virtual PC 2004.
No luck with either the live CD or the install CD.
In both cases it hangs when the logo screen appears.
I am confused by the preceding comments in this thread.
Is there something I can do that would make it work, or not?

Don't know what QEMU is. Never tried that.
I gave Parallels a try-out a while ago but seemed much
the same as Virtual PC 2004 so I went back to that.
Is Parallels worth trying again to make 0.3.1 run?

Posted: Tue Apr 03, 2007 6:34 pm
by Z98
ReactOS will not run on VPC because of some stupid things MS did. Of all the virtual machine systems out there, VPC is arguably the worst. Use either VMware or QEMU, those are the only two confirmed VM systems that work.

non-virtual trials

Posted: Thu Apr 05, 2007 6:50 pm
by Paul Conway
I burned CDs of ReactOS.ISO and ReactOS-LiveCD.ISO.
I tried each of them out directly on my PC, no emulation.
Both froze at the ReactOS logo screen.
(With ReactOS.ISO I was able to do the install ok,
it was the boot thereafter where it froze.)

My machine is home-built.
It has an Asus motherboard, with a 1.8 GHz 32-bit AMD
processor (equivalent to 2.4 GHz Intel), 1 GB RAM, and
an NVidia video card that has 64 MB RAM and is DirectX
9 capable.

Ordinarily I run Windows 2000, various Linuxes,
Vista Beta 2, etc, and all work fine.

Is there a problem supporting AMD processors?

Posted: Thu Apr 05, 2007 7:12 pm
by Haos
This is other thing. This logo freeze is supposedly fixed in trunk version. I cant confirm this yet, as other bugs were introduced, thus on my HW, trunk is freezing at install (described in thread - freeze after blue.sys).

I`ll try to setup some Celeron 300 machine and test ROS there.

Paul could you please try recent trunk on your hardware?

tried vga - ok

Posted: Thu Apr 05, 2007 7:19 pm
by Paul Conway
Sorry I was using the Vesa driver shown as a default.
I did not realise I had to select VGA explicitly.
I re-installed, selecting VGA.
Now I get it to boot ok.

Once it boots, it asks me to install audio drivers,
ethernet drivers, and video drivers. It did not get
far with any of those, leaving me in the 640 x 480

My video card is an NVidia MX440-T8X with 64 MB RAM.
My Asus board is a KT4V-series, and it has an ethernet
controller that is not recognised directly by Windows 2000,
so it has to have its own driver installed. I might try
putting in a bog-standard NIC just out of curiosity,
to give ReactOS an easier time installing a driver for it.

Anyway I am up and running, albeit with big pixels.
Sorry for all the fuss.

Posted: Thu Apr 05, 2007 8:11 pm
by Haos
This is typical for 0.3.1 running on real hardware.

Could you try latest trunk version?

using the trunk

Posted: Thu Apr 05, 2007 8:30 pm
by Paul Conway
I presume you mean within the source repository,
so I would need to do my own build etc.
I am not at a stage at which I am able to do that.
I have only used the released ISOs.

When I have more time (if ever!) I would certainly
like to be more involved, but for now I am not able
to do so, much as it intrigues me.

Posted: Thu Apr 05, 2007 8:36 pm
by Z98
SVN server builds an ISO every time someone makes a commit.

Just go to the highest numbered bootcd. It can be either debug or release, doesn't really matter which you choose.

Progammers Duty

Posted: Fri Apr 06, 2007 12:40 am
by ubion
A progammer inserts visible milestones. So the exact state of the machine prior to the error is known.

Re: Progammers Duty

Posted: Fri Apr 06, 2007 2:40 am
by mikedep333
ubion wrote:A progammer inserts visible milestones. So the exact state of the machine prior to the error is known.
You can bombard the user with info in your program if you want, but a ReactOS programmer uses debug information. Here is one method of getting it. ... ut_to_file

tried bootcd-26289-rel.iso

Posted: Mon Apr 09, 2007 4:17 am
by Paul Conway
As per recent suggestion...

Well I finally found some time so
I went to the iso directory and downloaded
the latest bootable image ie
bootcd-26289-rel.iso which I tried in Virtual PC
but it did not run. No matter...

But then I burned it to a CD and tried to boot from it
to install to a blank hard disk. The blue boot screen came
up and there were a few messages on the bottom line
saying loading ntkernel.exe etc.

Then it hung.

My PC has an AMD processor.
I don't have any Intel-based PCs that I could try out
at the moment.

I do have an old machine with a relatively dumb
graphics card (no acceleration) that I could try,
incase the hang is to do with my NVidia card.

However, let's suppose I do get this latest version to boot,
and install it ok. I have an application program of my own
(a text editor) which would execute under ROS 0.3.0 up to
the point where it actually opened its window on the screen.
So far under ROS 0.3.1 I cannot get it to run at all.

So I am wondering what in general is the state of Win32
functions support. I presume the support for them comes
from WINE? Or does it? How does ROS support Win32 funcs?

On the assumption that WINE sits on top of a Linux/Unix core,
how would WINE work with ROS, given that ROS, as I understand
it, is not really a Linux/Unix, but an implementation of the basic
functionality of a true Windows-like OS? So how then does WINE
work with it? Or is that not what happens?

Is there a list of Win32 functions and their current
implementation state, so I can figure out which ones
I can use, and which ones to avoid?
Obviously my text editor uses file i/o, dir scanning,
and GUI funcs (it uses MDI). It can also make use of
some common controls and COM, but I can suppress
those features if need be.