Page 1 of 1

No Mouse under real hardware

Posted: Mon Feb 07, 2005 3:35 am
by booter
Was wondering if anyone else hasn't had the problem of no mouse under real hardware. I have a ps2 mouse, it doesn't detect it in the blue screens, and even when I set it up, it doesn't show up at the desktop level, or even the setup screens. The qemu version I tried the mouse worked on, but VERRRRRY slowly.
Also the attempt at loading a floppy bootloader doesn't work, keeps saying no floppy....

Leadtek ncr18d pro mainboard nforce 2
processor Athlon Xp2k +
512 megs ddram
40 gig hard drive w/various attempts at formatting, no help
sony cdrw 12x
Geforce FX 5200 128 meg
standard ps2 mouse and keyboard (well, mouse is actually wireless, but it mimics a standard ps as it is a cheap one)
Lucent Win Modem 56k

Thanks in advance for any help

Posted: Tue Feb 08, 2005 11:23 pm
by BrandonTurner
i have a logitech wireless mouse and keyboard and the mouse part from the receiver is ps2 and that doesnt work with .2.5. thats all i know.

Posted: Wed Feb 09, 2005 2:39 pm
by Mrkaras
I have a USB mouse and i have found that my BIOS will suport the USB enough that i can use it in reactos, but it was not right, i jumped around randomly so i pluged in a ps2 mouse and now they both work fine (i put the ps2 aside and use the usb). The mouse only applies to the desktop as far as i know not any of the startup blue screens and if you have a mouse on these withe emulated hardware i suspect that it may be due to the emulation and not a real representation of the mouse in the OS.

I have no problem with a ps2 mouse at desktop level and dont think there should be one onb blue screens

Posted: Wed Feb 09, 2005 5:57 pm
by zoken
i think that the USB is not supported for the moment