How to install without booting from CD

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Posts: 5
Joined: Thu Aug 17, 2006 9:44 pm

How to install without booting from CD

Post by formula13x » Thu Aug 17, 2006 10:04 pm

I've got an old laptop I'm trying to get some use out of. It has a swappable cd drive and a swappable floppy. Only one can be in the system at a time. The laptop can not be booted from CD.
I have Linux installed on one partition, and DOS installed on another partition. I was interested in "testing" reactos out on this laptop, but I don't know how to install it in this situation.

Is there a way for me to boot into my DOS partition with CD Rom support and then kick off the install?

I have LILO installed as my bootloader to be able to boot to my different linux kernals and to my dos partition. After I install ReactOS, I would still like to have this functionality.. :)

Posts: 82
Joined: Tue Dec 07, 2004 1:39 pm

Post by loki1985 » Sat Aug 19, 2006 12:13 am

1) create FAT32 partition.
2) install ROS via ISO to a HD image inside QEmu
3) copy HD image contents to newly created partition, using some tools for exploring RAW HD images, can be found on the internet, i just found one driver for windows.
4) insert freeloader.sys into LILO config (should work, i only use GRUB)...

thats the theory, hope it helps...

Posts: 5
Joined: Thu Aug 17, 2006 9:44 pm

Post by formula13x » Tue Aug 22, 2006 5:45 pm

I created a new fat32 partition.
Booted to linux.
Mounted the ReactOS ISO, and the fat32 partition.
Copied the contents of the ReactOS ISO to the fat32 partition.
I downloaded GRUB for dos and installed this onto my existing DOS partition (fat16 for what it's worth).
Booted into dos.
Manually created the freeloader.ini
From Grub for dos I loaded booted freeloader.
In the FreeLoader v2.1 ReactOS Boot Manager, I try to boot ReactOS or

ReactOS Debug, and either instance I get the message (NTOSKRNL.EXE not found)

The NTOSKRNL.EXE exist in the ReactOS directory.

What do I need to do now?

Here is the freeldr.ini I used


TitleText=ReactOS Boot Manager

[Operating Systems]
ReactOS_Debug="ReactOS (Debug)"



Note, how this it is using partition 2 (which is the fat32 partition)
I also tried installing reactos on the fat16 partion and trying to boot from fat16 with the same effect (does ReactOS require fat32?) In either event, I still get the (NTOSKRNL.EXE not found) from the ReactOS Boot Manager.

Posts: 295
Joined: Mon Jun 13, 2005 12:16 pm

Post by GreyGhost » Sat Aug 26, 2006 6:24 pm

If you havent installed it off a cd.... i'd say make sure that you've got the directory tree structure correct..... i'd say create a vm using QEMU install ROS there and then try to copy the files .....
I dont know if this will work (i'm not very good at this stuff.....) but hopwe it works....

Posts: 82
Joined: Tue Dec 07, 2004 1:39 pm

Post by loki1985 » Mon Aug 28, 2006 10:51 am


this part must be correct, try to play around with the partition(x) setting, worked for me.. my partition was 4 or 5 tho i never understood why....

Posts: 5
Joined: Thu Aug 17, 2006 9:44 pm

Post by formula13x » Thu Sep 07, 2006 3:12 pm

I'm not gaining much ground on this.
I didn't really understand the QEMU solution. I'll read into this some (haven't used QEMU much)

I was able to find a way to boot from CD.
I installed Smart Boot Manager to provide support for (indirect) CD-ROM booting.
But even the install from CD doesn't work for me.. I have opened another thread on this here

Posts: 7
Joined: Sun Jun 04, 2006 12:40 pm

Post by .t. » Sat Oct 14, 2006 3:44 pm

Well. To get this to work, I used to create a fat32 partition and mount it in Linux. Then, you either use the ROS_INSTALL variable or point <reactos-src-path>/reactos to the mount point (as a symlink). I chose the latter. Then, build freeldr.sys (you can use either of the CD targets to do this; find it in output-i386) and copy it to the mount point. Create freeldr.sys yourself, and in the sources root, run "make install". Add freeldr.sys to GRUB or LILO of whatever, and on next boot, see if it works. It did for me, but isn't any more. I suspect this is because I don't have it on a primary partition...

Posts: 18
Joined: Sat Jan 07, 2006 10:39 pm

Post by Davy » Mon Oct 16, 2006 6:22 pm

lol funny, id love to get reactos to function on my 486 laptop, but it keeps rebooting when booting freeldr :( the specs are 486DX @ 50MHz, 300mb harddrive, 16mb of ram.

Posts: 295
Joined: Mon Jun 13, 2005 12:16 pm

Post by GreyGhost » Tue Oct 17, 2006 11:01 am

I think its the 16 mb ram .... the regular builds will need at least 64 mbs... or was it 32 ? ... but i'm pretty sure its not 16....

Posts: 108
Joined: Thu Jul 07, 2005 4:08 pm

Post by Andrewm1986 » Tue Oct 17, 2006 11:47 am

Installer needs 32MB but reactos, once installed, will run on 16MB

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests