Page 1 of 1

Installing into existing partition

Posted: Mon Jul 31, 2006 4:10 am
by amdmi3
Hi!
I've run into a problem installing ReactOS into existing partition.
I want to install many systems for testing purposes, and, as there are only 4 partitions, I use grub to provide different partition tables for every OS I boot, so I need all partitions to be aligned nicely and not overlap (I've also ensured that partition bounds are cylinder-aligned) - that's why I want to create empty partition with type 11 (dec) first, and then try to install ReactOS into it - to be sure neighbouring data is not damaged.

Installation seem to go without problems (I choose my partition, then to format it with FAT32, then install boot loader on a floppy), but then I just can't boot the OS. It turns out that not all needed files are actually installed onto filesystem - there's only ReactOS folder, and no Documents and Settings, Program Files, TEMP, bootsect.old, freeldr.{ini,sys} that are installed normally.

Some details:
- when ROS' setup creates partition itself, ROS then installs without problems.
- partitions were ~4gb in the beginning of disk
- tried in qemu 0.8.1 under FreeBSD

Posted: Mon Jul 31, 2006 8:48 am
by GreyGhost
Welcome to ReactOS !!!
I'm pretty sure that those files are created after the second stage setup ....
freeldr (ini, and sys) will be on the floppy .... u must boot using the floppy (see ur bios setting whether it is set to boot from floppy)....If ur getting some errors there then please report back !!
also ... considering that you are using grub i'd suggest that u go through this page.....
http://www.reactos.org/wiki/index.php/H ... _from_GRUB

P.S. Please bear in mind that ReactOS is still in alpha stage and is not recommended for everyday use.

Posted: Mon Jul 31, 2006 2:17 pm
by amdmi3
Yeah, you have the best wiki covering QEMU and Grub issues, but still I can't use GRUB, because there's no /freeldr.sys on the filesystem. I think the problem in here: when I install into partition created by myself, grub doesn't give me an option of installing boot loader on the hard disk. That's strange: as I've understood from the source, this only depends on primary partition type (and the type IS compatible). I think, I'll try to hack the installer code a bit and also try to copy files from successfull installation.

Posted: Mon Jul 31, 2006 2:21 pm
by GreyGhost
If you have selected "Write bootloader to floppy" and if setup has completed properly.... you'll find the freeldr.sys and the ini on the floppy..

Posted: Wed Aug 02, 2006 2:57 am
by kopinux
im also having some installation problems, i run it before.
i wish the next version has a better boot system, that even grub can detect it.

after installation, the loader was written in mbr, the freeldr, bootsect.ros is in there, but i wonder it was saying "partition is not found" or "ntoskrnl.exe is not found" it even place a selection in the windows boot.ini.

Boot floppy writing working now?

Posted: Wed Aug 09, 2006 12:46 pm
by steveh
>If you have selected "Write bootloader to floppy" and if setup has completed properly.... you'll find the freeldr.sys and the ini on the floppy...

I remember that some time ago (months) writing the boot system, in installer, to a floppy did not yet work. Is it OK for now in the 0.3 RC1? in the 0.4 SVN?