Page 1 of 1

Trying to install ReactOS on Compaq nc6120

Posted: Wed Jun 05, 2019 8:10 pm
by Askareth
So it installed fine, I even installed the graphic driver and it worked, but I have a LOT of drivers that aren't working. I don't even have USB working. (0.4.11, 20190303-0.4.11)

I was curious if there was any workaround I could do to make it work better? (sorry for the potato quality, it's a pain to get it from the laptop to my computer without USB): https://imgur.com/a/6jCKO2h

Thanks for the help!

Re: Trying to install ReactOS on Compaq nc6120

Posted: Thu Jun 06, 2019 12:07 pm
by Reactions
For USB, you might want to try to install a nightly build.

That might also help the driver issues. However, if you can find the temporary installer files, move them to somewhere else before closing the original. There is usually an actual installer that works. This is true for the Intel XP Ethernet drivers.

Re: Trying to install ReactOS on Compaq nc6120

Posted: Thu Jun 06, 2019 3:34 pm
by karlexceed
Askareth wrote:
Wed Jun 05, 2019 8:10 pm
I have a LOT of drivers that aren't working.
In short, if it's designed for Windows XP or Server 2003 SP2, it should work. If it doesn't, then you can check in Jira ( https://jira.reactos.org ) to see if it's a known issue. If it's not and you can get good debug info, you can file a bug report ( https://reactos.org/wiki/File_Bugs ) to hopefully help the devs fix it.

For USB specifically, you can always try an old VGal USB build: http://vgal.ru.com/downloads/bootusb-Re ... gal.iso.7z

Re: Trying to install ReactOS on Compaq nc6120

Posted: Fri Jun 07, 2019 12:49 am
by Askareth
Yeah but apparently the drivers are ACPI, I assume they're included with WinXP and such since they don't appear in a new install without drivers? Wifi drivers don't finish installing and ethernet drivers don't seem to do anything, weirdly enough