Page 1 of 1


Posted: Tue Mar 12, 2019 2:20 am
by Plug Nickel
Just discovered ReactOS beta version and my curiosity was peaked because XP is slow on the PC and due to custom hardware / drivers, Linux won't load. I understand that it is in beta development but the thought of a Windows compatible open source OS is hard not to try.

I downloaded the latest build to try to load on a old OQO 2 UMPC that came with windows XP to see if I could load the OQO drivers but after loading a few drivers when I ran the install CD, it hung on a black screen.

I believe this is caused by buggy USB drivers?

If so, is this currently being addressed? USB is the only method available to load software on this machine.

Also, is there anyway to create a live disk to try future versions (yes, I know it will be slow) without actually loading it onto the machine?

Thank you,


Posted: Tue Mar 12, 2019 11:25 am
by dizt3mp3r
If you found the beta version, you searched harder than me. ReactOS is in ALPHA. Read the installation instructions link in my signature below.


Posted: Tue Mar 12, 2019 11:53 am
by oldman
Plug Nickel wrote:
Tue Mar 12, 2019 2:20 am
I downloaded the latest build
What do you mean by "latest build"? The 0.4.11 release from Sourceforge or one of the regular source tree builds from

I suggest that you get the very latest ISO image from, because there has been a commit to the source tree, just 11 hours ago, which may help you get further. See the text here


Posted: Tue Mar 12, 2019 9:30 pm
by Plug Nickel
Sorry, I meant Alpha but my fingers have a mind of their own sometimes.
Thanks for pointing me to the links and I'll download it this time from here and not Source Forge and try it again.


Posted: Wed Mar 13, 2019 11:14 am
by dizt3mp3r
Just be aware of ReactOS limitations being in Alpha and lower your expectations of replacing Windows now. Do it for fun, for testing on a VM or on test hardware, enjoy the slog, see what ReactOS will do with a particular piece of software that you aspire to run, get an idea of how ReactOS WILL operate in the future in a few years time. Join the community.


Posted: Wed Mar 13, 2019 8:11 pm
by Plug Nickel
Tried both the reactos-livecd-0.4.12-dev-863-g77e0409-x86-gcc-lin-dbg.iso as well as the liveusb-ReactOS-0.4.10-vgal.iso and ran into the dreaded swenum.sys hang.

Since I can only run or load via a USB drive, it looks like I'm gonna have to wait for the USB fix.

Thanks for your help