Page 1 of 1

Wiki not loading?

Posted: Mon Apr 23, 2018 4:42 pm
by mrmajik45
Is it just me or is the wiki timing out with a 504 error code? Is ReactOS's server for the wiki overloaded?

Re: Wiki not loading?

Posted: Mon Apr 23, 2018 5:01 pm
by oldman
I am not experiencing any problems.

Re: Wiki not loading?

Posted: Mon Apr 23, 2018 5:06 pm
by mrmajik45
Probably my internet...

Re: Wiki not loading?

Posted: Mon Apr 23, 2018 6:02 pm
by Adcock
Do you use any vpn or proxy ?
Look
If you can use any search engine then you might find more information.
( I am confident that I am not an expert at this )

Re: Wiki not loading?

Posted: Mon Apr 23, 2018 6:09 pm
by mrmajik45
no vpn or proxy. The wiki worked until today.

Re: Wiki not loading?

Posted: Mon Apr 23, 2018 10:40 pm
by mrmajik45
Hmm when logged out of my account it loads. But if im logged in it doesn't load.

Re: Wiki not loading?

Posted: Tue Apr 24, 2018 9:32 pm
by middings
The log in state of the ReactOS Wiki sometimes fails when multiple pages of the ReactOS.org web site are on multiple browser tabs.
Perhaps an interruption of the session triggers the problem. A session could be interrupted by suspending or hibernating the PC or by closing the browser then restarting the browser and reloading the session (restoring all the tabs previously open) later.

(From now on, mrmajik45, please describe exactly what you did that led to the difficulty you are having. I am tired of guessing.)

I happened to have been logged into the ReactOS Wiki on another tab of my browser (Firefox 52.7.3 ESR) when I saw this thread. I tried to reproduce the problem you seem to be having.

I opened that tab with a ReactOS Wiki page, It showed me to be already logged in. I logged out of the wiki by choosing "Log out" at the top of the web page. This caused the web page at https://www.reactos.org/user/logout titled "Access denied |ReactOS Project" to appear. This page looks like an abbreviated version of the ReactOS.org home page (front page) and has the message "You are not authorized to access this page." Choosing "Login" on that page just took me to the footer of the same "Access denied | ReactOS Project" page.

I suspected that the "Login" link is supposed to be https://www.reactos.org/#footer instead of https://www.reactos.org/user/logout#footer. I went to the ReactOS.org home page (also called the front page) by clicking on the ReactOS logo in the upper left corner of the page. From there I chose the "Login" link at the top right of the page. My browser jumped to the log in fields (username, password) in the footer (at the bottom) of the ReactOS.org home page. I logged in. Then I went to the top of the ReactOS.org home page and chose the link marked "Wiki". That took me to https://www.reactos.org/wiki/Welcome_to ... pment_Wiki page. I navigated back to the wiki page I had been on when this adventure began. I could see that I was again logged in to the wiki and the page was ready for editing.

Re: Wiki not loading?

Posted: Tue Apr 24, 2018 10:43 pm
by mrmajik45
It's working today.