ReactOS: Internet Adapter not working in Virtual Machine.

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Disbxnd
Posts: 2
Joined: Sun Mar 11, 2018 5:20 pm

ReactOS: Internet Adapter not working in Virtual Machine.

Post by Disbxnd » Sun Mar 11, 2018 5:33 pm

Hello,
I have just recently installed ReactOS onto a virtual machine and the built-in Internet Adapter isn't working even though it says in VirtualBox that it is plugged in. No internet is working. I tried going into the Program Manager and it said something about an "SSL error".

I would love to test out ReactOS and can't because of this bug.



Thanks,
Disbxnd :lol:
Where we dropping boys?
- Fortnite Players Everywhere

Disbxnd
Posts: 2
Joined: Sun Mar 11, 2018 5:20 pm

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by Disbxnd » Sun Mar 11, 2018 5:38 pm

Also, restarting my VM after an "ACPI Shutdown" keeps doing this https://imgur.com/Ine3EUl
Where we dropping boys?
- Fortnite Players Everywhere

cernodile
Posts: 57
Joined: Wed Nov 01, 2017 7:01 pm
Location: Estonia
Contact:

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by cernodile » Sun Mar 11, 2018 8:38 pm

Use PCnet-FAST III adapter rather than the default one. SSL error might occur in 0.4.7 due to recent server change, try using 0.4.8 RC1 or latest nightly build.
My working rigs:
Dell Latitude E5430 on 0.4.9-vgal - i5-3340M, 8GB (4 utilized) DDR3-1600MHz RAM, booting off a USB.
Image

dodger4
Posts: 6
Joined: Thu Mar 15, 2018 6:10 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by dodger4 » Thu Mar 15, 2018 7:15 am

I need help installing an adapter, then setting up networking.

Device Manager - has no network adapter listed in the resources. How do I install a virtual one please? In fact how do I get into the control panel?

I am running Win10 on a Lenovo 910 with a SSD.

dodger4
Posts: 6
Joined: Thu Mar 15, 2018 6:10 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by dodger4 » Thu Mar 15, 2018 7:17 am

This thread: HOW TO: Install ReactOS Networking on Virtual PC

describes setting up on a WinXP machine, but the 2 files referred to are not in Win10

karlexceed
Posts: 391
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by karlexceed » Thu Mar 15, 2018 3:20 pm

viewtopic.php?f=4&t=16047#p128823

Once your VirtualBox has the correct virtual hardware, ROS should be able to see that and make use of it.

oldman
Posts: 1040
Joined: Sun Dec 20, 2009 1:23 pm

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by oldman » Thu Mar 15, 2018 6:39 pm

Have a look through this wiki page! It describes how to get a working VirtualBox.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

dodger4
Posts: 6
Joined: Thu Mar 15, 2018 6:10 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by dodger4 » Thu Mar 15, 2018 8:21 pm

The interface for "Settings" does not look like the one shown in that thread. I have read it before. When you click "Network" in the interface I have, you are offered links that say:

(Hardware links) In network adapter, I assume there's meant to be one listed - it just says "not connected". When you click it, the right pane contains elements I do not understand. Nowhere to add an adapter, or virtual adapter of course.

It would seem to me that you need to add an adapted in an "Add Hardware" dialog, and I cannot find that. I cannot discover how to get into the Control Panel. My memory of WinXP is becoming clouded by the forced adoption of Win 10...which I dislike intensely.

Management links: Name, Integration Services, Checkpoints, Smart Paging File location, Automatic start action, Automatic stop action.

dodger4
Posts: 6
Joined: Thu Mar 15, 2018 6:10 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by dodger4 » Thu Mar 15, 2018 8:23 pm

I am currently looking at the Wiki page. Thanks.

karlexceed
Posts: 391
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by karlexceed » Thu Mar 15, 2018 9:17 pm

Post some screenshots of what you're seeing in VBox; this doesn't sound right.

Also, based on the icon on your screenshot above, it looks like you build this VM as "Linux - Other 32 bit"? That completely changes the virtual hardware that's included by default in the VBox VM. You should start with it as "Windows - 2003 32 bit".

dodger4
Posts: 6
Joined: Thu Mar 15, 2018 6:10 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by dodger4 » Fri Mar 16, 2018 12:40 am

Sorry. I used Hyper-V, not VBox. Do you still want screen shots?

dodger4
Posts: 6
Joined: Thu Mar 15, 2018 6:10 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by dodger4 » Fri Mar 16, 2018 12:43 am

I'm an ankle-biter, not the Lord of the Rings...

ThFabba
Developer
Posts: 236
Joined: Sun Jul 11, 2010 11:39 am

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by ThFabba » Fri Mar 16, 2018 9:22 am

Make sure you add a "Legacy Network Adapter". And ROS doesn't come with drivers for Hyper-V/VirtualPC's network card yet, so you need to install one.

I've been successfully using a driver for a while but I don't remember where I downloaded it. Here are the checksums for its files:
DC21X4.sys - sha256: 1cd298b8061d9f7480c5fc7ccc03a6b024bb55c7c9d7be6c3dc59c8e8cc5afbd
net21x4.inf - sha256: dd752cb93394d7f932fbbc6f88f1bf535e21e9989882ab51b18572bbddf50190

I've seen this link suggested, but don't know if it's the same driver (nor that it's malware-free or, really, anything about it). http://devid.info/lb-lu/405/Intel+21140 ... et+Adapter

If you build your own iso, you can also copy the above two files to the modules/optional subdirectory in the source tree, then ROS will automatically install that driver if it finds the right card.

karlexceed
Posts: 391
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: ReactOS: Internet Adapter not working in Virtual Machine

Post by karlexceed » Fri Mar 16, 2018 3:19 pm

Oops, I confused dodger4 with Disbxnd - wasn't looking at usernames. Sorry for the confusion.

Post Reply

Who is online

Users browsing this forum: Yandex [Bot] and 1 guest