RosBE-Unix does not find zlib - but zlib.so is in /lib

Ask your support questions in here

Moderator: Moderator Team

Post Reply
oldman
Posts: 1110
Joined: Sun Dec 20, 2009 1:23 pm

RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by oldman »

I am running Puppy Linux from a USB stick and I am trying to install RosBE-Unix, but the builder script says that it cannot find zlib, though zlib.so is in the /lib directory.
Anyone got any ideas of what is going wrong or how to make the script find it?
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

User avatar
Fraizeraust
Posts: 233
Joined: Thu Jan 05, 2017 11:46 am
Location: Italy
Contact:

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by Fraizeraust »

What is the architecture of the Puppy Linux OS you are using? Most of the time Linux complains about shared libraries, files, etc. for the mere reason that they are built for a specific arch whilst your arch OS differs. In other words, Puppy tells you that the specific zlib SO compatible for your OS is missing. I may be wrong though.

You can run this command as follows (as long as Puppy Linux supports APT, never used such a distro like this) to install required zlib files so the script won't complain anymore. You can append :i386 architecture at the end of the package's name in any case if it's needed.

Code: Select all

apt-get install zlib1g-dev

MadWolf
Posts: 556
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by MadWolf »

hi
i got the same error on debian jessie

i commented out the line

Code: Select all

rs_needed_libs="zlib"
in RosBE-Builder.sh and i am not getting any errors so far i will update this if i get any errors

edit
it looks like it Finished successfully

oldman
Posts: 1110
Joined: Sun Dec 20, 2009 1:23 pm

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by oldman »

Fraizeraust wrote:What is the architecture of the Puppy Linux OS you are using?
It is based on Slackware.
Fraizeraust wrote:apt-get install zlib1g-dev
apt-get is not supported. zlib1g-dev is not found by the package manager!

I had already installed zlib and it looks like I have multiple copies too! It just is not found by RosBE-Builder script.
MadWolf wrote:I commented out the line rs_needed_libs="zlib"
Well, that got the script further, but it is now complaining that it cannot find one of it's own files! It is there, but for some unknown reason, it cannot find it.
By the way, I have changed the file permissions, so that is not the problem.

I am only doing this to be able to add Unix support to my layman's guide!
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

MadWolf
Posts: 556
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by MadWolf »

hi
http://puppylinux.org/main/Overview%20a ... tarted.htm
what version of Puppy Linux are you ruining ? is it the latest release or an older release
32 or 64 bit?

oldman
Posts: 1110
Joined: Sun Dec 20, 2009 1:23 pm

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by oldman »

I don't think that is much help; I have messed around with Linux off and on since the late 90s, so I have a little knowledge of Unix.
what version of Puppy Linux are you ruining ?
32 or 64 bit?
I am running (when I use it) Slacko 6.3.2 - 32bit.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

MadWolf
Posts: 556
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by MadWolf »

hi
you may need to reinstall Puppy Linux Slacko

open puppy package manager and install the following
Note you do not need to do this step you can skip to the last step
bison
flex
gcc
gcc-g++
grep
make
texinfo
libz
python 2.7.5
open Sfs Manager and install Development Libraries
edit
i have not tested compiling reactos but i do not get any errors installing the Build Environment

oldman
Posts: 1110
Joined: Sun Dec 20, 2009 1:23 pm

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by oldman »

MadWolf wrote:hi
you may need to reinstall Puppy Linux Slacko
You are probably right; it is now getting a little messed up!
MadWolf wrote: open puppy package manager and install the following
Note you do not need to do this step you can skip to the last step
bison
flex
gcc
gcc-g++
grep
make
texinfo
libz
python 2.7.5
All these dependencies are maked as OK. I managed to get it to find zlib by installing the binutils package (I think that was the one).
MadWolf wrote: open Sfs Manager and install Development Libraries
edit
I have not tested compiling reactos but I do not get any errors installing the Build Environment
I must admit that I do not know how to use/install squash file system packages.

EDIT: It is simple, just use (as you said) the sfs manager!

Thanks.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

oldman
Posts: 1110
Joined: Sun Dec 20, 2009 1:23 pm

Re: RosBE-Unix does not find zlib - but zlib.so is in /lib

Post by oldman »

Problem now solved.

I have run Slacko from a CD and I have installed the Sfs Development Libraries. The RosBE-Builder script now completes.

There must have been some dependency, which was not in the individual packages.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest