ReactOS on a HP Compaq 8510p

Ask your support questions in here

Moderator: Moderator Team

Post Reply
User avatar
matthiasbasler
Posts: 38
Joined: Sun Sep 18, 2016 9:53 am

ReactOS on a HP Compaq 8510p

Post by matthiasbasler »

I have been testing ROS 0.4.2 to 0.4.10 (trunk) on my HP Compaq 8510p business notebook, using a fresh conventional HDD and the boot CD. This is not an application test, I was only interested in getting the hardware/drivers to work.

Current status as for 0.4.10 trunk is: ROS is not yet usable for any serious work on this machine, mainly because VGA and sound drivers don't work. Some drivers work, others fail or even cause ROS to fail rebooting after installation.

What works:
4.6+: USB Stick works, so I can install drivers from it (but ROS often freezes when the stick is detached and there is no "safe detach" icon)

Intel Chipset Driver for ICH8 (v8.2.0.1012)
- Unzips, executes and exists successfully.
HP Ethernet Drivers (c1.0.0.8)
- Unzips, executes and exists. Internet works (not even restart needed). Tested using application manager.
Ricoh Media Card Driver (v2.10.00.04)
- Finishes OK, but the SD card slot does not work. (SD cards are not recognized and shown in the explorer.)
Ricoh R5C853 DVD-Burner (v1.01.05)
- Installation is OK. Functionality not checked.
HDA Modem (High Definition Audio Modem)
- Seems to install. Functionality not checked.
Synaptex Touchpad (v13.2.6.2e)
- Touchpad itself works already on vanilla ROS
- 0.4.4: Shows "Gerätetreiber werden gesucht" -> Searches eternally for devices -> Reboot.
- 0.4.2, 0.4.6+: Installs and works (Touchpad is listed in device manager)
- 0.4.10: Installs and shows touchpad in device manager, after reboot touchpad does *not work any more*.

What does not work: (sometimes not quite unexpected)
ATI Video Driver and Control Panel (v8.65 and others) for ATI Mobility Radeon 2600 -> CORE-14479
- requires VC++ 6.0 Runtime, otherwise: "MFC42.dll was not found"
- VC++ 6.0 Runtime installation does not work on ROS 4.x, so I unzipped the file and installed via .inf file.
- on next attempt: "Unable to load ATICIM.dll", but installation seems to continue. Dialog "Express" vs. "Custom" appears. Then application suddenly disappears.
- Setup.exe complains: "Setup konnte die Installation nicht starten."
- Setup.exe in "Driver" subfolder "ATI-Treiber-Setup" reports not to find a suitable driver.
- Driver can be installed by pointing Device manager to c:\swsetup\SP51066\Driver\XP_INF
-> Finds and installs Radeon HD2600 driver, but after reboot ROS only shows desktop for a second, than back.

P.S: The Control Center (CCC) can be installed from the deflated setup, but does not start as it requires and does not recognize the installed .net 2.0 Runtime.

GMI 915GM Video Driver (for Win2000/WinXP)
- Setup-Programm only shows empty blue window, freezes with CPU at 100% CORE-13774
UAA Bus Driver for HD Audio (v1.00B3 and others)
- Setup cancels with error (-5011 : 0x80040707) in SetupDLL.cpp
- No change with compatibility modes.
Soundmax Sound Driver
- requires UAA Bus Driver (which does not work, see above)
HP QuickLaunchButtons
- Complains: "Diese Software wird auf diesem System nicht unterstützt." (aka "Not supported on this system.")

Audio Microsoft Bus (KB835221) für Win2003 (v5.10.1.5013)
- Complains: "Das Setup kann keine Debugversion des Systems mit einer Retailversion von KB835221Srv2k3 (und anders herum) aktualisieren."

What does not work and renders the system unusable
Matrix Storage Manager (v8.9.8) ("for improved SATA disk performance")
- Up to 0.4.6: Setup cancelled with "Fehler beim Kopieren der Dateien" (aka "Error copying files") after copying of "removdrv.txt".
- ROS 0.4.7+: Setup finishes successfully.
- ROS 0.4.10: Setup finishes successfully, but BSOD after subsequent reboots
(<0.4.13) Intel Pro Wireless Drivers (v8.20C)
- Setup makes ReactOS freeze completely -> requires hard reboot, after which ROS freezes after searching drivers.
- With ROS 0.4.13, after the reboot the system starts up normally.


Nasty bugs and issues encountered:
0.4.2-0.4.10: Native display resolution of 1280x800 not available to choose. (Have to use 1024x768, which looks ... meh.)
Trying to choose a resolution higher than my notebook screen produced striking colors and stalled the system. From now on ROS didn't show anything after startup, I had to completely re-install it. (Safe mode or the like didn't help.)
0.4.2/0.4.4: If the USB mouse is connected to the notebook on ROS startup, startup hangs forever at showing ~75% of the loading bar. Reproducible. I always have to disconnect the mouse before ROS startup and re-connect it afterwards.
From 0.4.6 on: This hangup occurrs on a vanilla ROS, but after drivers are installed the issue disappears.
0.4.2-0.4.8: Explorer doesn't remember the folder display settings (Icons vs. List vs. Details). Just change to parent folder and back and you see the icon view again.
0.4.2-0.4.7: Deleting folders containing files is unreliabe. (Sometimes it works, most times the folder disappears but after refresh it is there again, an often enough now the files within show cryptic file names and make ROS freeze when trying to delete them. Sometimes nothing seems to happen at all.)
0.4.4-0.4.6: On every start ROS tries to install missing drivers for "new" hardware, which (of course) always fails. It is unnerving having to click through a dozen dialogs every time after re-start. (Does not happen on 0.4.7+.)

Matthias.
Last edited by matthiasbasler on Sun Oct 27, 2019 6:04 pm, edited 8 times in total.

Reziac
Posts: 24
Joined: Fri Dec 23, 2016 7:35 am

Re: ReactOS 4.4 on a HP Compaq 8510p

Post by Reziac »

I had the same problem with both the default file explorer and "explorer_old.exe" -- sometimes one would work but not the other; sometimes I could only drag and drop from one version to the other version (but not within the same version); PASTE is often greyed out despite that I just COPY'd something; sometimes nothing happens; in one case, when I tried to move a new shortcut to the desktop, it rewrote both the shortcut and the associated .exe as zero-byte files. Then it might work perfectly two tries later. Refresh almost never works right with regard to folders, and folder deletion only works sometimes, but is more likely to fail the longer ROS has been running.

I am not sure it's the file manager(s); I'm inclined to suspect a bogus interaction with the filesystem, or a bug in the FAT (which may manifest only when ROS is installed on real hardware as I am doing, rather than in a VM), as this reminds me of what happens when on a FAT32 disk, you try to use a utility that only speaks FAT16. This would also explain why Explorer++ initially worked perfectly, but on 2nd use complained "failed to clean up tempfiles" and on the 3rd attempt locked up hard and would not run again, and perhaps why QDir also locked up hard (I was testing file manager replacements due to the problems noted).

And perhaps related, Buerg's LIST (a 16bit DOS app) does run in a console window, and everything works except that it cannot see the HD. I thought there was no support for 16bit programs?

Perhaps also related -- in explorer_old, folder order sorts normally, but in the default file manager, sort order is often scrambled, or partly in order by date. This again smells like a problem between it and the FAT.

User avatar
matthiasbasler
Posts: 38
Joined: Sun Sep 18, 2016 9:53 am

Re: ReactOS 4.4 on a HP Compaq 8510p

Post by matthiasbasler »

Found ROS 4.6 improvements over 4.4:
  • USB stick works (except for removing it, which kills ROS)
  • Synaptex Touchpad works again (as in 4.2)
  • Under certain conditions (unclear which) ROS 4.6 now starts with USB mouse attached (doesn't hang on startup any more)
Not yet the big breakthrough on this notebook but better than nothing.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest