Page 1 of 1

VMware ESXi 5.5, doesn't load desktop

Posted: Fri Feb 17, 2017 12:52 pm
by Refalm
Hi there,

I'm trying to run ReactOS in VMware ESXi 5.5, and I used the Boot CD.
Installation went great after I discovered not to use SCSI.

I even got the settings wizard (with locale, password, etc.). After rebooting, I got this forever:
Image

It's not loading the desktop. Did I do something wrong?

Here are some of my settings:
Image

Image

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Sun Feb 19, 2017 6:28 pm
by LuxenDM
Only thing I suggest is changing it from the guest version "Windows XP" to "Windows 2003" (if you have that option). But I dont think that is the issue...

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Tue Feb 21, 2017 4:05 am
by Z98
We would need a debug log to be able to diagnose the issue.

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Tue Feb 21, 2017 7:01 pm
by Refalm
I've changed the profile to Windows Server 2003 (32-bit), but had the same result.

What kind of debug log? Of ESXi or of ReactOS?

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Wed Feb 22, 2017 1:19 pm
by middings
Produce a ReactOS debug log because ReactOS's behavior is what is in question.
See the instructions on this ReactOS Wiki web page: https://www.reactos.org/wiki/Debugging.
Instructions for debugging when ReactOS is running inside a virtual machine are included.
The page includes a link to the page that describes how to set up a virtual serial connection from the VMWare virtual ReactOS machine target to the real machine host that is hosting VMWare. (The other virtual machines supported by the ReactOS project are also covered, but on web pages of their own.) People who run ReactOS in virtual machines find this method very helpful.

The instructions have not been updated recently. If you encounter problems search the ReactOS site for solutions. Use your favorite search engine and include site:ReactOS.org with your search string. If such a search does not reveal an answer, ask for more help here.

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Fri Mar 17, 2017 12:47 pm
by Refalm
Hello,

So I attached the serial device and output to a file.
Image

The file was empty.
If there is a printer device, I obviously can't remove it, since the desktop isn't loading.

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Fri Mar 17, 2017 5:53 pm
by justincase
In order for ReactOS to output debug logs to the serial port you need to choose the "ReactOS (Debug)" boot option.

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Fri Mar 31, 2017 10:43 am
by Refalm
Good tip. I've done what you said, here's the debug log:
https://privatebin.net/?685fdb49bbb0d9e ... fujzfcfhY=

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Sat Apr 01, 2017 5:12 am
by justincase
Good, glad to see you got that going. Looking at your debug log, it seems you're using ReactOS 0.4.4. ReactOS is a very active project so release versions tend to lag a bit behind current development, you should try using one of the debug builds from ReactOS.org/getbuilds as your issue could conceivably have already been fixed in the trunk builds since February, or if not already fixed, a debug log from the latest build would probably shed more light on what's wrong than the older 0.4.4 build.

Re: VMware ESXi 5.5, doesn't load desktop

Posted: Thu Apr 06, 2017 11:31 am
by Refalm
The latest SVN build will show the desktop, thank you :)