MB Internet Driver

Ask your support questions in here

Moderator: Moderator Team

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

MB Internet Driver

Post by theFred » Tue Jan 03, 2017 11:58 pm

I am running build 73501 on a Gigabyte GA-G31M Motherboard with a Pentium CPU. I am using this old motherboard which has 2 PS-2 sockets
so I can get both the mouse and the keyboard to work. The MB has an Atheros AR8131 PCI-e Gigabit NDIS 6.2 internet chip.
The OS loads and seems to work ( other than the USB ports ) but I cannot access the internet.

I have downloaded the install package for the internet chip and have run it. System report now shows the internet chip but says it cannot load the driver.
Thus I cannot access the internet.

Does anyone have any suggestions for this problem?

Thanks in advance for any help

Fred

EmuandCo
Developer
Posts: 4329
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: MB Internet Driver

Post by EmuandCo » Wed Jan 04, 2017 1:09 pm

Which driver for which OS did you load?
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

Re: MB Internet Driver

Post by theFred » Wed Jan 04, 2017 1:49 pm

I downloaded it from the internet...the following info is from the packet I downloaded
***************************************
Readme.htm created 30-APR-2009

Readme File for AR81Family setup package

Supporting: Qualcomm Atheros AR81Family Gigabit/Fast Ethernet Controller

Operation Systems:
Windows XP, Windows Server 2003
Windows XP x64, Windows Server 2003 x64
Windows Vista, Windows Vista x64
Windows 7, Windows 7 x64
Windows 8, Windows 8 x64
***************************************
The driver installation package contains the Qualcomm Atheros AR81Family Gigabit/Fast Ethernet Controller Driver.

This README file explains how to install the driver and installation package on a machine running one of the following operation systems:

Windows XP, Windows Server 2003, Windows XP x64, Windows Server 2003 x64, Windows Vista, Windows Vista x64, Windows 7, Windows 7 x64, Windows 8, Windows 8 x64

***************************************
Thank you,

EmuandCo
Developer
Posts: 4329
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: MB Internet Driver

Post by EmuandCo » Thu Jan 05, 2017 1:22 pm

Seems legit.... can you somehow give us a log file, like using boot method Debug (file) and send us the file in C:\ReactOS?
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

Re: MB Internet Driver

Post by theFred » Thu Jan 05, 2017 6:00 pm

Hi - I reinstalled using build 73228 since build 73501 gives me an error that it cant find wine gecko.

Since I cannot get to the internet, Applications Manager shows no programs available for installation.

Per your request, I see two files in \ReactOS. bootstat.dat and setuplog.txt

I can view setuplog.txt but cannot extract it from the pc since I have no floppy attached, the cd burner doesn't work, I can't access the usb ports and I have no internet. Overall the setuplog.txt seems to show no errors.

I don't have a program to open bootstat.dat...all I see are jiberish characters.

?????

Thanks

Fred

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

Re: MB Internet Driver

Post by theFred » Thu Jan 05, 2017 6:02 pm

Is it possible that the Atheros drivers don't work with Fat32?

menuhin
Posts: 21
Joined: Sun Dec 30, 2012 12:19 am

Re: MB Internet Driver

Post by menuhin » Fri Jan 06, 2017 1:38 pm

The file is debug.log named.

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

Re: MB Internet Driver

Post by theFred » Fri Jan 06, 2017 7:01 pm

I finally managed to generate a debug.txt file but I have no way to extract it from the pc.

PROGRESS!!!
I loaded 73499. During the install I received an error that there was no Wine Gecko installer. Then I installed Atheros driver 1.0.0.14 and now it shows that the driver is working. The green light on the internet plug on the back of the PC is now on.
I cannot access the internet with Internet Explorer ( I assume because Wine is missing ) but now when I go to Application Manager and ask for "Available for Installation", the available files display on the screen.
I have downloaded and installed a couple of programs so I assume the internet is now working.

How can I try to reload Wine? I can't find it on the hard drive.

Thanks for your help with this!

menuhin
Posts: 21
Joined: Sun Dec 30, 2012 12:19 am

Re: MB Internet Driver

Post by menuhin » Fri Jan 06, 2017 7:58 pm

Take linux liveCD to copy to usb key.

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

Re: MB Internet Driver

Post by theFred » Fri Jan 06, 2017 8:36 pm

OK - but I need more information. Is the usb key a ".sys" file and how do I install it?

Downloaded Firefox and it works ( without wine )

Now I need to get the sound to work.
Its a "Realtek High Definition Audio". I've downloaded several versions of the installation package and none of them install...they all lock up.
When I use Update Driver from the System /Hardware screen, it processes/completes but does not fix the problem.
Suggestions????

nat32support
Posts: 15
Joined: Mon Jan 21, 2008 1:18 am
Location: Canberra, Australia
Contact:

Re: MB Internet Driver

Post by nat32support » Sat Jan 07, 2017 7:45 am

Its a "Realtek High Definition Audio". I've downloaded several versions of the installation package and none of them install...they all lock up.
I'm having similar problems with my Gigabyte mainboard with Azalia codec.

I almost go there with this driver: http://www.techspot.com/drivers/driver/ ... ion/15942/ but the installer hung close to the end and made no further progress. But at least the system kept running! Maybe that one works for you?

EmuandCo
Developer
Posts: 4329
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: MB Internet Driver

Post by EmuandCo » Sat Jan 07, 2017 11:17 am

HD Audio is not working yet. In that case you have to wait a bit
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

theFred
Posts: 8
Joined: Tue Jan 03, 2017 11:46 pm

Re: MB Internet Driver

Post by theFred » Sat Jan 07, 2017 2:39 pm

The driver you referenced is version R 2.70. I have tried that version before. I did download it and it runs and then dies.....mouse still works but computer is locked.

If I can't get audio, I can't use the OS ( to listen to internet radio in an old PC in my workshop). Back to Linux Mint.

FWIW.....How would I download Wine to install ( since the build that works doesn't have Wine ) and how would I find and install the Linux USB driver you mentioned?

Thanks for working with me on this...

Fred

dizt3mp3r
Posts: 1450
Joined: Mon Jun 14, 2010 5:54 pm

Re: MB Internet Driver

Post by dizt3mp3r » Sat Jan 07, 2017 5:08 pm

Don't expect ReactOS to actually be useful! If it fails it fails.

This should just be an academic exercise as ReactOS is still alpha grade software. Simply lower expectations and be happy when something works. Then raise your hopes in the realisation that it WILL work eventually.

If you are trying to make an old machine into a media player then go straight for Linux Mint and don't waste your time. If you are happy to play with ReactOS just for testing/fixing/documenting purposes then please proceed and good luck to you either way.

osuser25
Posts: 19
Joined: Fri Dec 30, 2016 10:32 am

Re: MB Internet Driver

Post by osuser25 » Sun Jan 08, 2017 12:48 am

dizt3mp3r wrote:Don't expect ReactOS to actually be useful! If it fails it fails.

This should just be an academic exercise as ReactOS is still alpha grade software. Simply lower expectations and be happy when something works. Then raise your hopes in the realisation that it WILL work eventually.

If you are trying to make an old machine into a media player then go straight for Linux Mint and don't waste your time. If you are happy to play with ReactOS just for testing/fixing/documenting purposes then please proceed and good luck to you either way.
For a machine that old I would use Puppy Linux not LInux Mint ;)

However if you don't need to put a full OS on the machine and just want to test ReactOS on it, I am sure the community would be grateful for any reports of what you can get to work on it. :)

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests