[bug]the installing process repeats again and again

Ask your support questions in here

Moderator: Moderator Team

Post Reply
minlearn
Posts: 24
Joined: Sat Apr 09, 2011 6:43 am

[bug]the installing process repeats again and again

Post by minlearn »

i fired it at https://jira.reactos.org/browse/ROSTESTS-241

-------

i unzipped the bootcd iso into the fat32 partition,use the opts below to install it:
[Setup]
BootType=ReactOSSetup
SystemPath=\boot\imgs\rosboot\cdfiles
---------------------
cdfiles dir contains all the files unzipped from the bootcd iso into the harddisk.
after it ,i started to install it,everything goes well till the final step "choose whether to install the bootloader on the harddisk",i chose to skip it.
then i reboot my pc to enter the installed ros,before it would enter the desktop,it repeated again and again the "active componet" gui dialog.
how avoid it?

User avatar
dizt3mp3r
Posts: 1601
Joined: Mon Jun 14, 2010 5:54 pm

Re: [bug]the installing process repeats again and again

Post by dizt3mp3r »

Thank you for trying ReactOS on your computer and letting us know your result. ReactOS is still in alpha. The compatibility target of ReactOS is Microsoft Server 2003. Therefore, ReactOS may not run well on computers designed for operating systems other than Microsoft Windows XP and Microsoft Server 2003. The best hardware to try ReactOS on is hardware that originally shipped with Microsoft Windows XP (Home or Professional editions) or Microsoft Server 2003. Avoid hardware that uses a USB port for its keyboard or mouse, the ReactOS USB driver is not fully implemented and has bugs. Laptop computers often use USB to communicate with their built-in keyboard and mouse pad.

Do not be discouraged. Help the ReactOS forum community help you. Read this post:
https://reactos.org/wiki/Installing_ReactOS
and this:
viewtopic.php?f=4&t=13361#p109218

then come back to this thread that you started. Edit your initial post to add information that can help other ReactOS forum readers understand your computer and its configuration. Again, thank you for trying ReactOS on your computer.

;)
Skillset: VMS sysadmin 20 years, fault Tolerance, cluster, Vax, Alpha, ftSparc. DCL, QB45, VB6, NET, PHP, JS, CMS, Graphics, Project Manager, DOS, Windows admin from 1985. Quad Electronics. Classic cars & motorbikes. Artist watercolours. Historian.

fLuXx
Posts: 76
Joined: Sun Oct 25, 2009 11:42 am

Re: [bug]the installing process repeats again and again

Post by fLuXx »

I'm not completely sure what you've done, but from your mail, I gather you have copied the contents of a CD to a HDD, then booted from HDD, installed to (the same?) HDD, skipped writing of MBR, which causes the PC to boot the installation again. Is this correct? Because, I think this is how it is suppose to work?

minlearn
Posts: 24
Joined: Sat Apr 09, 2011 6:43 am

Re: [bug]the installing process repeats again and again

Post by minlearn »

not the installation repeated again and again from the first phase/stage
but the 2st phase/stage repeat again and again when you see the desktop and the titled "installing drivers..." dialog

oldman
Posts: 1128
Joined: Sun Dec 20, 2009 1:23 pm

Re: [bug]the installing process repeats again and again

Post by oldman »

minlearn wrote:not the installation repeated again and again from the first phase/stage
but the 2st phase/stage repeat again and again when you see the desktop and the titled "installing drivers..." dialog
Does the computer freeze or does it just reboot itself?

I have tried to install revision 74958 and can get no further than loading drivers in second stage. I have made a bug report for this (CORE-13397). The last log entry is Loading: \SystemRoot\system32\drivers\kbdclass.sys

I have found, that if you move the mouse around when you reach the loading drivers window, after a while the pointer suddenly stops. If you experience the same, then it must be the same bug.

EDIT
I have now been able to install ReactOS by disabling HDAudio in the BIOS. I have used revision 75012.

minlearn, if you are still around, then it is worth disabling HDAudio in the BIOS and then seeing if you can boot into the desktop.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

minlearn
Posts: 24
Joined: Sat Apr 09, 2011 6:43 am

Re: [bug]the installing process repeats again and again

Post by minlearn »

i will test 0.4.5

but in my previous tries, it failed everytime when i enter the 2st stage in which i can see the desktop and the "installing drivers" dialog poping up,when it finished drivers installation, it required a reboot.

the bug is : this ( all i said above) would repeat again and again after each reboot

justincase
Posts: 441
Joined: Sat Nov 15, 2008 4:13 pm

Re: [bug]the installing process repeats again and again

Post by justincase »

Hi, I'm not sure we're fully understanding what exactly is happening. Can you explain as a step by step instruction for how someone else could reproduce the exact behavior you're seeing? or maybe post a video of it?
I reserve the right to ignore any portion of any post if I deem it not constructive or likely to cause the discussion to degenerate.

minlearn
Posts: 24
Joined: Sat Apr 09, 2011 6:43 am

Re: [bug]the installing process repeats again and again

Post by minlearn »

i think this ros4realhwtest.rar exactly describled:
what i did,
and how the bug happened,
and what was the senario i came over
and how the file/folder structed when i tried


https://jira.reactos.org/secure/attachm ... hwtest.rar

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests