Dell XPS M1530 installation fail

Ask your support questions in here

Moderator: Moderator Team

Post Reply
klink
Posts: 11
Joined: Thu Jun 09, 2016 3:15 pm

Dell XPS M1530 installation fail

Post by klink »

I've tried to install ReactOS (bootcd-71594-rel) on my XPS M1530.

First problem, installation routine is slow, especially the language selection is extreme slow, pressing arrow up/down or enter button cause 30-40 second freeze.


After reaching this point, the installation hangs.
[ external image ]
Last edited by klink on Fri Jun 17, 2016 1:06 am, edited 1 time in total.

MadWolf
Posts: 554
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: Dell XPS M1530 installation fail

Post by MadWolf »

you need to get a debug log have a look at this
https://www.reactos.org/wiki/Debugging

klink
Posts: 11
Joined: Thu Jun 09, 2016 3:15 pm

Re: Dell XPS M1530 installation fail

Post by klink »

After formatting the HDD with windows, i was able to install ReactOS. But now ReactOS hangs after boot logo.

debug.log
http://pastebin.com/xzk69Bgt

hbelusca
Developer
Posts: 1165
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: Dell XPS M1530 installation fail

Post by hbelusca »

@ klink : I strongly suggest you to report your problem on JIRA (precising your hardware specs AND attaching your debug log), since you have an error that never happened before elsewhere. Not many developers actually go to the forums and would miss your problem.
To connect to JIRA, use the same credentials as the ones for the forum. Beware that it may take some time between the first connection attempt to JIRA and the first successful connection to JIRA since there needs to be a credentials database synchronization. In case of problems, please go to IRC, freenode, channel #reactos .

menuhin
Posts: 21
Joined: Sun Dec 30, 2012 12:19 am

Re: Dell XPS M1530 installation fail

Post by menuhin »

Disable USB on BIOS and do not connect USB Devices in Time Booting.

klink
Posts: 11
Joined: Thu Jun 09, 2016 3:15 pm

Re: Dell XPS M1530 installation fail

Post by klink »


User avatar
EmuandCo
Developer
Posts: 4394
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: Dell XPS M1530 installation fail

Post by EmuandCo »

Oh, UHCI tries to init... that's bad. UHCI is far from being usable. I think you have to wait until USB is more complete tbh. I am very sure that it is used internally too and disabling it will render some stuff useless for sure.
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

klink
Posts: 11
Joined: Thu Jun 09, 2016 3:15 pm

Re: Dell XPS M1530 installation fail

Post by klink »

Will GSoC work on UHCI improve this situation?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest