run ROS live to do that

Ask your support questions in here

Moderator: Moderator Team

Posts: 5
Joined: Mon Dec 26, 2005 3:18 pm

run ROS live to do that

Post by burna »

i want to ckeck this OS but i can`t run the live cd...

would someone tell me all the steps to do that'???

maybe here is anyone who speaks german...that is much better for me...hrhrhr...

so i say thx.

HF ;)


Posts: 829
Joined: Fri Nov 26, 2004 7:48 pm
Location: Austria, Europe

Post by frik85 »

1) Download the LiveCD image file. ... p?download

2) Open your favorite cd burning software (e.g. "Nero Burning Rom")

3) Search for a function called "Disc Image". In Nero for example use the Nero Express, then click on "Disk Image" and select the LiveCD file (on your harddisc).

3) Burn the CD

4) Put the CD into the CD/DVD-Drive and re-boot your computer.

5) Press any key while the ReactOS setup information screen (white text with on a black background).

6) ReactOS will boot from the LiveCD.

PS. If you don't get an option to press the key in #5 you need to set CD-ROM as first boot device in CMOS Setup before you try next time. (Jaix Bly Edit.)

Posts: 5
Joined: Fri Dec 30, 2005 5:36 am
Location: CA, USA


Post by TecSoft »

The most common problem is that you just burned the ISO as a data file on the CD. You have to burn the CD as a Image (In NERO)

Posts: 1
Joined: Wed Dec 28, 2005 1:27 pm

Post by Dreamora »

For me the Live Disc does not work at all. Burned it with Image burning on a RW (first using Nero Image burning and then Alcohol 120%).
When it tries to boot afterwards, it can't start anything and will after 5 errors just switch back to WinXP boot.
But this might perhaps have to do with the fact that I am using a notebook with Pentium-M Banias and Radeon Mobile 9700 ... or with the live disc not liking CD-RWs instead of a CD-R.

Posts: 81
Joined: Mon Oct 10, 2005 9:08 pm

Post by GaeTaN »

I would suggest you not to use the live cd at all, it seems it's not the same than normal react os, there's less driver, no usb support for example :(

Posts: 379
Joined: Sat Nov 27, 2004 5:43 am
Location: Australia

Post by Mrkaras »

yes the qemu version may be a better option but the LiveCD should work from a CD-RW disk, i have tried several live cds from CD-RW and have not had any problems caused by that.

Posts: 13
Joined: Mon Mar 13, 2006 12:42 am

Post by n4mwd »

I just ran the Live CD here for the first time. GREAT WORK GUYS!

It still has a ways to go, but it seems to have come a long way.

I did notice a few problems that other users of the LiveCD should be aware of. I ran it on a machine with Win98 already installed.

1. I think the LiveCD messed with the registry. Some of my settings in Win98 are messed up. Nothing major seen so far.

2. The GUI is really slow which could be the result of internal debugging code.


Posts: 2
Joined: Thu May 11, 2006 3:45 pm

Post by digimars »

I don't see how the LiveCD could have messed with your Windows registry settings. The purpose of the LiveCD is having ReactOS boot up in RAM. It won't touch your actual Windows OS on the HDD.

Posts: 1
Joined: Mon May 15, 2006 12:53 pm

using livecd with cordless keyboard & mouse

Post by tashammer »

using livecd with cordless keyboard & mouse - well, simply put, it won't work. Is it possible to get it to work or is it back to the ps2/usb keyboard? Dang, i only have cordless meeces.

Posts: 496
Joined: Tue Dec 27, 2005 12:43 am

Post by Matthias »

ReactOS currently doesn't really seen to support USB human interface devices (e. g. mice and keyboards). I can't install ReactOS because of that, we probably have to wait...

Posts: 170
Joined: Wed Dec 07, 2005 10:20 pm
Location: In front of my pc maybe?

Post by Nmn »

Nope. you need to jump into the current century and get a PS/2 mouse and keyboard with a computer with the ps/2 ports. Like this: ... 2-port.jpg

It will work with a PS/2 mouse and its on your pc back. So buy a new keyboard and a new mouse, its not expensive.

USB keyboards should be illegal. Well, not really, but they can cause alot of trouble.

Posts: 508
Joined: Mon Apr 25, 2005 12:46 pm

Post by ThePhysicist »

I am using cordless mouse and keyboard. PS2. works great. Or better worked great. I have problems with my keyboard with actual svn build. Windows-key works, but I can't type text.
Setup only completed because I copied some text from the GPL text and inserted it later (for username or machinename, not sure)

Posts: 2
Joined: Sat Jul 28, 2007 7:20 pm

I'm using a laptop

Post by callumh »

What if you use a laptop, such as me? There, there is no PS/2 ports for mouse and keyboards, just USB ones. Plus when I used QEMU, it worked for all of my USB human interface equipment such as mouse and keyboard (obviously) and my graphics tablet aswell. Enough of that though, I can't seem to get the ReactOS live cd to work at all, but the problem persists on furthur; I can't get any live cds to work. I've tried Ubuntu, Freespire, Damn Small Linux and now ReactOS. My laptop used to be able boot from all live cds, that was until I used the Ubuntu installation wizard which mashed up all of my partitions, so I deleted them all and installed a fresh copy of Windows, and now, I'm really not sure whats happened... The very problem that I'm experiencing is that when the loading screen of all of then operating systems on the live cds has finished doing its loading, my screen goes off - my hard disk doesn't, just my screen. I've pressed FN+F11 which turns my screen on and off and it turns on, but then just displays a creamish-colour background with lots of vertical black lines. Its not the disks that are causing this problem since I've tried them on another laptop. Anyone have any idea of whats happened? Any sort of support will be highly appriciated :wink: (I'm only 13 you see...)

Posts: 107
Joined: Mon Jan 22, 2007 10:23 pm

Post by aicommander »

First, the reason QEMU worked is because it emulates PS/2 hardware even if you have a USB keyboard or mouse.

Second, the display issue is probably caused by an incompatible display card. If it is not VESA 2.0 compatible the live cds won't work. What are the specs of your computer?

Posts: 2
Joined: Sat Jul 28, 2007 7:20 pm


Post by callumh »

Well it worked before using the SAME drivers, thats what I don't get.

Anyway, its a 1.49GHz Fujitsu Siemens L7310GW with 498MB of RAM. Default O/S is Windows XP Home.

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 1 guest