UNIATA Hangs when BIOS set to "sata ide combined mode"

Ask your support questions in here

Moderator: Moderator Team

Zombiedeth
Posts: 116
Joined: Fri Jun 27, 2014 9:01 am

UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Zombiedeth » Sun Dec 07, 2014 5:48 pm

I'm testing livecd-65574-dbg on real hardware

My configuration:
CPU: AMD Phenom II X6 3.2 GHz
Ram: 4GB
Motherboard: ASRock 880GM-LE
Video Card: Nvidia Geforce 6600 (PCIE)
Two SATA DVD-RW drives


With BIOS set to default setup UNIATA Hangs on boot.

Image

If i disable sata ide combined mode in the BIOS ReactOS does boot up but PCI and USB Drivers don't start up for some reason.

Image

hbelusca
Developer
Posts: 1125
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by hbelusca » Mon Dec 08, 2014 9:01 pm

Please report your problem on JIRA (otherwise no dev will see it).

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Webunny » Mon Dec 08, 2014 9:47 pm

hbelusca wrote:Please report your problem on JIRA (otherwise no dev will see it).
I've been wondering about that too, as part as an amelioration in how to handle (new) community members. Couldn't some construct be devised that makes it easier for people to just point out bugs, and make sure it gets noted, without going to the whole JIRA-process? Or get it into JIRA more easily?

I think it's worth pondering about, and if people have ideas, I'll be glad to listen to them.

Zombiedeth
Posts: 116
Joined: Fri Jun 27, 2014 9:01 am

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Zombiedeth » Tue Dec 09, 2014 4:07 am

hbelusca wrote:Please report your problem on JIRA (otherwise no dev will see it).
How do i create an JIRA account. It says to contact your JIRA administrators but how do i contact them.

oldman
Posts: 1071
Joined: Sun Dec 20, 2009 1:23 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by oldman » Tue Dec 09, 2014 9:33 am

Zombiedeth wrote:
hbelusca wrote:Please report your problem on JIRA (otherwise no dev will see it).
How do i create an JIRA account. It says to contact your JIRA administrators but how do i contact them.
Go to the jira page (https://jira.reactos.org/secure/Dashboard.jspa), there you should see a login form (there is also a login link in the top right of the page), just use your forum username and password.

When you have logged in, click on the "+ Create Issue" on the links bar at the top, which will open a Create Issue form.

Give a short description of the problem in Summary (this with be the title of the report).

Put your computer specification (or VM) in Environment.

In Description describe what happens and how to replicate the problem and the revision number where it occurred (include the down-load link to any software) .

If you get a debug log or take a photo, use the Browse button in Attachment to upload it.

That is all you need to fill in, leave the rest to the devs.


The "Not a member? To request an account, please contact your JIRA administrators." is for people who have not got an account; but you have, because you can post here in the forum!
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

Zombiedeth
Posts: 116
Joined: Fri Jun 27, 2014 9:01 am

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Zombiedeth » Tue Dec 09, 2014 3:39 pm

oldman wrote:
Zombiedeth wrote:
hbelusca wrote:Please report your problem on JIRA (otherwise no dev will see it).
How do i create an JIRA account. It says to contact your JIRA administrators but how do i contact them.
Go to the jira page (https://jira.reactos.org/secure/Dashboard.jspa), there you should see a login form (there is also a login link in the top right of the page), just use your forum username and password.

When you have logged in, click on the "+ Create Issue" on the links bar at the top, which will open a Create Issue form.

Give a short description of the problem in Summary (this with be the title of the report).

Put your computer specification (or VM) in Environment.

In Description describe what happens and how to replicate the problem and the revision number where it occurred (include the down-load link to any software) .

If you get a debug log or take a photo, use the Browse button in Attachment to upload it.

That is all you need to fill in, leave the rest to the devs.


The "Not a member? To request an account, please contact your JIRA administrators." is for people who have not got an account; but you have, because you can post here in the forum!
When i try and log in there using my forum username and pass i get Sorry, your username and password are incorrect - please try again.

oldman
Posts: 1071
Joined: Sun Dec 20, 2009 1:23 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by oldman » Tue Dec 09, 2014 5:48 pm

Zombiedeth wrote: When I try and log in there using my forum username and pass I get Sorry, your username and password are incorrect - please try again.
First, have you typed your username or password in the wrong case (upper or lower).

IF that was not the cause, then try this; go to the front page and log out, then log in again, then go to the jira page, there you should see that you are logged in. If that does not work, then I cannot help you any more
Last edited by oldman on Wed Dec 10, 2014 3:30 pm, edited 1 time in total.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

Zombiedeth
Posts: 116
Joined: Fri Jun 27, 2014 9:01 am

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Zombiedeth » Tue Dec 09, 2014 8:49 pm

oldman wrote:
Zombiedeth wrote: When I try and log in there using my forum username and pass I get Sorry, your username and password are incorrect - please try again.
First, have you typed your username or password in the wrong case (upper or lower).

IF that was not the cause, then try this; go to the front page and log, then log in again, then go to the jira page, there you should see that you are logged in. If that does not work, then I cannot help you any more
I cut and pasted the username and password so it is identical case.

I tried what you suggested on the front page then going to the jira page but i get the same error. Is it possible this problem only effects new users.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Z98 » Tue Dec 09, 2014 8:57 pm

The bridge is imperfect and we've had users whose accounts do not get mirrored over for a while. It usually fixes itself (there's no way to manually mirror the account without potentially breaking other things) so the current course of action is to be patient or ask one of the people who do have their accounts mirrored to create a but report for you.

Regarding the PCI driver, it does start up, but our current PCI driver doesn't properly enumerate everything so things that are over a bridge don't get seen.

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Webunny » Wed Dec 10, 2014 2:49 pm

Webunny wrote:
hbelusca wrote:Please report your problem on JIRA (otherwise no dev will see it).
I've been wondering about that too, as part as an amelioration in how to handle (new) community members. Couldn't some construct be devised that makes it easier for people to just point out bugs, and make sure it gets noted, without going to the whole JIRA-process? Or get it into JIRA more easily?

I think it's worth pondering about, and if people have ideas, I'll be glad to listen to them.
Z98 wrote:The bridge is imperfect and we've had users whose accounts do not get mirrored over for a while. It usually fixes itself (there's no way to manually mirror the account without potentially breaking other things) so the current course of action is to be patient or ask one of the people who do have their accounts mirrored to create a but report for you.

Regarding the PCI driver, it does start up, but our current PCI driver doesn't properly enumerate everything so things that are over a bridge don't get seen.
A butt report. :twisted:

Now, it does seem we're on the same wavgelength for once, though I would like to maybe extend it a bit. I would suggest to establish a semi-official system whereby routined people on the furom whom already have a password and already made JIRA-reports, could and would paste - in a structured processed way, the bug reports of newbies, or those who can't or won't go through the official JIRA process.

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Black_Fox » Wed Dec 10, 2014 6:44 pm

That generally sucks for realHW as these people don't remain around for long enough to test a fix - nobody else can test it. At least as far as newjoiners without working JIRA access.

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by Webunny » Wed Dec 10, 2014 8:16 pm

Black_Fox wrote:That generally sucks for realHW as these people don't remain around for long enough to test a fix - nobody else can test it. At least as far as newjoiners without working JIRA access.
Maybe, but maybe they leave because they don't get any response except 'go to JIRA'. I know what you're saying, and it's quite possible this will happen now and then, but then again, it might be useful in drawing in those newbies. Most of us start of as a lurker, then user - at which point the first bugreports come in. But in most cases they aren't really 'testers' yet at that point, in the sense that it's part of their routine. I think a system like I propose would help in pulling more newbies to go from the casual 'user-that-report-a-bug' to the more 'focussed tester'.
Last edited by Webunny on Sat Dec 13, 2014 9:05 pm, edited 1 time in total.

milon
Posts: 969
Joined: Sat Sep 05, 2009 9:26 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by milon » Sat Dec 13, 2014 3:51 pm

Webunny wrote:
A butt report. :twisted:

Now, it does seem we're on the same wavgelength for once, though I would like to maybe extend it a bit. I would suggest to establish a semi-official system whereby routined people on the furom whom already have a password and already made JIRA-reports, could and would paste - in a structured processed way, the bug reports of newbies, or those who can't or won't go through the official JIRA process.
I've actually been pondering the same thing. My Jira account is defunct, so I haven't been able to attempt/test anything. The two ideas I'm thinking about are a wiki page solution (easy, but good luck getting people to follow format) or a GUI app with menus etc that matches the inputs Jira asks for. The GUI could log in and post the bug for the user, or else email the data to someone who can. This is what I would attempt to code if my Jira account was working. This approach is technically better, but opens the door to all kinds of spam & duplicates.

Thoughts?

hbelusca
Developer
Posts: 1125
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by hbelusca » Sat Dec 13, 2014 4:35 pm

milon wrote:My Jira account is defunct [...]
How so? It's the same login/pwd as your reactos website account (and if there are problems, you can send a mail to ros-dev or go to IRC, and ask Pierre aka. HeisSpiter to fix that).

milon
Posts: 969
Joined: Sat Sep 05, 2009 9:26 pm

Re: UNIATA Hangs when BIOS set to "sata ide combined mode"

Post by milon » Sat Dec 13, 2014 4:55 pm

Oh. I misunderstood Z98's post then. I thought they couldn't be manually fixed, and the work-around was to have someone else post to JIRA on my behalf. Anyway, I'll email a dev then. Thanks! :)

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest