Installing ros, sans round shiny things

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Winterwing
Posts: 1
Joined: Thu Sep 29, 2005 3:00 pm

Installing ros, sans round shiny things

Post by Winterwing » Mon Dec 12, 2005 10:47 pm

Hi all. <-- lurker ^_^

So I have this old laptop with no usb and I want to install ros on it (its drive doesn't support RW discs and I can't spare CDRs or I would do it the easy way). It seems like there should be a way to start the installer from the local hd, right?

However, I haven't succeeded yet. Have tried so far (using 0.2.8 release):

1. Running the bootcd with ISOEmu, which crashes immediately with a General Protection Fault - I've tried both ieldr.exe from dos and ieldr from ntldr. Trying the livecd instead hangs immediately at a blank screen with a cursor.

2. Unpacked the bootcd into c:\ros028b and ran grub, using:

Code: Select all

kernel (hd0,0)/ros028b/loader/setupldr.sys
boot
Setup starts, then complains about missing txtsetup.sif and restarts the boot sequence. I suppose it looks for the install files in \reactos as opposed to ..\reactos, but I can't really check because I don't speak C.
Copying the contents of c:\ros028b\reactos to c:\reactos got it to finish booting, at which point it halts with inaccessible_boot_device.

3. Performing the above using the livecd in c:\ros028l results in freeldr happily appearing but apparently having no idea where ntoskrnl is.

Update:
Success! Apparently when I attempted to start the livecd, it was using a freeldr.ini from the root (c:\freeldr.ini) that the attempts at installing had put there along with a freeldr.sys. I changed the entry in freeldr.ini:

Code: Select all

; from
[ReactOS]
multi(0)disk(0)rdisk(0)partition(1)\ReactOS="ReactOS"

; to
[ReactOS]
multi(0)disk(0)rdisk(0)partition(1)\ros028l\ReactOS="ReactOS"
and then in grub:

Code: Select all

kernel (hd0,0)/freeldr.sys
boot
and the LiveCD install loaded right up. Joy! Unfortunately the vbe driver doesn't like the laptop's video adapter so the desktop is all neon. :( But now I'll move over a recent livecd from svn trunk and mess with booting it. I hope this helps somebody! ^^

Post Reply

Who is online

Users browsing this forum: DotBot [Crawler] and 1 guest