Bootloader help

Ask your support questions in here

Moderator: Moderator Team

Post Reply
reub2000
Posts: 100
Joined: Fri Dec 03, 2004 5:54 pm
Location: Evanston, IL, US

Bootloader help

Post by reub2000 » Mon Nov 21, 2005 12:41 am

The ros installer isn't writing the bootloader to my MBR. My MBR currently contains lilo.

I tried writing it to a floppy disc, but when booting the floppy, it said that it couldn't find the partition with ros.

ThePhysicist
Developer
Posts: 508
Joined: Mon Apr 25, 2005 12:46 pm

Post by ThePhysicist » Mon Nov 21, 2005 9:47 pm

ROS has to be on the primary partition on the primary drive, I think.
floppy boot works well for me, when I unplug my 1st hdd with windows xp.
I will soon change my hdds, put win xp bootloader on hdd1 (fat32) and boot from hdd2 (ntfs).
The same should work with Linux.

steveh
Posts: 271
Joined: Sat Dec 18, 2004 10:02 pm

possible reason for this?

Post by steveh » Mon Nov 21, 2005 10:50 pm

I have always had the same effect. At last stage of installation, the boot sector is not written and i must manually copy the sectos from "fat32.bin".
So happens with putting reactos on 1st primary active partition.

I think reactos installer is still irritated by the presence of 2 inactive and hidden NTFS partitions as primary 2 or primary 3, is it? :shock:

And what about logical NTFS partitions in the extended partition? Do they also fool the reactos installer?

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot], Google [Bot] and 1 guest