Page 1 of 1

Updating ReactOS manually

Posted: Thu Nov 10, 2005 9:09 pm
by auron
The next question is how to update the files manually to the latest build?

I'm using XP, so could I just move files over from the iso...opening the cab file and just copy files over to where they belong under d:\reactos?

Posted: Thu Nov 10, 2005 9:44 pm
by Ged
It's best to reinstall from scratch everytime, especially since the registry is changing quite lot at the moment.

can't use install

Posted: Fri Nov 11, 2005 12:06 am
by auron
should have posted this under my original thread.

the reason I need to do this manually is because I get an installation error when using the install cd. I can run a livecd, qemu fine. is it because I have a sata drive?

I'm using XP, so I took the 0.2.8 qemu image and copied it to the fat32 partition and used grub to boot it up. I would like to see the latest work now that I'm hooked.

since I can't use the install cd, what's the next best thing for installing the latest files?

Posted: Fri Nov 11, 2005 1:01 am
by GvG
So you can boot via Grub into FreeLdr and then into ReactOS, but you can't boot from the install CD? That's weird...

allocConsole() failed

Posted: Fri Nov 11, 2005 4:01 am
by auron
GvG wrote:So you can boot via Grub into FreeLdr and then into ReactOS, but you can't boot from the install CD? That's weird...
during install I get:

AllocConsole() failed (Status=0xc0000001)

so instead I did it manually. so how do update manually?!

Posted: Fri Nov 11, 2005 10:19 am
by GvG
Are you using a USB keyboard? USB keyboard is not supported yet and will result in the AllocConsole error message during install.

usb keyboard

Posted: Fri Nov 11, 2005 5:45 pm
by auron
GvG wrote:Are you using a USB keyboard? USB keyboard is not supported yet and will result in the AllocConsole error message during install.
i have a usb keyboard that has a ps/2 port adapter. My box has ports for the keyboard and mouse so I'm using them instead of usb. I did the same with the mouse (using the adapter).

Regardless, the keyboard and the mouse work with 0.2.8 after my manual install so all I want to do is upgrade to the latest release manually.

Re: can't use install

Posted: Sat Nov 12, 2005 2:18 pm
by Jaix
auron wrote:should have posted this under my original thread.
No, a new thread is apropriate, dual boot and manual installation is two completely different questions, else it will be hard to find later on.