react os Tidak bisa ???

Moderator: adezm

Post Reply
jeasz
Posts: 3
Joined: Sat Feb 10, 2007 3:52 pm

react os Tidak bisa ???

Post by jeasz » Sat Feb 10, 2007 5:39 pm

saya mencoba react os beberapa waktu lalu dan saya berharap akan berjalan lancar dan tidak ada masalah seperti yang telah saya simulasikan di Bochs 2.2, baik yang live maupun install, namun saya kecewa, reactos tidak berjalan lancar seperti yang telah saya simulasikan. setelah booting lewat cd react os mendeteksi ram saya, namun proses berhenti ketika muncul tulisan di sebelah atas layar "Reactos Release setup" lama saya tunggu tidak ada perubahan dan berakhir dengan restart dan booting dari hardisk! saya telah coba berkali-kali dan hasilnya sma! apa yang salah pada kejadian ini! saya menggunakan intel p4 2.3, ram 256, vga 32 dan hd 40, Os yang terinstal ada Xp sp 2 dan Astrumi!

adezm
Posts: 77
Joined: Sun May 28, 2006 8:01 pm
Location: Indonesia

Post by adezm » Mon Feb 12, 2007 6:45 pm

Coba naikkan ram di bochs ke 192 atau 224, idealnya 256.

adezm
Posts: 77
Joined: Sun May 28, 2006 8:01 pm
Location: Indonesia

Post by adezm » Mon Feb 12, 2007 10:23 pm

Saya menggunakan Bochs 2.3, ReactOS 0.3 dan berjalan dengan baik.
CATATAN: jika menggunakan Bochs anda harus memperhatikan suhu CPU anda karena ia akan terus naik bahkan mungkin melebihi 100 derajat. Ini tidak hanya untuk ReactOS saja tapi aplikasi lainnya juga. Hasilnya jangan terlalu diharapkan karena sangat lambat. Saya menyarankan untuk menggunakan QEMU, VMWare, atau Parallels.

Berikut konfigurasi bochs saya (bochsrc.bxrc):
#--- CONFIG_INTERFACE
config_interface: textconfig
#--- DISPLAY_LIBRARY
display_library: win32, options="legacyF12" # use F12 to toggle mouse
#--- ROMIMAGE:
romimage: file=$BXSHARE/BIOS-bochs-latest, address=0xf0000
#--- CPU:
cpu: count=1, ips=10000000, reset_on_triple_fault=1
#--- MEGS
megs: 256
#--- VGAROMIMAGE
vgaromimage: file=$BXSHARE/VGABIOS-lgpl-latest-cirrus
#--- VGA:
vga: extension=cirrus
#vga: extension=vbe
#--- FLOPPYA:
floppya: 1_44=/dev/fd0, status=inserted
#--- ATA0, ATA1, ATA2, ATA3
ata0: enabled=1, ioaddr1=0x1f0, ioaddr2=0x3f0, irq=14
ata1: enabled=1, ioaddr1=0x170, ioaddr2=0x370, irq=15
ata2: enabled=0, ioaddr1=0x1e8, ioaddr2=0x3e0, irq=11
ata3: enabled=0, ioaddr1=0x168, ioaddr2=0x360, irq=9
#--- ATA[0-3]-MASTER, ATA[0-3]-SLAVE
ata0-master: type=disk, path=c.img, mode=growing, cylinders=4161, heads=16, spt=63
ata0-slave: type=cdrom, path=reactos-03.iso, status=inserted
#--- BOOT:
boot: cdrom, disk
#--- CLOCK:
clock: sync=none, time0=local
#--- FLOPPY_BOOTSIG_CHECK: disabled=[0|1]
floppy_bootsig_check: disabled=0
#--- LOG:
log: bochsout.txt
#--- LOG CONTROLS
panic: action=ask
error: action=report
info: action=report
debug: action=ignore
#pass: action=fatal
#--- DEBUGGER_LOG:
debugger_log: -
#--- COM1, COM2, COM3, COM4:
#com1: enabled=1, mode=term, dev=/dev/ttyp9
#--- PARPORT1, PARPORT2:
parport1: enabled=1, file="parport.out"
#--- SB16:
#sb16: midimode=1, midi=/dev/midi00, wavemode=1, wave=/dev/dsp, loglevel=2, log=sb16.log, dmatimer=600000
#--- VGA_UPDATE_INTERVAL:
vga_update_interval: 300000
#--- KEYBOARD_SERIAL_DELAY:
keyboard_serial_delay: 250
#--- KEYBOARD_PASTE_DELAY:
keyboard_paste_delay: 100000
#--- MOUSE:
mouse: enabled=0
private_colormap: enabled=0
#--- ne2k: NE2000 compatible ethernet adapter
# ne2k: ioaddr=0x240, irq=9, mac=b0:c4:20:00:00:01, ethmod=win32, ethdev=MYCARD
#--- KEYBOARD_MAPPING:
keyboard_mapping: enabled=0, map=
#--- KEYBOARD_TYPE:
#keyboard_type: mf
#--- I440FXSUPPORT:
i440fxsupport: enabled=1
#--- USB1:
#usb1: enabled=1

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests