Woohoo! Scanning under ReactOS!

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Woohoo! Scanning under ReactOS!

Post by SomeGuy » Wed Nov 23, 2011 11:10 pm

I tried my old UMAX Austra 2200 scanner again (attached via SCSI card) and this time I actually got it to scan :shock: :D !

ReactOS stops with several failed asserts, but typing "cont" a couple of times and it happily goes on its way. (Filed bug http://www.reactos.org/bugzilla/show_bug.cgi?id=6684 about the failed assert)

Image

Bblaauw
Posts: 149
Joined: Mon Aug 03, 2009 12:59 am

Re: Woohoo! Scanning under ReactOS!

Post by Bblaauw » Thu Nov 24, 2011 1:34 am

That's a pleasant surprise, well done. Does it mean TWAIN works? Or is it just luck due to SCSI? I guess you can see if VUESCAN works next.

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Re: Woohoo! Scanning under ReactOS!

Post by SomeGuy » Thu Nov 24, 2011 2:12 am

This part of the driver doesn't use TWAIN at all. (It may have been designed for systems without) But supposedly TWAIN can call it somehow. The installer is 16-bit so I had to set things up manually so not everything is set up for it. Might give that a try though now.

betaluva
Posts: 424
Joined: Tue Dec 14, 2004 1:33 am
Location: Australia
Contact:

Re: Woohoo! Scanning under ReactOS!

Post by betaluva » Thu Nov 24, 2011 4:14 am

holy cow :o

fred02
Posts: 551
Joined: Thu Nov 22, 2007 5:54 pm

Re: Woohoo! Scanning under ReactOS!

Post by fred02 » Thu Nov 24, 2011 1:49 pm

SomeGuy wrote:attached via SCSI card
ROS support SCSI :?: :!: :shock:
What card model and what drivers?

Saibamen
Posts: 212
Joined: Mon Jul 19, 2010 11:19 am
Location: Poland
Contact:

Re: Woohoo! Scanning under ReactOS!

Post by Saibamen » Thu Nov 24, 2011 4:05 pm

@SomeGuy: please retest in revision 54484 or newer :)
ReactOS Forum Global Moderator
IT-Maniak.pl administrator

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Re: Woohoo! Scanning under ReactOS!

Post by SomeGuy » Sun Nov 27, 2011 3:10 am

fred02 wrote:What card model and what drivers?
It is an Adaptec AHA-2940U PCI SCSI card using the NT 4 driver file + the Win2k INF file to load it. The nice thing about this card is it has drivers for everything from DOS to Windows 7. (I probably should retest with the win2k/xp driver when I get a chance - that didn't work last time).

BTW, retried in r54497 and there was no difference.

fred02
Posts: 551
Joined: Thu Nov 22, 2007 5:54 pm

Re: Woohoo! Scanning under ReactOS!

Post by fred02 » Sun Nov 27, 2011 10:28 pm

SomeGuy wrote:It is an Adaptec AHA-2940U PCI SCSI card using the NT 4 driver file + the Win2k INF file to load it. The nice thing about this card is it has drivers for everything from DOS to Windows 7. (I probably should retest with the win2k/xp driver when I get a chance - that didn't work last time).
Cool, thanks for the info. Yes, the good thing with Adaptec card is that it they are an almost "defacto" standard, and so are supported almost universally, especially for their "mature" hardware.
This made me wander: is there a HCL for ROS?
And for your test go for w2k3 drivers directly. :D

jonaspm
Posts: 585
Joined: Mon Nov 21, 2011 1:10 am
Location: Mexico
Contact:

Re: Woohoo! Scanning under ReactOS!

Post by jonaspm » Tue Dec 06, 2011 5:50 am

as Saibamen said:

@SomeGuy: please retest in revision 54484 or newer
Image

PascalDragon
Posts: 123
Joined: Wed Aug 04, 2010 7:34 pm

Re: Woohoo! Scanning under ReactOS!

Post by PascalDragon » Tue Dec 06, 2011 10:23 am

jonaspm wrote:as Saibamen said:

@SomeGuy: please retest in revision 54484 or newer
SomeGuy wrote:BTW, retried in r54497 and there was no difference.
He already tried in a newer revision.

Regards,
Sven
Free Pascal compiler developer

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Re: Woohoo! Scanning under ReactOS!

Post by SomeGuy » Tue Dec 06, 2011 7:29 pm

Incidentally the other day I retested the Windows 2000 and Windows XP dirivers, and they appear to work too (in r54555).

They can see the SCSI scanner (with VistaScan loaded), and even read from a SCSI CD-ROM drive!

Oddly they won't recognize a SCSI Hard drive. Also tried a SCSI Zip drive but that didn't work.

fred02
Posts: 551
Joined: Thu Nov 22, 2007 5:54 pm

Re: Woohoo! Scanning under ReactOS!

Post by fred02 » Wed Dec 07, 2011 4:47 pm

SomeGuy wrote:Oddly they won't recognize a SCSI Hard drive. Also tried a SCSI Zip drive but that didn't work.
Odd indeed, especially since the CD-ROM is working. May be something is not quite finished in ROS drive/cache stack?

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot], Baidu [Spider] and 4 guests