[TESTING] Developer request: UNIATA

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

[TESTING] Developer request: UNIATA

Post by vicmarcal »

Developer Requesting a Test

As promised, some of the Devs testing requests will begin appearing in the Forum. This way we can coordinate better our efforts improving ReactOS project to move forward much faster.

Rafalh(a ReactOS Dev) and Alter( Uniata developer)have finished some improvements in UNIATA driver and seems really promising, they worked together to remove some of the ReactOS specific hacks so now SATA support should be much better. ReactOS project is trying to improve these kind of cooperation (ReactOS-3rParties) but we really need Testers to report feedback finding any regressions or new Hardware working.
So please, give a test to our new UNIATA driver(and its IDE compatibility too) and report any bug/problems you find when using it.Please tell us if the problem happens in current Uniata driver too(commun bug), or if it is just happening in the new one(regression).
We need the driver tested in Virtual Machines but also, if possible, in real hardware.
ReactOS is step by step moving towards a daily operating system. Keep helping us!

You fill find the link and the "Developer Request" in Testing Central . To test it, just replace the UNIATA driver with the new one provided or you can download an ISO with the new driver here(thanks Amine for the creation and Gabriel to tell)
If you have any doubt, ask here, the whole Community will try to solve it.
Thanks a lot.

PD: Instead filling the Wiki page, please report in this thread. As you know we are rewritting Testing Central so it's much better if you answer here.
Last edited by vicmarcal on Sun Apr 17, 2011 2:23 pm, edited 3 times in total.

gabrielilardi
Moderator Team
Posts: 873
Joined: Sat Sep 02, 2006 1:30 am
Location: Italy

Re: [TESTING] Developer request: UNIATA

Post by gabrielilardi »

Amine built the 51347 iso with the new driver. Download it here.

mrugiero
Posts: 482
Joined: Sun Feb 14, 2010 9:12 am

Re: [TESTING] Developer request: UNIATA

Post by mrugiero »

Sadly, my test boxes (which are a work in progress XD) has no SATA support, so my only way to help is by using a virtual machine. How do I configure it to use SATA?

sh4ring4n
Posts: 120
Joined: Thu Oct 30, 2008 2:05 am
Location: Canada
Contact:

Re: [TESTING] Developer request: UNIATA

Post by sh4ring4n »

Is there a patch file for it? I would like to compile dmesg support with it. :)
The cake is a lie!

hzlilx
Posts: 25
Joined: Sun Feb 13, 2011 1:06 pm

Re: [TESTING] Developer request: UNIATA

Post by hzlilx »

Also ask how to configue the virtual machine to use sata disks.

I downloaded the iso file and burn it to my cd-data-disk, but sadly after reboot my notebook pc it can't boot up at all, it seemed it can't be regarded as a bootable cd-data-disk.

rafalh
Developer
Posts: 5
Joined: Sat Apr 10, 2010 9:33 pm

Re: [TESTING] Developer request: UNIATA

Post by rafalh »

Hello,
Patches for upgrading UniATA are here: http://www.reactos.org/bugzilla/show_bug.cgi?id=6078
To be more specific only Alter is working on UniATA. I just point him out our problems with UniATA. Don't expect my work on this driver. Instead I will be continuously informing him about bugs and motivate him to work on them :)
BTW SATA doesn't work in VirtaulBox for me in ReactOS.

mrugiero
Posts: 482
Joined: Sun Feb 14, 2010 9:12 am

Re: [TESTING] Developer request: UNIATA

Post by mrugiero »

rafalh wrote:Hello,
Patches for upgrading UniATA are here: http://www.reactos.org/bugzilla/show_bug.cgi?id=6078
To be more specific only Alter is working on UniATA. I just point him out our problems with UniATA. Don't expect my work on this driver. Instead I will be continuously informing him about bugs and motivate him to work on them :)
BTW SATA doesn't work in VirtaulBox for me in ReactOS.
Your post reminded me there are many different virtual machines, and if I want someone to guide me on it, I need to be more specific XD
I use qemu, if anyone knows if it is possible to make it emulate SATA and how, I hope he/she will be happy to tell :)

EDIT: According to qemu's wiki, there is no mainstream support, but there is a patch which MIGHT add support (it is experimental).

rafalh
Developer
Posts: 5
Joined: Sat Apr 10, 2010 9:33 pm

Re: [TESTING] Developer request: UNIATA

Post by rafalh »

Test for regressions in IDE mode too. Timings has changed and there was many other changes so new issues can appear. I will not commit it before it's fully tested.

Mna.
Posts: 122
Joined: Thu Dec 02, 2010 3:13 pm

Re: [TESTING] Developer request: UNIATA

Post by Mna. »

Hi,

Tested on Real Hardware... But only the newest version, so can't say anything specific about regressions.
One the good machine (saying good for ROS I mean it is working with unchanged ROS) which have SATA2 - it works, well there are no Windows partitions there, but at least ROS recognized HDD and added two partitions in ObjectManager (into /device/Harddrive/) (ICH7 here)

On 'bad' machine as uniata.sys hadn't recodnized my IDE HDD, and LIveCD run is failed, so it is the same now. Nothing changed. BugCheck 0x0000069, means no booting device (ICH4 here)
***

But well, I noticed good mark in that the "good" machine could have installed ReactOS! ...future is coming! :)
==
But I can't run this promising patch on really interesting machine with SATA2 due to serious bug (6031) with RAM recognition.
Are any possibility to call back the ARM3 memory manager developers to review it?

mrugiero
Posts: 482
Joined: Sun Feb 14, 2010 9:12 am

Re: [TESTING] Developer request: UNIATA

Post by mrugiero »

rafalh wrote:Test for regressions in IDE mode too. Timings has changed and there was many other changes so new issues can appear. I will not commit it before it's fully tested.
If IDE is useful, next week (in about 6 hours I will be in a neightbor country in a meeting of chemistry students, until next monday) I'll try it.

hzlilx
Posts: 25
Joined: Sun Feb 13, 2011 1:06 pm

Re: [TESTING] Developer request: UNIATA

Post by hzlilx »

I burn the iso to cd but it can't boot. I read FAQ it tell me SATA cd driver is not surpport, maybe this is the reason.

so, I make a grub4dos bootable usb disk, and use grub to boot livecd iso file. The livecd iso file boot start success, load uniata.sys and other xxxx.sys ok, but, it print "try init 8086 3629" and return STATUS_DEVICE_DOES_NOT_EXIST, uniata can't find any disk and then system hang.

further infomation, windows xp device manager tell me my notebook pc is AUSU i7 cpu Q720@1.6GHz, disk controler is Intel(R) 5 serials/3400 Serials chipest Family 4 Port SATA AHCI controller - 3B29, windows xp tell me the driver file is iaStor7.sys.

roytam1
Posts: 43
Joined: Thu Oct 06, 2005 11:14 am

Re: [TESTING] Developer request: UNIATA

Post by roytam1 »

hzlilx wrote:I burn the iso to cd but it can't boot. I read FAQ it tell me SATA cd driver is not surpport, maybe this is the reason.

so, I make a grub4dos bootable usb disk, and use grub to boot livecd iso file. The livecd iso file boot start success, load uniata.sys and other xxxx.sys ok, but, it print "try init 8086 3629" and return STATUS_DEVICE_DOES_NOT_EXIST, uniata can't find any disk and then system hang.

further infomation, windows xp device manager tell me my notebook pc is AUSU i7 cpu Q720@1.6GHz, disk controler is Intel(R) 5 serials/3400 Serials chipest Family 4 Port SATA AHCI controller - 3B29, windows xp tell me the driver file is iaStor7.sys.
AHCI is not yet supported by uniata.sys

hzlilx
Posts: 25
Joined: Sun Feb 13, 2011 1:06 pm

Re: [TESTING] Developer request: UNIATA

Post by hzlilx »

roytam1 wrote:
hzlilx wrote:I burn the iso to cd but it can't boot. I read FAQ it tell me SATA cd driver is not surpport, maybe this is the reason.

so, I make a grub4dos bootable usb disk, and use grub to boot livecd iso file. The livecd iso file boot start success, load uniata.sys and other xxxx.sys ok, but, it print "try init 8086 3629" and return STATUS_DEVICE_DOES_NOT_EXIST, uniata can't find any disk and then system hang.

further infomation, windows xp device manager tell me my notebook pc is AUSU i7 cpu Q720@1.6GHz, disk controler is Intel(R) 5 serials/3400 Serials chipest Family 4 Port SATA AHCI controller - 3B29, windows xp tell me the driver file is iaStor7.sys.
AHCI is not yet supported by uniata.sys
Yeah, thank you very much. I dig into source code and find a bug. In my case, when calling SpiGetPciConfigData(), my SATA harddisk is in PCI 0, device 31, function 2, but, when #2353 loop search "our device" with PCI 0, device 31, function 1, PciConfig.VendorID got PCI_INVALID_VENDORID, so it break and have no chance to test PCI 0, device 31, function 2. This lead to ScsiPortInitialize() fail.

I change #2370 to:
if ((PciConfig.VendorID == PCI_INVALID_VENDORID) && (DeviceNumber != 31))

Now it create scsiport success but have other error, id_init.cpp #1074 show me "AHCI excluded" and return STATUS_UNSUCCESSFUL;

#2353 for (FunctionNumber = NextSlotNumber->u.bits.FunctionNumber; FunctionNumber < PCI_MAX_FUNCTION; FunctionNumber++)
#2354 {

#2368 /* If result is PCI_INVALID_VENDORID, then this device has no more
#2369 "Functions" */
#2370 if (PciConfig.VendorID == PCI_INVALID_VENDORID)
#2371 break;

vicmarcal
Test Team
Posts: 2732
Joined: Mon Jul 07, 2008 12:35 pm

Re: [TESTING] Developer request: UNIATA

Post by vicmarcal »

Could you create a patch?I'll give it to rafalh or alter to review it :)

hzlilx
Posts: 25
Joined: Sun Feb 13, 2011 1:06 pm

Re: [TESTING] Developer request: UNIATA

Post by hzlilx »

I think my way is not the right way. I am doing some work, trying to make it clear, but it is very hardware specify, I think it may beyond my ability.

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 9 guests